520

 Instalación y actualización
> Mensaje de error oleacc.dll no encontrada.
> ¿ Instalador o binarios ?
> ¿ Cómo puedo mantener mis preferencias/descargas cuando actualizo a una nueva versión del eMule ?
> Actualizando desde eDonkey/Overnet a eMule manteniendo las descargas.
¿ Qué influencia tiene el sistema operativo que tenga instalado?
eMule corre en todas las versiones de windows posteriores a W95. Una aplicación P2P utiliza muchas conexiones de red, lo cual implica que el sistema debe tener una implementación estable de los servicios de red. Windows 98 y ME tienen una pobre implementación de los mencionados servicios, empobreciendo el rendimiento de eMule.
Sistemas operativos más recientes como Windows 2000 o XP están mejor equipados para trabajar en red. No utilice los parches del registro de Windows 98 que le prometen incrementar las conexiones posibles. No funcionan correctamente y pueden causar inestabilidad en su sistema.
Arriba
Mensaje de error oleacc.dll no encontrada.
Este mensaje de error puede aparecer al iniciar el eMule en una máquina con Windows 98. La dll no encontrada está en una actualización de sistema de Windows 98 de Microsoft.
Arriba
¿ Instalador o binarios ?
La versión con instalador está indicada para una instalación limpia del eMule, puesto que contiene todos los archivos y la documentación necesaria. Ejecútelo y el instalador le guiará el resto del proceso.
La distribución de la versión de los binarios se realiza en un solo archivo. El contenido debe ser extraído en el directorio deseado. Es lo indicado a la hora de actualizar la versión del eMule.
Arriba
¿ Cómo puedo mantener mis preferencias/descargas cuando actualizo a una nueva versión del eMule ?
Extraiga o instale una nueva versión del eMule en el mismo directorio en el que estaba instalada la versión antigua. Sólo eMule.exe y algunos archivos inherentes al mismo (no contienen datos de usuario) serán reemplazados. Todas las preferencias, así como las descargas se mantendrán. También se puede realizar una copia de seguridad de la carpeta config que se encuentra dentro de la carpeta en la que esté instalado el eMule. ¡ Se debe cerrar el eMule antes de actualizar a una versión nueva! Para mantener las preferencias existentes, simplemente pulse cancelar cuando aparezca el asistente.
Arriba

Actualizando desde eDonkey/Overnet a eMule manteniendo las descargas.
Las versiones de eDonkey anteriores a la .47 utilizan un sistema de partes compatible con el eMule, sin embargo las posteriores a la .47 dividen las descargas temporales en muchos archivos individuales. Para las versiones antiguas de eDonkey, simplemente indique en preferencias como directorio temporal el mismo que utilizaba eDonkey, o mueva los archivos .met y .part del directorio temporal del eDonkey al directorio temporal que utilice eMule. Para hacer esto, eMule tiene que estar apagado. Las nuevas versiones de eDonkey/Overnet, utilizan el sistema de división del archivo de partes. Una opción de "viejo estilo" está disponible en esos clientes, que hace que las descargas temporales se almacenen en un solo archivo. El archivo part.met todavía sigue estando en un formato nuevo e incompatible. eMule v0.30c introdujo una función de conversión para importar descargas de otros programas a sus descargas de eMule. Esta función importa tanto el formato clásico (eMule, eDonkey <=.47) como el formato dividido como el formato "viejo estilo" de clientes eDonkey/Overnet >.47. Los formatos no-eMule serán convertidos al formato eMule. Puede acceder a la función para importar tanto desde la combinación de teclas rápidas (Alt+X) como desde el icono de Herramientas. Todo lo que tiene que hacer aquí es especificar una carpeta que contenga los archivos de partes (.part). eMule intentará convertir automáticamente los archivos de partes y los añadirá en tiempo de ejecución a sus descargas.

Arriba

28.08.2004 7:45


521

 Servidor, conexión e ID
> ¿Dónde conseguir una lista de servidores?
> ¿Cuál es el mejor servidor y el más rápido?
> ¿Cada cuanto tiempo debería actualizar mi lista de servidores?
> ¿Por qué eMule no se conecta?
> ¿Por qué tengo LowID?
> eMule siempre se desconecta de los servidores.
¿Cómo conectar a Kademlia?
eMule intenta conectar automáticamente a la red Kademlia a partir de cualquier cliente compatible conocido que encuentre. Si emule no se conecta, pulsa Autoarranque de clientes conocidos que está situado en la pestaña superior Kad, después conecta a un servidor y comienza la descarga. Kademlia se conectará en breve espacio de tiempo.
Arriba
¿Dónde conseguir una lista de servidores?
http://ed2k.has.it – Pulsa el enlace para poder añadir a eMule una lista de servidores.
Arriba
¿Cuál es el mejor servidor y el más rápido?
No existe ni el servidor más rápido ni el mejor. Los servidores se usan para conectarse a la red y buscar archivos y fuentes. eMule realiza su búsqueda haciendo peticiones a todos los servidores que contenga su server list y usando la Búsqueda Global se fuerza a todos los servidores a responder a la búsqueda de resultados.
eMule también intercambia fuentes con distintos clientes eMule, de esta forma el intercambio de fuentes es mucho más rápido.
Arriba
¿Cada cuanto tiempo debería actualizar mi lista de servidores?
En las sesiones de descargas o si usas frecuentemente eMule no tienes la necesidad de actualizar la lista de servidores puesto que eMule tiene activado por defecto la actualización de lista de servidores (Preferencias -> Servidor -> Actualizar lista de servidores al conectar a un cliente), (Preferencias->Servidor->Actualizar lista de servidores al conectar a un servidor)
Arriba
¿Por qué eMule no se conecta?
Puede llevar un tiempo el conectarse a un servidor, ya que éste puede estar caído o no responder. Si eMule no se conecta en absoluto asegúrate de que tienes una lista de servidores actualizada y de que ningún tipo de software tipo firewall, router, Acceso telefónico a redes o similar esté bloqueando el trafico a eMule. Comprueba también el valor en Preferencias -> Servidor -> Autoconectar solo a servidores fijos. Si está marcado y no tienes un staticservers.dat con servidores válidos eMule será incapaz de conectar
Arriba
¿Por qué tengo LowID?
eMule sólo funcionará totalmente si estos puertos están abiertos para la conexión:
• 4662 TCP (Server low ID)
• 4672 UDP (Kademlia firewalled)
• 4711 TCP (no Webinterface accesible)
Pueden existir diferentes motivos por los que estos puertos puedan estar bloqueados:
• Firewalls - el incluído en Windows XP (ICF) también (¡el WinXp SP2 lo habilita por defecto!)
• Routers
• El software de marcación de algunos Proveedores de Acceso a Internet.
• El software de compartición de conexión/ El software del router.
• Redes con cualquier tipo de conexión NAT.
• Puertos bloqueados por el Proveedores de Acceso a Internet.
Comprueba el software y hardware que tengas instalado para configurar correctamente cualquier firewall o router y permitir la conexiones entrantes a dichos puertos. También puedes probar a cambiar los puertos a los siguientes: 6666, 80 ó 20. Más información en los capítulos sobre Firewalls y Routers.
Arriba
eMule siempre se desconecta de los servidores
Existen algunas razones por las cuales eMule puede desconectarse de un servidor:
• Demasiados archivos en la lista de descargas (sólo versiones anteriores a v0.30a).
• Demasiados archivos compartidos (sólo versiones anteriores a la v0.29a).
• Problemas en el servidor.
• Problema desconexión de red.
eMule habitualmente se vuelve a conectar al perder la conexión con el servidor. Éste no es ningún problema grave.
Arriba

28.08.2004 7:50


522

 Configuración de velocidad
> Cosas que influyen en las descargas.
> ¿Qué configuración es la mejor?
> ¿Cómo puedo incrementar la velocidad de mis descargas?
> ¿Qué ratios de descarga puedo esperar?
> ¿Cómo de grande debería de ser la cola de espera?
¿Puedo iniciar el eMule, añadir los últimos videos caseros y verlos 5 min. más tarde?
No, seguramente no. eMule suele usarse para descargar archivos bastante grandes, por lo que la carga de la red suele estar casi siempre al 100 %. Hay una simple regla que dice: "La suma de todas las subidas a la red = la suma de todas las descargas". Los archivos largos requieren mucho tráfico de subida y considerando la media de la velocidad de subida que ofrecen los ISP's de hoy, es natural que las descargas se tomen su tiempo. eMule es un programa orientado a compartir archivos con todos los usuarios de la red, no para intercambiarlos entre unos pocos [o unos pocos colegas]. Si aprecias esta diferencia eMule está hecho para ti.
Arriba
Cosas que influyen en las descargas.
Hay algunos factores que influyen directamente en la velocidad de descarga:
• La configuración de eMule.
• ID Alta.
• Duración de la sesión eMule
• Número de fuentes para una descarga.
• Disponibilidad de las partes simples (chunks).
• Popularidad de la descarga
Malos ajustes en la configuración del eMule (límites equivocados, demasiadas conexiones), ID baja y sesiones de duración demasiado corta tienen un impacto negativo en la velocidad de descarga. Los archivos muy populares (lanzamientos recientes) y los que tienen un número bajo de fuentes o una mala distribución de las partes (chunks) también serán causa de bajas velocidades de descarga.
Arriba

¿Qué configuración es la mejor?
No hay configuraciones óptimas para eMule, puesto que depende en gran medida del tipo y de la velocidad de la conexión a internet y del sistema operativo instalado. Siempre se debería utilizar el asistente para conseguir una configuración básica buena. Lo más importante es que se introduzcan los valores correctos para la conexión a internet y el sistema operativo.

Una buena configuración para una conexión ADSL 256/128 debería de ser la siguiente:

Windows XP
 | Capacidad descarga: 32 (= 256 / 8)
 | Capacidad de subida: 16 (= 128 / 8)
 | Lím. de descarga: ninguno (quitar la marca de la casilla de verificación)
 | Lím. de subida: 12
 | Máx. fuentes/archivo - Límite máximo: 500
 | Límites de conexión - Conexiones máximas: 400
 | Nuevas conexiones máx. / 5seg.: 30 (en Preferencias -> Opciones adicionales)
 | Descargar entre 6 y 20 archivos a la vez.
Windows 98 / ME
 | Capacidad descarga: 32 (= 256 / 8)
 | Capacidad de subida: 16 (= 128 / 8)
 | Lím. de descarga: ninguno (quitar la marca de la casilla de verificación)
 | Lím. de subida: 12
 | Máx. fuentes/archivo - Límite máximo: 300
 | Límites de conexión - Conexiones máximas: 200
 | Nuevas conexiones máx. / 5seg.: 20 (en Preferencias -> Opciones adicionales)
 | No descargar más de 12 archivos a la vez

Si se utiliza el USS (Upload Sense Speed) en Preferencias -> Opciones adicionales entonces lo mejor es quitar todas lar marcas de las casillas de verificación de los límites y dejar al eMule que controle el ancho de banda. Esto asegurará que se consiga la máxima velocidad de subida para obtener créditos rápidamente. Otras aplicaciones como juegos on-line o navegar por internet pueden ralentizarse.
Arriba
¿Cómo puedo incrementar la velocidad de mis descargas?
Aparte de una buena configuración, sólo los archivos que se pretenden descargar deciden la velocidad. Para conseguir una buena media observe lo siguiente:
• eMule debe estar conectado por largo tiempo. Cuanto más mejor. Si se puede siempre.
• No descargue un solo archivo.
• Intente descargar archivos con 150 fuentes como mínimo.
• No intente descargar los últimos lanzamientos. Al menos no rápidamente.
• Suba todo lo que pueda para ganar créditos.
• No se quede como un tonto mirando al eMule. No le gusta que lo miren.
Arriba
¿Qué ratios de descarga puedo esperar?
Si se tiene un eMule bien configurado con algunos archivos buenos, normalmente se obtendrán velocidades de entre 10 kB/s y 20 kB/s después de un período de tiempo necesario para el arranque del mismo. Habrá veces en que la velocidad será mucho menor, pero también habrá otras en las que se llegará hasta 2 ó 2,5 veces estos valores (todos los valores son para la ADSL del ejemplo del punto anterior: 256/128).
Arriba

¿Cómo de grande debería de ser la cola de espera?
Una cola de espera grande aumenta la efectividad del sistema de créditos. Valores muy altos del QR no significan que nunca se podrá descargar de esas fuentes, puesto que hay muchos modificadores que recortarán el tiempo de espera.

Arriba

28.08.2004 7:53


523

 Créditos
> ¿Dónde puedo ver mis créditos?
> He perdido/borrado mi archivo clients.met. ¿He perdido mis créditos?
> ¿Son seguros los créditos?
> La única forma de perder los créditos.
Créditos. ¿Qué son y para qué conseguirlos?
Los créditos recompensan a los usuarios que suben datos a la red. La cantidad transferida de datos determina la cantidad de créditos obtenidos. Los créditos no son globales, es decir sólo pueden ser usados con aquel cliente que nos los ha otorgado.
Son el modificador más alto cuando se calcula la posición y el progreso en la cola de otro cliente. Cuantos más créditos se tengan más rápido se avanzará.
Arriba
¿Dónde puedo ver mis créditos?
Para prevenir manipulaciones en la cantidad, los créditos no se almacenan localmente en el disco duro, sino en el disco duro de los otros clientes. No es posible hacer un recuento de los créditos propios.
Arriba
He perdido/borrado mi archivo clients.met. ¿He perdido mis créditos?
Perder este archivo no significa que sus créditos se hayan perdido, pero sí se pierden todos los créditos de la gente que ha dado algo a su eMule. Hay una copia del archivo clients.met (clients.met.bak), con lo que debería ser posible restaurarlo, renombrando la copia (clients.met.bak) a clients.met.
Arriba
¿Son seguros los créditos?
eMule utiliza un método de clave de "apretón de manos" para asegurarse de que los créditos pertenecen a ese cliente en concreto. Los créditos almacenados en los demás clientes sólo podrán utilizarse después de una autentificación correcta
Arriba
La única forma de perder los créditos.
Como se describió en el punto anterior, los créditos van emparejados con la identificación segura del usuario. La clave secreta para esta identificación es calculada a partir de información almacenada en los archivos preferentes.dat y criptkey.dat. Si se pierde uno de estos dos archivos no podremos demostrar que somos los propietarios de los créditos.
Si se pierde solamente el archivo criptkey.dat se deberá borrar obligatoriamente el archivo preferentes.dat.
Arriba

28.08.2004 7:57


524

 Descargas y archivos compartidos
> ¿Qué significa esa barra de colores en la ventana de tráfico?
> ¿Qué son los valores xx/yy+aa(zz) de la columna fuentes?
> ¿Qué significa QR?
> ¿Por qué mis fuentes aparecen como "se le ha pedido otro archivo" (A4AF)?
> Cómo descargar en orden alfabético
> ¿Qué significa demasiadas conexiones?
> ¿Puedo cambiar el nombre de las descargas?
> ¿Qué significan las exclamaciones rojas y verdes?
> ¿Cómo puedo comentar/evaluar un archivo?
> ¿Cómo puedo saber si un archivo es un fake (falsificación)?
> Una o más descargas nunca se completan.
> Mis descargas se completan, pero se muestran erróneas.
> Mis descargas se completan, pero no aparecen en incoming.
> La carpeta para los temporales es muy grande ¿Puedo borrarla?
> ¿Cómo puedo borrar/dejar de compartir archivos?

Mis descargas han desaparecido de la lista.
Esto puede ocurrir después de un cuelgue del eMule, o después de actualizar a una versión nueva.

• | En la carpeta donde esté instalado eMule se crea un archivo llamado downloads.txt. Contiene los nombres de cada uno de los archivos de la lista de descargas junto con su e-link y su archivo .part asociado. Se puede volver a descargar el archivo usando el e-link o intentar reestablecer el enlace roto entre el archivo .part y el .part.met con herramientas como MetMedic o DonkeyDoctor.
• | Compruebe en Preferencias -> Directorios que la ruta indicada para los archivos temporales sea la correcta.
• | Sustituya los archivos .part.met del directorio temporal con sus copias de seguridad: .part.met.BAK.
• | Consulte el capítulo Problemas - Descargas de esta ayuda.
Arriba
¿Qué significa esa barra de colores en la ventana de tráfico?
Los colores muestran la disponibilidad de las partes de los archivos. Rojo significa que no hay ninguna fuente disponible para esa parte. Lea este mensaje para más detalles.
Arriba
¿Qué son los valores xx/yy+aa(zz) de la columna fuentes?
Los valores informan del número de fuentes encontradas para una descarga:
• xx - Número de fuentes útiles.
• yy - Número total de fuentes.
• + aa - Número de "se le ha pedido otro archivo (A4AF)" (sólo se muestra con los controles avanzados activos).
• zz - Fuentes de las que estamos descargando.
Arriba
¿Qué significa QR?
QR es una abreviatura de "Queue Rank" (posición en la cola), y es la posición en la cola de otro cliente. Con un QR menor de 20 es de esperar que esa fuente empiece a transferir pronto. Los créditos ayudan a avanzar más rápido en las colas.
La posición en la cola no se pierde en caso de cambio de IP o si se cierra eMule durante poco tiempo (5-10 min.).
Arriba
¿Por qué mis fuentes aparecen como "se le ha pedido otro archivo" (A4AF)?
eMule sólo puede ocupar una posición de transferencia en la cola de otro cliente. Si otro usuario tiene más de uno de los archivos que se pretenden descargar, eMule será puesto en cola para uno de ellos y cuando termine la descarga cambiará al otro. La misma fuente aparecerá como "se le ha pedido otro archivo" en la descarga que no haya podido añadirse a la cola. La función "intercambiar A4AF a este archivo", accesible haciendo clic con el botón secundario encima de un cliente que esté como "se le ha pedido otro archivo", le permite asignar manualmente las fuentes "se le ha pedido otro archivo" a la descarga deseada (esta función sólo estará disponible si está activada la opción de Mostrar controles avanzados). Ver manejo de fuentes para más detalles.
Arriba
Cómo descargar en orden alfabético
Es posible descargar archivos en orden alfabético para usar las fuentes encontradas de la forma más eficiente. Comprueba que los archivos están nombrados alfabéticamente de la forma que quieres descargar (pulsa F2 para renombrar), crea una categoría para ellos y muévelos a ésta. En el menú de contexto de la categoría selecciona Descargar en orden alfabético. Los controles avanzados deben de estar activados para que esto funcione. Ver manejo de fuentes para más detalles.
Arriba
¿Qué significa demasiadas conexiones?
Ese estado de la fuente significa que hay que procesar más fuentes que conexiones se pueden establecer en ese momento. Normalmente aparece cuando demasiados archivos han sido añadidos a la lista de descargas o el límite máximo de fuentes por archivo ha sido establecido muy alto.
Arriba
¿Puedo cambiar el nombre de las descargas?
Se puede cambiar el nombre de las descargas, puesto que no se identifican por el nombre, sino por un hash único. Seleccione un archivo y haga clic con el botón derecho del ratón y seleccione Mostrar comentarios -> Nombre en el menú emergente. Mantenga las extensiones de los archivos cuando cambie el nombre en la solapa nombre de archivo.
Arriba
¿Qué significan las exclamaciones rojas y verdes?
Los signos de exclamación son un indicador de que la descarga ha sido comentada o evaluada por algún usuario..
• Verde: evaluación positiva.
• Rojo: evaluación negativa.
Arriba
¿Cómo puedo comentar/evaluar un archivo?
Se pueden añadir comentarios y evaluaciones desde la ventana compartidos (accesible a través del icono compartidos). Pulse el botón central del ratón o con el botón derecho encima del archivo compartido que desee comentar y seleccione Cambiar el comentario a este archivo. No escriba tonterías aquí. Limítese a poner comentarios útiles para los demás.
Arriba
¿Cómo puedo saber si un archivo es un fake (falsificación)?
Se pueden reconocer fácilmente los fakes mirando detalladamente los nombres de los archivos encontrados. Pulse con el botón derecho en la descarga deseada y seleccione Mostrar comentarios -> Nombre en el menú emergente. Vaya a la pestaña nombre de archivo y allí verá todos los nombres que se han encontrado para ese archivo (recuerde que los archivos se identifican por el hash, no por el nombre). Si los nombres difieren mucho o son contradictorios probablemente sea un fake. Los resultados de las búsquedas que contengan un + al estilo explorador de windows es porque se han encontrado diferentes nombres para ese archivo.
Arriba
Una o más descargas nunca se completan.
No hay fuentes que tengan el archivo completo: Si la barra de progreso de la descarga muestra partes en rojo que nunca se vuelven azules y a todas las fuentes encontradas les falta la misma parte, el archivo probablemente está muerto y nunca podrá completarse. La columna última comprobación completa en la ventana de transferencias muestra la fecha en la que todas las partes del archivo estuvieron disponibles. Lo más recomendable es cancelar ese archivo e intentar buscar otro e-link distinto.
Descarga corrupta: En la ventana de servidores existe una sub-ventana de log, en la que se muestra una entrada si una parte corrupta ha sido recibida. Si siempre se obtiene la misma parte corrupta es posible que esa descarga esté completamente corrupta (ocurre muy raras veces). No obstante, eMule intentará volver a descargar de nuevo esa parte hasta que complete el archivo.
Arriba
Mis descargas se completan, pero se muestran erróneas.
Este error suele aparecer cuando la carpeta de los archivos temporales y la de incoming están en discos o particiones distintas. eMule no puede terminar la descarga porque no hay sitio suficiente en el disco de la carpeta incoming.
Arriba
Mis descargas se completan, pero no aparecen en incoming.
Esto puede ser debido a que no existe suficiente espacio libre en el disco donde se encuentre la carpeta incoming. Si a pesar de tener espacio suficiente se termina una descarga pero no aparece en el directorio de incoming, se puede realizar el proceso manualmente. Primero mire en detalles del archivo y asegúrese de que el archivo está realmente completado comparando el tamaño. También mire el nombre del archivo .part y copie el nombre del archivo al portapapeles. En el explorador de windows, navegue hasta el directorio temporal y mueva el .part al directorio de incoming. Renombre el archivo a su nombre final usando el nombre que se había copiado al portapapeles, teniendo en cuenta la extensión del mismo. La mayoría de las veces éstos archivos no tendrán un archivo .part.met asociado.
Arriba

La carpeta para los temporales es muy grande ¿Puedo borrarla?
Esta carpeta contiene todas las descargas que no se han terminado. ¡Borrar esos archivos supondrá eliminar las descargas actuales! Debido al sistema de transferencia usado en eMule, puede ocurrir que el espacio necesario para la descarga completa sea ocupado incluso aunque sólo se hayan descargado unos pocos kilobytes.
Arriba

¿Cómo puedo borrar/dejar de compartir archivos?
eMule comparte archivos tan pronto como:

• | Una parte de una descarga (chunk) ha sido completada y chequeada contra errores.
• | Hay archivos en la carpeta incoming o en cualquier directorio marcado como compartido en preferencias->directorios->Directorios compartidos.

Para dejar de compartir un archivo se deberá quitar del directorio incoming o de los directorios marcados como compartidos. En la ventana de compartidos también se pueden eliminar archivos pulsando con el botón derecho y seleccionando Borrar en el menú emergente.
Arriba

28.08.2004 8:18


525

 Usando eMule
> ¿Cómo puedo añadir un amigo?
> Cómo establecer puesto reservado para amigo.
> ¿Cómo puedo limpiar el historial de autocompletado de las búsquedas?
> ¿Cuál es el significado de los iconos delante de las fuentes, etc.?
> ¿Puedo echar o bloquear a otros usuarios?
> ¿Por qué sólo obtengo 201 resultados en una búsqueda?
> ¿Debería poner todos mis archivos en prioridad alta o lanzamiento?
Consejos generales.
Muchas de las funciones de eMule sólo están disponibles a través del menú contextual, el cual emerge al pulsar el botón secundario del ratón sobre muchos y diferentes objetos. También otras áreas y objetos reaccionan a la doble pulsación o incluso a pulsaciones del botón central del ratón. Un menú rápido aparece al pulsar la combinación Alt+x. Pruebe las distintas combinaciones. Es muy útil.
Arriba
¿Cómo puedo añadir un amigo?
Los amigos se gestionan en la pantalla principal de Mensajes. Para añadir un amigo, se pulsa con el botón derecho en la lista de amigos y se elige añadir a lista de amigos. Será necesaria la siguiente información:
• Dirección IP – obligatoria. Se tiene que disponer de ella. Simplemente hay que preguntársela a quien va a ser nuestro amigo.
• Puerto (el que utiliza el futuro amigo en su eMule) – generalmente el 4662; también obligatorio.
• Nombre – no es obligatorio. Se puede poner cualquiera.
Otra forma de añadir amigos es pulsar con el botón derecho del ratón encima de una fuente en la ventana principal de tráfico y elegir añadir a lista de amigos. eMule rellenará por sí mismo la información necesaria.
Arriba
Cómo establecer puesto reservado para amigo.
Pulsar con el botón derecho encima de cualquier amigo de la lista ofrece la opción de asignarle un puesto de transferencia. Éste se activará tan pronto haya alguno disponible, permitiendo al amigo iniciar la descarga. Los puestos de amigo no incrementan las subidas hacia ellos, sino que son puestos de transferencia normales.
Arriba
¿Cómo puedo limpiar el historial de autocompletado de las búsquedas?
En la ventana de búsquedas, pulse con el botón izquierdo del ratón dentro del campo de búsqueda. Luego pulse Control o Alt. + Supr. (valen las dos combinaciones Control+Supr y Alt+Supr.).
Arriba
¿Cuál es el significado de los iconos delante de las fuentes, etc.?
Para una correcta comprensión del significado de los iconos se debe consultar el capítulo Iconos de esta ayuda.
Arriba
¿Puedo echar o bloquear a otros usuarios?
No. Rotundamente no. Jamás será implementada en eMule una función de esas características, puesto que es contraria a su filosofía.
Arriba
¿Por qué sólo obtengo 201 resultados en una búsqueda?
Las búsquedas son las responsables de una gran parte del tráfico de red de los servidores. Para evitar consecuencias desagradables (caída de servidores, retrasos, desconexiones, etc.) se ha limitado la búsqueda en eMule a 201 coincidencias.
Lo anterior es válido para los clientes antiguos de eMule. Con las últimas versiones se pueden obtener más resultados de la siguiente manera:
Cuando se realice una búsqueda popular, el servidor enviará las primeras 200-300 coincidencias que encuentre, pero si ha encontrado más resultados, se activará el botón "Más". Al pulsarlo el servidor enviará el siguiente paquete de coincidencias de la búsqueda (200-300) y así hasta un total de 6 veces, es decir el número total de coincidencias estará entre 1200-1800 (suponiendo que existan tantas).
También se puede utilizar la búsqueda basada en páginas web como Filedonkey
Arriba
¿Debería poner todos mis archivos en prioridad alta o lanzamiento?
No. Las prioridades se utilizan para favorecer el envío de determinados archivos en lugar de otros. Estas prioridades siempre son relativas a las de los demás archivos (es lo mismo poner TODOS los archivos en prioridad muy alta que ponerlos TODOS en prioridad muy baja).
La prioridad de las descargas influye en cómo eMule las tratará a la hora de buscar fuentes o de procesar las conexiones de dichas descargas.
La prioridad de las subidas determina en qué manera se favorecerá a aquéllos que pidan ese archivo. Cualquier cliente que pida una descarga con prioridades altas avanzará más rápidamente en la cola que aquéllos que pidan otros con prioridades normal/bajas.
Arriba

31.08.2004 11:37


526

 Miscelánea
> ¿Qué es un Mod?
> ¿Son mejores o más rápidos los Mods?
> Aparece un mensaje diciendo que eMule está baneado.
> ¿Dónde consigo más ayuda?
> ¿Es eMule anónimo?
> Mi cortafuegos (firewall) muestra ataques o ¿por qué eMule envía correos?.
> Mi cortafuegos todavía detecta conexiones después de cerrar eMule.
> ¿Qué es el IP Filter?
> ¿Puedo copiar esta ayuda / FAQ en mi sitio web?
Cuando tengo eMule activo se ralentiza la carga de páginas web. ¿Por qué?
Dependiendo de la configuración puede ocurrir que eMule intente abrir demasiadas conexiones a la vez a parte de utilizar casi todo el ancho de banda disponible. En estas situaciones se pueden ralentizar otras aplicaciones que hagan uso de internet, como por ejemplo navegar por páginas web. Especialmente una mala configuración o un límite muy alto de conexiones causarán una bajada significativa en el rendimiento cuando se navegue por páginas web.
Arriba
¿Qué es un Mod?
eMule es un programa de código abierto, con lo que el código fuente es accesible a todo el mundo. Otros programadores han realizado versiones MODificadas del original. A estas versiones no se les da soporte por parte del equipo oficial de eMule.
Arriba
¿Son mejores o más rápidos los Mods?
La mayoría de ellos no lo son. Las versiones oficiales se benefician de los desarrollos de los mods, pero los programadores de los mods no pueden cambiar el funcionamiento interno de eMule sin hacerlo incompatible con el resto de la red. Debido a este hecho cualquier mejora en la velocidad no es muy recomendable.
Los mods ofrecen nuevas funciones y nuevos errores que pueden gustar o no. Incluso algunos de ellos incorporan funciones perjudiciales que pueden causar mucho daño a toda la red. Esas versiones, llamadas "leecher" (que se aprovechan de los demás para beneficio propio), no deben ser usadas y el cliente oficial de eMule intenta aislarlas mediante funciones de seguridad y banearlas (les prohibe descargar).
Los mods ofrecidos en nuestros foros no incorporan funciones perjudiciales y respetan las reglas de la red.
Arriba
Aparece un mensaje diciendo que eMule está baneado
Los clientes oficiales de eMule no envían esos mensajes sino que vienen de los mods. Si se utiliza el cliente oficial se puede ignorar e incluso filtrar esos mensajes.
Arriba

¿Dónde consigo más ayuda?
Si después de leer el contenido de estos documentos de ayuda y FAQ aún quedan cuestiones sin resolver, se puede obtener más ayuda por los siguientes medios:

• | el Foro (El foro (por favor, utilice la función de búsqueda antes de comenzar nuevos hilos)
• | IRC - Vaya a la ventana IRC de eMule y pulse conectar. Para entrar en el canal de ayuda en español teclee /join #emule-spanish. También hay canales de ayuda en otros idiomas: #emule (inglés), #emule-french (francés) ó #emule-dutch (alemán).
Arriba
¿Es eMule anónimo?
Las redes P2P (peer to peer ó igual a igual) se basan en conexiones directas entre dos usuarios para transferir datos. Para que esto se cumpla se debe conocer la dirección IP del usuario de destino. Por medio de esta dirección se puede identificar y localizar al usuario. Sólo hay dos formas posibles que garanticen el anonimato: desviar el tráfico a través de un proxy anonimizador o canalizar dicho tráfico a través de otros clientes. Los servidores proxy tienen una considerable serie de desventajas: pueden estar caídos, el grado de anonimato depende de la buena voluntad del administrador del proxy y el tráfico que consumen las conexiones cuesta mucho dinero. Pongamos un ejemplo: un servidor para 100.000 usuarios eMule. Cada uno de los clientes conectados genera un tráfico de 10 kB/s en ambas direcciones, por lo que el servidor debe de soportar un volumen de tráfico de 2000 MB/s (1,98 GB/s). Pocos pueden mantener económicamente un servidor de esas características.
Desviar o canalizar el tráfico a través de terceros clientes causa un impacto similar, debido a que la mitad del tráfico sería usado para el anonimato, lo cual significa que los usuarios deberían de tener el doble de ancho de banda de subidas para mantener el rendimiento de la red en los niveles actuales. Por el momento no hay ningún método seguro para ser anónimo en una red P2P.
Arriba
Mi cortafuegos (firewall) muestra ataques o ¿por qué eMule envía correos?.
El software cortafuegos analiza el tráfico mirando a través de qué puertos se envía o recibe. Muchos de los puertos son usados normalmente por determinadas aplicaciones. El correo electrónico, por ejemplo, normalmente suele utilizar el puerto 110 para recibir y el 25 para enviar. También hay troyanos y otro tipo de software maligno que utiliza puertos específicos.
Debido a que eMule permite libremente configurar cualquier puerto para el envío y recepción de datos, algunos usuarios están estableciendo puertos utilizados normalmente por otras aplicaciones. Ello puede derivar en mensajes de ataque por parte del software cortafuegos o que éste crea que el eMule envía mensajes porque establece una conexión a través de determinado puerto.
Si se utiliza el cliente oficial de eMule se puede estar tranquilo, puesto que nunca intentará enviar ningún tipo de información que no sea necesaria para el normal funcionamiento del mismo. Desde la versión 0.30b no hay ningún exploit (fallo de seguridad del que podría beneficiarse alguien) conocido.
Arriba
Mi cortafuegos todavía detecta conexiones después de cerrar eMule.
El cliente eMule se propaga en la red como fuente para el resto de clientes. El servidor también propaga al cliente como fuente de los archivos que se comparten. Cuando se cierre eMule se seguirá recibiendo tráfico de clientes preguntando si una conexión es posible todavía. Este efecto cesará después de un corto período de tiempo.
Arriba

¿Qué es el IP Filter?
El IP Filter (filtro IP) se usa para bloquear el tráfico de determinadas direcciones que podrían ser perjudiciales para la red. La página más popular en castellano para actualizar los archivos de filtro es ésta. Añada la dirección al archivo de filtro en Preferencias -> Seguridad -> Actualizar desde URL y presione Cargar>. También se pueden añadir listas de bloqueo directamente si apuntan a un archivo .zip
Arriba
¿Puedo copiar esta ayuda / FAQ en mi sitio web?
Se puede copiar cualquier parte de la ayuda o de las FAQ siempre que se mantenga la autoría y se adjunte un link a http://www.emule-project.net
Sería deseable, e incluso una señal de respeto, el enviarme un aviso cuando se haga esto.
Referencia al autor (Monk)
Arriba

31.08.2004 11:51


527

 Iconos

Transmitiendo o recibiendo "hash" de este usuario.

En la cola de peticiones de este usuario o solicitándole una descarga.

Conectando con este usuario.

De este usuario no se necesitan partes, se le ha pedido otro archivo o bien no se puede conectar con él por culpa de una ID baja.

Estado desconocido.

Mensaje recibido.

Usuario normal de eDonkey o antiguo de eMule.

Usuario capaz de comprender el protocolo extendido de eMule.

Cliente normal con muchos créditos, es decir, con prioridad más alta.

Usuario capaz de comprender el protocolo extendido de eMule y con muchos créditos.

Usuario de mlDonkey.

Usuario de mlDonkey con muchos créditos.

Usuario de eDonkey2000-Overnet-Hybrid.

Usuario de eDonkey2000-Overnet-Hybrid con muchos créditos.

Usuario de Shareaza.

Usuario de Shareaza con muchos créditos.

Usuario verificado mediante la Identificación Segura de Usuario.

Conectado con ID alta en las redes eD2k y Kademlia

Conectado con ID alta en la red eD2k y con ID baja (es decir, tras cortafuegos) en Kademlia.

Conectado con ID baja en la red eD2k y con ID alta en Kademlia.

Conectado a ambas redes con ID baja.

Conectado con ID alta a la red eD2k y sin conectar en Kademlia.

Sin conectar a la red eD2k y conectado con ID alta en Kademlia.

Sin conectar en Kademlia y conectado con ID baja en la red eD2k.

Sin conectar en la red eD2k y conectado con ID baja en Kademlia.

Sin conectar.

Contacto a través de Kademlia: correcto.

Contacto a través de Kademlia: no se ha obtenido respuesta en la última comprobación.

Contacto a través de Kademlia: Seguramente sin contacto y por lo tanto se eliminará de la lista.

Icono de eMule que aparece en la bandeja de sistema (systray) cuando se está conectado con ID alta a un servidor.

Icono de eMule que aparece en la bandeja de sistema (systray) cuando se está conectado con ID baja a un servidor.

Icono de eMule que aparece en la bandeja de sistema (systray) cuando no se está conectado a un servidor.

Algún usuario ha escrito un comentario favorable a este archivo.

El archivo ha sido evaluado como Falso ("fake"), Corrupto o No válido.

Válido de la versión 0.42a en adelante.

09.10.2004 7:59


528

 Colores de la barra de progreso

En la pantalla de "Tráfico", cada descarga cuenta con una barra de colores que da información acerca de su disponibilidad en la red y su progreso hasta el momento.

(Estilo plano)
(Estilo sombreado)

El negro indica las partes del archivo que ya has descargado.
El rojo indica que esa parte falta en todas las fuentes que conoces, es decir, que nadie de los que están conectados contigo ahora mismo tiene esa parte.
Los distintos tonos de azul se refieren a la disponibilidad de una parte del archivo en las distintas fuentes. Cuanto más oscuro sea el tono, más disponible estará el trozo.
El amarillo informa de que esa parte en concreto se está descargando en ese mismo momento.
La línea verde indica el progreso total de la descarga

(Estilo plano)
(Estilo sombreado)
La barra verde significa que la descarga se ha completado..

(Estilo plano)
(Estilo sombreado)
Una barra de progreso en rojo o azul oscuro indica una descarga pausada o denteida.

Si pinchas dos veces (o una vez solo, si así lo has especificado en "Preferencias" -> "General") sobre una descarga, ésta se expandirá y podrás ver todas sus fuentes, cada una de ellas con su correspondiente barra de progreso. Aquí los colores tienen un significado ligeramente diferente.

(Estilo plano)
(Estilo sombreado)

El negro indica las partes que ya has descargado.
El azul se refiere a las partes que aún te faltan.
El color plata te informa de cuáles son las partes que también le faltan a esta fuente.
El verde aparecen aquellas partes que se están descargando en este momento.
El amarillo informa de que esa parte ya se ha pedido y está pendiente de descargarse.

Recuento de fuentes
Los cuatro valores xx / yy + aa (zz) que figuran en la columna "Descargas" no son sino el recuento de fuentes de cada archivo y ofrecen la siguiente información:

• xx - Cantidad de fuentes útiles disponibles.
• yy - Número total de fuentes.
• + aa - Cantidad de fuentes del tipo "Se le ha pedido otro archivo" (A4F4). Sólo se muestran cuando se activa esta opción en "Preferencias" -> "Controles avanzados".
• zz - Fuentes de las que estás bajando datos en este momento.

Partes obtenidas
Esta barra sólo aparece en las colas de subida si el cliente del otro usuario las contempla. Proporciona información sobre el progreso del archivo que ese usuario se está descargando de ti.

En negro aparecen las partes que este usuario ya ha completado.
En plata las partes que todavía le faltan.
En verde aparecen las partes que está descargando de ti en este momento.
En amarillo indica una parte pendiente de subir, aunque ya está solicitada.

Disponibilidad de los archivos compartidos
Los ficheros compartidos también muestran su disponibilidad por medio de una barra. El sistema de colores que se emplea aquí es parecido al que se usa con la barra de progreso.

En rojo denota una parte que falta en todas las fuentes que conoces.
Los diferentes tonos de azul ofrecen una idea del grado de difusión con que cuentan las distintas partes del archivo.

09.10.2004 8:06


529

 Posición en cola (QR)
En la ventana de "Tráfico", cuando desplegamos las fuentes disponibles pinchando dos veces en cualquiera de nuestras descargas, aparece en la columna "Prioridad" un valor QR:[x] para cada una de esas fuentes.
QR son las siglas de "Queue Ranking" e indican nuestra posición en la cola de cada una de las fuentes disponibles para esta descarga.

Obviamente, cuanto más bajo sea este valor, mucho mejor.

05.09.2004 8:47


530

 Explicación del ID

La ID es un valor que se calcula a partir de la dirección IP del usuario. Se la asigna el servidor cuando eMule logra conectar. La ID sirve para informar de si es posible establecer una comunicación correcta entre dos usuarios. Una vez establecida la conexión, se muestra la ID en la ventana de "Registro" del servidor.

eMule no muestra la ID en ningún otro sitio, pero sí informa del tipo de ID que tenemos en el globo terráqueo que aparece en la esquina inferior derecha, junto al nombre del servidor

Indica una ID alta en las dos redes.
Indica una ID baja en las dos redes.

Tener una ID alta quiere decir que el puerto que hemos escogido en "Preferencias" -> "Conexión" (por defecto el 4662) se halla abierto y puede accederse a él libremente.

Por el contrario, tener ID baja quiere decir que este puerto está bloqueado o que no se puede acceder a él. La causa de esto puede hallarse en la presencia de cortafuegos ("firewalls"), enrutadores ("routers") o servidores proxy ("proxy servers").
Tener una ID baja no quiere decir que no se puedan descargar o subir archivos, si bien es cierto que tiene algunas desventajas:

- No se conoce la IP de la máquina en la que eMule está funcionando y por lo tanto todas las peticiones a este usuario, como por ejemplo las peticiones de conexión o de solicitud de puesto en cola, habrán de hacerse a través del servidor al que está conectado el usuario que tiene ID baja. Esta re-dirección provoca en el procesador del servidor una cantidad de trabajo extra muy elevada, con lo que se reduce el número máximo de usuarios a los que el servidor puede atender. Los servidores Lugdunum llegan a limitar el número de usuarios con ID baja a los que atienden, e incluso llegan a rechazarlos por completo.

- Dos usuarios con ID baja no pueden conectar entre sí, puesto que no se pueden redirigir los mensajes a través de dos servidores distintos. Como consecuencia de esto, contarán con menos fuentes para sus descargas.

- Cuando los servidores estén muy ocupados puede ocurrir que se pierdan mensajes y que eMule pierda información importante referida al progreso en la cola o a peticiones de descarga. Como consecuencia de esto se pueden obtener menos créditos y, por lo tanto, peores descargas.

Notas:
- Las desventajas causadas por la ID baja afectan únicamente al intercambio de información (es decir, al intercambio de datos sobre los archivos, sus fuentes, etc.) entre los clientes con ID baja. Por lo demás, no hay ningún problema entre ellos para el intercambio de ficheros.

- Si no se logra obtener una ID alta, es mejor conectarse a servidores con pocos usuarios, puesto que les quedarán más recursos que a los grandes, habitualmente más congestionados.

- También se puede obtener una ID baja cuando el servidor al que estás conectado está demasiado ocupado o cargado para responderte correctamente, o si simplemente está mal configurado. Cuando estés seguro de que tu configuración es del todo correcta y de que deberías tener ID alta, conéctate a otro servidor. Arranca eMule y usa este test (gracias a TheDonkeyNetwork) para comprobar tu configuración.

Por otro lado, si la IP asignada a tu ordenador acaba en 0, los servidores te darán un Id baja a pesar de tener correctamente configurado cortafuegos, router, proxy o cualquier otra cosa. Esto se debe a una limitación del protocolo ed2k a la hora de calcular la ID de un usuario. En ese caso el servidor enviará un mensaje como éste: Your ip (xxx.xxx.xxx.xxx) ends with a 0. The edonkey protocol assigns a LOWID to you.

- Si la ID es alta, no importa cuán alta sea. Una ID "más alta todavía" no es mejor ni ofrece ventajas extra.

- Si la ID es baja, no importa cuán baja sea. Una ID baja es aquella que tiene un valor por debajo de 16777216.

- La relación entre tu IP y una ID alta es como sigue: a una IP = A.B.C.D le corresponde la ID alta = A + 256*B + 256*256*C + 256*256*256*D.

Importante:
Desde la versión 0.23a, eMule elimina las fuentes con ID baja para mantener la carga de trabajo de los servidores lo más baja posible. Sólo se aceptan las fuentes con ID baja que estén conectadas al mismo servidor que tú y las fuentes con ID baja que quieran descargar un archivo de ti. Además, las fuentes con ID baja no intercambian datos a través del Intercambio de Fuentes de Usuario a Usuario.

09.10.2004 8:11


531

 Valoración y puntuación

La lista de la cola muestra a los usuarios que se hallan esperando para ocupar un puesto de descarga en la cola. Esta lista aparece al pinchar "En cola" en la pantalla "Tráfico". El significado de la mayor parte de los valores que aquí figuran es bien claro, excepto "Valoración" y "Puntuación".

Valoración
En principio, cada usuario en cola tiene una valoración de 100. Este valor inicial cambia en función del archivo compartido que el usuario solicita y algún otro factor:

> | Rechazado Modificador: x0 Los usuarios rechazados no obtienen valoración ni, por lo tanto, puesto de descarga en la cola.
> | ID baja Modificador: ninguno [x0.8] Las versiones anteriores a la 0.27a asignaban un modificador de 0,8 a los usuarios con ID baja. Esta característica se ha eliminado.
> | Conectado Modificador: ninguno [x1.5] El premio de x1,5 por estar ya conectado se ha abandonado de la versión 0.27a en adelante.
> | Créditos Modificador: x1 - x10 El sistema de créditos calcula este modificador principal en función de la relación subida/bajada.
> | Prioridad de archivos para archivos compartidos Modificador: x1,8 - x0,2 Los usuarios que solicitan descargar un archivo recibirán un modificador que dependerá de la prioridad escogida para compartir el archivo. Las versiones anteriores a la 0.27a emplean los valores que aparecen entre corchetes [ ].
 | Lanzamiento: | x1.8 [x5]
 | Alta: | x0.9 [x2]
 | Normal: | x0.7 [x1]
 | Baja: | x0.6 [x0.5]
 | Muy baja: | x0.2 [x0.2]
> | Versiones de eMule anteriores a v0.20a Modificador: x0.5 Las versiones anteriores a la 0.20a causan demasiada carga innecesaria en la red y son penalizadas con un modificador de x0.5.

Ejemplo:
Un cliente se ha ganado un modificador de créditos de x8 por haber subido mucho material. Pide un archivo que tiene prioridad alta. Su Valoración total será: 100 x 8 x 0,9 = 720

Puntuación
La puntuación se calcula con los mismos modificadores que se describen en Valoración, si bien se tiene también en cuenta el tiempo que el usuario ha esperado. La puntuación determina la asignación de los puestos de descarga que estén libres. Los usuarios con puntuaciones altas y *** detrás del valor estarán próximos a ocupar un puesto de descarga.
La fórmula para calcular la puntuación es:

Puntuación = Valoración x Tiempo de espera en la cola en segundos / 100

Los usuarios que tengan un modificador total mayor que 1 obtendrán un icono de cliente amarillo.

10.09.2004 16:38


532

 Listas
La pantalla "Tráfico" ofrece información muy diversa sobre sus subidas y descargas actuales. La parte superior de esta pantalla muestra las descargas, y el número entre paréntesis ( ) se refiere a la cantidad de descargas actualmente en curso.
La parte inferior muestra las subidas en curso. Aquí se puede pasar de una lista de información a otra, pues son varios los tipos de datos que se enseñan.

Para pasar de una lista a otra pincha sobre el nombre de la lista que ves ahora. La información que aparece en dichas listas es fácilmente comprensible.

Se aplica a la versiones 0.27a y siguientes.
09.10.2004 8:08


533

 Archivos usados

Cuando arrancamos eMule se crea o se utiliza una cantidad nada despreciable de archivos. La mayoría de ellos se crea en el directorio "config" de eMule, mientras que otros se alojan en el directorio temporal (según se especifica en "Preferencias") o directamente en el directorio de instalación de eMule.

o | Known.met El archivo Known.met guarda todos aquellos archivos que nuestro eMule conoce, independientemente de si son archivos compartidos o archivos que figuran en nuestra lista de descargas. Se guarda información sobre todos esos archivos, información que incluye tamaño del archivo, ruta, conjuntos de "hash" y algunas estadísticas.
o | Clients.met En este archivo se guardan las referencias a todos los usuarios que poseen créditos en tu eMule.
o | Server.met Contiene todos los servidores que conoces.
o | Emfriends.met Si se añaden usuarios a la lista de amigos se les guarda en este archivo.
o | Preferences.ini Conserva todas las opciones introducidas en "Preferencias", así como información acerca de ciertos detalles visuales, como el ancho de las columnas, etc.
o | Fileinfo.ini Comentarios o Valoraciones de tus propios archivos compartidos.
o | Category.ini Aquí se guarda la configuración de tus categorías, como el nombre, los comentarios y los colores que les hayas asignado.
o | Ipfilter.dat Este archivo contiene los rangos IP y los niveles de acceso que deben ser filtrados por el Filtro IP. Véase también "Preferencias" -> "Seguridad"
o | Onlinesig.dat La Firma en Línea (Online Signature) es un pequeño fichero que contiene el servidor al que está conectado tu eMule y algunas estadísticas tanto de subida como de descarga. Tal vez se use para "scripts" de IRC o imágenes en las firmas.
o | Preferences.dat Conserva el hash del usuario. Éste es un valor que se calcula cuando eMule arranca por primera vez y se emplea para identificar al usuario en la red. Se usa para los sistemas de crédito y de amigos.
o | Sharedir.dat Contiene todas las rutas a los directorios compartidos.
o | Staticservers.dat Los servidores estáticos no cambian nunca su IP y, en teoría, están siempre conectados en la red. Estos servidores se pueden añadir al archivo staticservers.dat utilizando el menú contextual (botón derecho del ratón) de la lista de servidores. Véase también "Preferencias" -> Servidor.
o | Adresses.dat Al arrancar, eMule actualiza su lista de servidores si este archivo contiene direcciones válidas para bajar o actualizar archivos de listas de servidores conocidos (las server.met). "Preferencias" -> "Servidor" contiene un botón para editar esta lista y la opción de actualizarla al arrancar. El archivo puede contener muchas entradas (una por línea) pero sólo se termina usando la primera que proporcione un server.met válido.
o | AC_SearchStrings.dat Todas las cadenas de búsqueda utilizadas con anterioridad se guardan aquí, con el fin de ofrecer la opción de auto-completar si una nueva búsqueda coincide con otras anteriores.
o | AC_ServerMetURLs.dat Este archivo tiene un funcionamiento igual que el del archivo anterior. La única diferencia estriba en que este se emplea para guardar las URL a archivos server.met introducidas previamente. Hay que tener en cuenta que muchas páginas web cambian con frecuencia sus direcciones de los server.met.
o | Cryptkey.dat Contiene tu clave RSA privada y exclusiva, de 384 bits.
o | eMule.tmpl Los archivos *.tmpl son necesarios para la Interfaz Web. En ellos se definen la disposición y las opciones de las páginas que se muestran.
o | xx.part Los archivos .part corresponden a descargas sin finalizar aún. eMule puede descargar de más de un usuario al mismo tiempo, por lo que el archivo *.part siempre tendrá el tamaño de la descarga en su estado final. Las partes aún pendientes de descargar son rellenadas con ceros.
o | xx.part.met Todo archivo *.part tiene su correspondiente archivo *.part.met. Con el fin de identificar las descargas en la red y comprobar posibles errores, cada descarga se divide en partes de aproximadamente 9 MB. A cada parte se le calcula lo que se llama un valor hash. Después, se crea otro valor hash que contiene todo el conjunto de estos hashes parciales. Esta información se almacena en los archivos *.part.met, junto con el nombre del archivo y el estado en que se encuentran los hashes.
o | xx.part.met.BAK Dado que supone un gran problema el que los archivos *.part.met se corrompan o estropeen por culpa de un cuelgue del sistema o de un corte de luz, se crean copias de seguridad de esos archivos. Si necesitas ayuda porque tus descargas desaparecen por culpa de archivos *.part.met corruptos, consulta la sección Resolución de problemas.
o | eMule.log Aquí se conserva el texto de la ventana "Registro" en la pantalla "Servidores" siempre y cuando la opción correspondiente se haya activado en "Preferencias" -> "Opciones adicionales".
o | eMule_Debug.log Aquí se conserva el texto de la ventana "Debug" en la pantalla "Servidores" siempre y cuando la opción correspondiente se haya activado en "Preferencias" -> "Opciones adicionales".

Aplicable a las versiones 0.29b y siguientes

05.09.2004 12:42


534

 Controlando eMule

eMule puede ser totalmente controlado a través del teclado mediante combinaciones de teclas. Su funcionamiento es parecido a su uso en el entorno Microsoft Windows.

• | Las funciones que tienen un carácter subrayado ( _ ) en su nombre son invocadas mediante la pulsación de la tecla Alt más la letra subrayada.
• | En un teclado estandar Windows, la tecla de menú contextual situada junto a la tecla Ctrl (o Control) derecha, abre el menú contextual de los componentes seleccionados
• | Varios componentes de una lista, como puede ser la de Servidores o la de Tráfico, pueden ser seleccionados uno a uno manteniendo pulsada la tecla Ctrl mientras van siendo seleccionados pulsando el botón izquierdo del ratón. Asimismo si se mantiene pulsada la tecla Shift o Mayúsculas, se podrán seleccionar todos los componentes que se encuentren entre dos elementos marcando ambos con el botón izquierdo del ratón.
• | Para ir rápidamente a un componente de una lista basta con escribir la primera letra de dicho componente.

Alt + X | Menú Rápido de eMule
Alt + C | Conexión - Desconexión (Cancela la conexión al servidor y/o a la red Kad)
Alt + K | Ventana Kad
Alt + S | Ventana Servidores
Alt + T | Ventana Tráfico
Alt + B | Ventana Buscar
Alt + D | Ventana Compartidos
Alt + M | Ventana Mensajes
Alt + I | Ventana IRC
Alt + A | Ventana Estadísticas
Alt + P | Menú de Preferencias
Alt + R | Menú Herramientas
Alt + Y | Abre fichero de ayuda de eMule
Alt + F4 | Cerrar eMule
Ctrl + C | Copia servidor(es) o descarga(s) que hayan sido seleccionados al portapapeles. Aplicable también a entradas en Registro, Mensajes o los contenidos de IRC.
Ctrl + V | Pega los servidor(es) o descarga(s) desde el portapapeles a la ventana deseada en eMule. También pega texto en Mensajes o en IRC.
Ctrl + A | Selecciona todos los componentes de una lista.
Ctrl + F | Abre el diálogo de Búsqueda en la ventana seleccionada, como puede ser en la lista de Servidores o en los resultados de una búsqueda.
F1 | Muestra el fichero .hlp de ayuda de eMule.
F2 | Renombra la descarga seleccionada.
(Shift + ) F3 | Tras una búsqueda mediante Ctrl + F, F3 salta hacia el siguiente término que cumpla el criterio de búsqueda. Shift + F3 salta hacia el anterior.
Esc | Minimiza el eMule .
Alt + Return (Enter) | Muestra los Detalles del fichero seleccionado.
Ctrl + Del or AltGr + Del | Borra el contenido de 'autocompletar' en Actualizar server.met, Buscar e IP de autoarranque en Kad
Tab(ulador) | Completa los nick en la ventana IRC tras escribir sus primeros caracteres
Doble click - descarga | Muestra las fuentes de una descarga.
Doble click - servidor | Conecta al servidor seleccionado.
Doble click - Barra de estado (primer campo) | Muestra la última entrada en Registro.
Doble click - Barra de estado (tercer campo) | Muestra la ventana Estadísticas.
Doble click - Barra de estado (cuarto campo) | Muestra los detalles de nuestra conexión.
Doble click - Barra de estado (quinto campo) | Muestra la ventana Mensajes.
Doble click - fichero compartido | Abre el fichero con su aplicación predeterminada si la descarga ha finalizado.
Alt + doble click - descarga | Muestra las fuentes que tienen partes que nos faltan para nuestra descarga.
Ctrl + doble click - descarga | Muestra todas las fuentes con QR > 0
Shift + doble click - descarga | Muestra todas las fuentes de las que estamos bajando datos en ese momento
Botón central del ratón - descarga | Muestra el diálogo Detalles de la descarga seleccionada.
Botón central del ratón - fichero compartido | Muestra el diálogo para comentar o calificar el archivo.
Botón derecho del ratón | Abre un menú contextual con opciones adicionales y funciones extra en practicamente cualquier pantalla de eMule.

05.09.2004 12:49


535

 General

Alias
Introduzca su alias tal y como aparecerá ante otros usuários.

Idioma
Escoja su idioma favorito de la lista.

Opciones Misceláneas

o Sonido en errores
Si se encuentra un error o un trozo de archivo corrupto, sonará el altavoz de su PC.

o Traer al frente al hacer click en un enlace
El eMule usa la red eD2k, las descargas y los servidores pueden agregarse por enlaces especiales de una web.
Establece el comportamiento de eMule al hacer click en un enlace. Escoja ya sea una tarea destellante del eMule o el mostrar la ventana del eMule encima.

o Activar online-signature
En el directorio de eMule se creará un pequeño archivo llamado onlinesig.dat. El formato del archivo es el siguiente:

[Estado en línea]|[Servidor conectado]|[IP:puerto] [Velocidad actual de descarga]|[Velocidad actual de subida]|[Usuarios en cola]

Esta información puede ser enviada a una página web mediante Dra.:.god's Online Signature o ser procesada de cualquier forma.
En el futuro se podrán agregar más funciones

o Preguntar al salir
Un cuadro de mensajes aparecerá al cerrar eMule pidiendo confirmación.

Al iniciar

o Comprobar si hay una nueva versión
Si está activa esta opción, eMule buscará una versión más nueva en cada puesta en marcha. La barra deslizante añade el intervalo de actualización para el chequeo de versión. Si una versión más nueva es encontrada, entonces usted puede hacer una descarga en www.emule-project.net. Para mejorar eMule simplemente instale / extraiga la nueva versión en la misma carpeta en uso donde esta su eMule. Todas los configuraciones y descargas serán automáticamente usadas por la nueva versión.

o Mostrar pantalla de inicio
Muestra una imagen agradable en la puesta en marcha de eMule si esta activado.

o Iniciar minimizado
Esto iniciará eMule como un icono de la bandeja

Editar servicios web.
Internet ofrece algunas webs basados en servicios como motores de búsqueda para la red. Estos servicios de web pueden ser usados directamente desde eMule. Para Configurarlos el archivo webservices.dat instalado en la carpeta eMule tiene que ser editado. El botón Edit Webservices da un acceso rapido para este archivo.

Ejemplo para un WebServices.Dat:
#########################################
# Fichero de configuración de los Servicios Web
# escriba un servicio en cada línea
#
# Formato: Nombre,URL
#
# variables:
# #filename -> nombre del fichero
# #hashid -> hashid del fichero
# #filesize -> tamaño del fichero
#
# Ejemplo:
# Fake Check,http://www.some-well-known-search-engine-for-downloads.com/search?p=ed2k:#filesize:#hashid
# eMule Homepage,http://www.emule-project.net
# eMule FAQ,http://www.emule-project.net/faq/
#
# Las líneas de comentarios empiezan con # o /

eMule Homepage,http://www.emule-project.net
eMule FAQ,http://www.emule-project.net/faq/

Este ejemplo añadirá eMule Homepage (pagina principal de emule) y eMule FAQ (preguntas frecuentes) para los servicios de Web. Se puede acceder a estos servicios desde el menú contextual de la lista de Descargas.

Enlaces ED2k
Usar este botón para asociar eMule al formato web de eDonkey2000 para bajadas de archivos y altas de servidores.

Nota:
Otras aplicaciones p2p pueden modificarle esta asociación. Se puede verificar su correcta configuración en el registro de windows usando el editor del registro (Inicio -> Ejecutar... -> regedit):

HKEY_CLASSES_ROOT\ed2k\shell\open\command
Nombre: (Predeterminado)
Tipo: REG_SZ
Datos: "Ruta de emule.exe (¡entre comillas!)" %1
(por ejemplo -> Datos: "C:\emule\emule.exe" %1)

y

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\shell\open\command
con los mismos datos que el apartado anterior.

Si se encuentra con problemas con la asociación de enlaces eD2k con eMule, borre todas las entradas tras HKEY_CLASSES_ROOT\ed2k\... y HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\... Una vez hecho esto, inicie eMule y use de nuevo el botón Enlaces ED2K.
¡Efectúe una copia de seguridad de su registro antes de modificarlo y reinicie el equipo después de efectuar modificaciones en él!

Válido para la versión 0.27a en adelante

12.09.2004 9:21


536

 Mostrar

o Estilo Barra de Progreso
El deslizador afecta a la cantidad de efectos 3D de las barras de progreso.

o Seg. para aparición de tooltips.
Si el ratón pasa por encima de una descarga una pequeña nota aparecerá con la información de dicha descarga. Esta opción especifica el retraso para que se muestre.

o Doble click en lista para expandir
Esta opción decide si la lista de fuentes de una descarga se mostrará al pulsar una vez o al hacerlo dos veces.

o Mostrar un icono en las descargas con comentarios
Muestra si hay comentarios positivos ( [image]) o comentarios negativos ( [image]) en las descargas de la lista de transferencias.

o Mostrar porcentaje de descarga en barra de progreso
Activando esta opción aparecerá el porcentaje de fichero descargado sobre la barra de progreso.

o Mostrar índices de transferencia en el título.
Muestra la velocidad de subida y bajada actual en la barra de título de la ventana de eMule.

o Mostrar información de descarga en pestañas de categorías
Mostrará dos valores (x/y) a la derecha del nombre de la categoría. El primer valor (x) es el número de las descargas actualmente activas y el segundo (y) el número total de archivos para esta categoría.

o Minimizar al área de notificación
eMule se minimizará en la bandeja del sistema en lugar de en la barra de tareas.

o Limpiar autom. descargas completas
eMule muestra descargas completas con una barra de progreso en verde. Esta opción las borrará automáticamente de la lista de descargas.

Conservar uso de CPU y Memoria

o Desactivar lista de clientes conocidos
eMule muestra la lista de clientes conocidos. Para ahorrar memoria, esta lista puede desactivarse con esta opción. Desactívalo en sistemas con poca memoria.

o Desactivar lista cola de espera
Similar a la anterior, también consume recursos del sistema. Desactívalo para ahorrarlos.

o No actualizar lista cola de espera en tiempo real
La información mostrada en la cola de espera no se actualizará tan a menudo, lo que ahorrará algo de carga en la CPU.

o No redibujar gráficos de estadísticas al cambiar de tamaño
eMule puede congelarse durante un pequeño periodo de tiempo cuando la ventana cambia de tamaño. Esto es causado por el redibujado de los gráficos con los datos guardados. Si esta opción está activada, los gráficos no serán recreados e iniciados de nuevo.

Seleccionar fuente
Este botón abre un diálogo para elegir la fuente, estilo y color del texto mostrado en las ventanas de servidor, mensajes e IRC.

Autocompletar (función registro)
Este historial guarda todas las entradas de la búsqueda, de las IP de autoarranque de Kademlia, de la dirección de actualización de servidores y de la dirección de actualización del IP Filter y permite completar la entrada si encuentra algo necesario en las entradas guardadas. La casilla permite desactivar esta opción y el botón "Restablecer" eliminará todas las entradas.

Válido para la versión 0.42f en adelante.
09.10.2004 8:04


537

 Conexión

Primero encuentra la velocidad que te proporciona tu Proveedor de Servicios de Internet (ISP) en tu contrato o en su página web.

Habitualmente los valores de velocidad se expresan en kilo Bits por segundo [kb/s] pero los valores que se introducen en la configuración de eMule deben ir en kilo Bytes por segundo [kB/s].
Para convertir a kilo Bytes tan sólo divide el valor de kilo Bits por 8.

Ejemplo:
Velocidad Máxima de Bajada: 768kb/s ÷ 8 = 96 kB/s
Velocidad Máxima de Subida: 128kb/s ÷ 8 = 16 kB/s

El Asistente lleva preconfigurados los tipos de conexión más frecuentes. Utilízalo para encontrar los ajustes adecuados a tu línea.

Capacidad
o Descarga
Este valor equivale a la Velocidad Máxima de Bajada. En el ejemplo anterior sería 96.

o Subida
La Velocidad Máxima de Subida. En el ejemplo sería de 16.

Nota:
La Capacidad es importante para el correcto funcionamiento del eMule. Comprueba que aquí has puesto los valores correctos.

Límites
o Descarga
Esta es la velocidad máxima de descarga en kB/s que le permitirás al eMule. Se recomienda fijarla en ilimitada mediante el desmarcado de la opción Lim. de descarga.

o Subida
Este es un ajuste importante. Representa la subida máxima que proporcionas a la red. El ajuste recomendable no debería ser mayor al ~75% de tu Velocidad Máxima de Subida. O usa el Sensor de Velocidad de Subida (USS) explicado más abajo.

Aspectos a considerar:
Poner los Límites a ilimitados usando el Sensor de Velocidad de Subida
Al activar el Sensor de Velocidad de Subida en Preferencias -> Opciones adicionales junto con la opción de Lím. de subida en ilimitado, eMule usará todo el ancho disponible para subidas. El ajuste automático del tiempo de tolerancia de ping y del ancho de subida asegurarán una correcta navegación o uso de juegos online al mismo tiempo que conseguimos maximizar la obtención de créditos por subidas.

Poner demasiado alto el Límite de subida
Todas las descargas necesitan un espacio extra en el ancho de banda para hacer peticiones, buscar fuentes, etc. Por tanto si se pone un límite demasiado alto, las subidas nos frenarán nuestras descargas ya que estas pueden dejarnos sin el ancho de banda necesario para dichas peticiones.

Poner demasiado bajo el Límite de subida
El Sistema de Créditos de eMule está basado en las cantidades que entregas a la red. Un valor bajo en el Límite de subidas significará menos créditos y tiempos más largos de espera en las colas.

Puerto
o TCP
eMule usa por defecto el puerto 4662 para bajar datos de otro cliente. Sólo es necesario cambiarlo si el puerto está bloqueado, por ejemplo no redirigido en un router o cerrado por un firewall. En ese caso tendrás ID baja. Utiliza este enlace (gracias a TheDonkeyNetwork) para comprobar si el puerto consignado está abierto para tu conexión.

o UDP
Puerto utilizado por los protocolos extendidos de eMule tales como el Intercambio de Fuentes entre clientes o la búsqueda de fuentes en clientes compatibles con eMule. El uso del UDP entre clientes reduce el Ancho de Banda Excedente (Overhead) y asímismo reduce el nivel de carga en los servidores. Además, Kademlia exclusivamente usa UDP para manejar las conexiones de la red.
Para mejores resultados y para poder conectar a la red Kademlia, el puerto UDP debe ser también redirigido si se usa un router y se deben permitir las conexiones entrantes a ese puerto en el firewall. Si no nos es posible abrir ese puerto, debe ser desactivado.

o Abrir éstos puertos en el cortafuegos interno de WinXP
Si tenemos activado el cortafuegos (firewall) interno de Windows XP, este botón abrirá en él de manera automática los puertos especificados y así permitirá la comunicación sin bloqueos de eMule. Sólo se abren los puertos UDP y TCP asignados en la configuración anterior y se recomienda el uso de esta función junto con el activado de la opción Preferencias -> Opciones adicionales -> Abrir/Cerrar puertos en el cortafuegos de WinXP cuando se inicia/cierra eMule. Así se consigue mejor protección. Esta opción sólo funciona bajo Windows XP (sin ningún Service Pack) o bajo Windows XP con SP1.

o Comprobar puertos
Este botón abrirá una página web en el navegador que ejecutará un script para comprobar que los puertos introducidos en la configuración están abiertos y por tanto con ID alta. Si la página muestra un error, han de ser corregidas las configuraciones para el router y/o el firewall.

- Nota del Traductor:
El test actualmente no tiene en cuenta el proxy que usa Telefonica u otros proveedores en España, por lo que la prueba que hace no es correcta. Comprueba que la dirección que muestra en ese test es la tuya, si pone un mensaje Testing:..... proxycache.rima-tde.net ... entonces está intentando conectarse y los resultados no son válidos.

Límites de Conexión
o Conexiones Máximas
Es el número máximo permitido para las conexiones TCP y UDP.
Las conexiones sólo se efectúan si hay datos transfiriéndose, en las búsquedas y control de las colas o durante el Intercambio de Fuentes entre clientes.
Normalmente no es necesario cambiar este valor, excepto para Windows 98/Me, en los que no se debería poner un valor mayor de 100.

Nota:
(Demasiadas conexiones) en la columna con el detalle de una descarga significa que se ha alcanzado el límite establecido para nuevas conexiones. Estas peticiones se quedan "en cola" y serán procesadas a la que queden nuevas conexiones disponibles.

Máx. Fuentes/Archivo
o Límite Máximo
El Límite Máximo es el mayor número de fuentes permitidas para un único archivo. A la que se llega a ese límite, eMule deja de aceptar nuevas fuentes para ese archivo.

Red
eMule trabaja bajo dos redes diferentes. Una es la basada en servidores siguiendo el sistema tradicional de red eD2k. La otra trabaja sin el uso de servidores y usa un concepto denominado Kademlia. Consultar la Guía Sobre las Redes en esta ayuda para una descripción más detallada.
El marcado de los recuadros correspondientes nos permite escoger a qué red(es) conectará eMule al pulsar el icono Conectar.

Autoconectar al iniciar
Fuerza a eMule a establecer una conexión vía Servidores y/o Kademlia justo al iniciar el programa.

Reconectar al perder la conexión
Si se pierde la conexión, eMule intentará automáticamente establecer una nueva conexión. Se recomienda dejar activada.

Mostrar ancho de banda excedente
Esta opción nos mostrará en la barra de estado inferior el Ancho de Banda Excedente (Overhead) tanto de subidas como de descargas. Son los valores entre paréntesis ( ) al lado de las velocidades de subida y descarga. Este excedente se calcula usando el total de datos necesarios para el manejo de fuentes, las nuevas conexiones abiertas y el control de cualquier forma de comunicación entre clientes. Este ancho de banda no es usado por las subidas y las descargas.

Importante:
Si la suma de la velocidad de subida más su ancho de banda excedente está cerca del límite de subida configurado, eMule abrirá demasiadas conexiones o tendrá que trabajar con un número excesivo de fuentes. En este caso deberás reducir los valores de Conexiones Máximas y/o de Máximas Fuentes/Archivo o tendrás malos resultados en tus subidas y descargas.

Nota:
El número de clientes en tu cola no causa tráfico adicional y no tienen ningún efecto en el Ancho de Banda Excedente.

Válido para la versión 0.43a en adelante.

01.10.2004 8:02


538

 Proxy

Un servidor proxy es una maquina que enlaza al usuario conectado con la dirección que se visita y viceversa. Los servidores proxy son utilizados habitualmente para 4 tareas diferentes:

> | Firewall Los servidores proxy pueden ser configurados para habilitar algunos puertos, protocolos y direcciones.
> | Router Habitualmente usados para facilitar el acceso a internet para un grupo de ordenadores englobados en una LAN.
> | Proxy - caché Los proxy-caché actúan como inmensos almacenes de material y servicios regularmente visitados en internet. El proxy-caché puede permitir un acceso mas rápido a estos contenidos.
> | Privacidad Algunos proxies, incluso los gratuitos, no remiten ninguna información específica del usuario como la IP o referentes a la dirección que se visita. La huella que la dirección recibirá será la del servidor proxy. Los servidores proxy gratuitos que existen en internet no están realmente adaptados al uso que se pueda hacer de ellos con eMule. La mayoría de ellos son lentos, inestables y probablemente denegarán la conexión de eMule que se intente. El uso de dichos proxies perjudicará de forma significativa nuestro uso de eMule. Los proxies que funcionan a nivel local no proporcionan ninguna privacidad.

Si se usa eMule en un ordenador que este protegido por un proxy tenemos que introducir los valores correctos para que el servidor proxy funcione adecuadamente. Si se introducen valores erróneos no obtendremos conexión alguna.

Importante:
Activa solamente el proxy si estás seguro de que tienes uno y de que conoces todos los datos necesarios para la configuración correcta. Los proxies raramente son utilizados en ordenadores domésticos y no proporcionan ventajas a aquellos que estén fuera de una LAN. ¡Los routers o módems no son proxies!

General

o Activar proxy.
Activa la característica proxy.

oTipo de proxy
Existen diferentes tipos de servidores proxy. Para conectarse con eMule a traves de ellos el tipo debe ser especificado obligatoriamente.

> | SOCKS v4 / v4a Los proxies SOCKS ofrecen una aplicación independiente del protocolo para conectar dos máquinas sin conexión directa por IP. Sólo los servidores versión 4 y 4a son capaces de distribuir el protocolo TCP. Si este tipo de proxy es usado, la casilla Deshabilitar en Preferencias- > Conexión - > Puerto UDP debe estar marcada.
> | SOCKS v5 Se aplican el mismo tipo de limitaciones que a los SOCKS v4/v4a
> | HTTP 1.1 Usa el Protocolo de Transferencia de Hipertexto v 1.1 para la conexión. De forma similar a los SOCKS v4, este tipo no permite el protocolo UDP, así que se aplican el mismo tipo de limitaciones que a los SOCKS v4/v4a. Los proxies HTTP normalmente no pueden abrir puertos en escucha. No será posible conseguir High ID cuando se usa HTTP 1.1.

o Servidor Proxy.
Introduce la dirección del servidor proxy.

o Puerto Proxy
Se tiene que especificar el Puerto al que se conectará al servidor proxy. Los proxies habitualmente utilizan el puerto 1080.

Autentificación
Algunos proxies necesitan un nombre de usuario y contraseña para permitir la conexión. Si ese es tu caso, deberás activar la Autentificación e introducir el nombre de usuario y contraseña correctas.

Conectar automáticamente sin proxy.
Marcando esta opcion haremos que eMule ignore la configuración del proxy cuando se conecte a servidores de la red ed2k.

Aplicable a las versiones superiores a: .28a
21.09.2004 16:26


539

 Servidor

Eliminar servidores caídos tras [n] reintentos
Cuando un servidor no responde adecuadamente a una solicitud se contabiliza como intento fallido. Después de [n] reintentos fallidos ese servidor se eliminará de la lista de servidores en la siguiente solicitud de conexión.

Auto-actualizar lista de servidores al iniciar.
En el directorio en el que instalaste eMule encontrarás un archivo llamado adresses.dat. Este archivo puedes editarlo pulsando el botón [image]. Introduce una dirección válida que conduzca a un archivo server.met y guarda el archivo. Si esta opción es activada, eMule actualizará al inicializarse su lista de servidores desde la URL que hayas introducido en el archivo adresses.dat. El archivo podrá contener más de una dirección pero sólo la primera será la que utilice para actualizar la lista de servidores.

Nota:
Puedes configurar el editor de textos que vayas a utilizar en preferences.ini. Busca en el archivo TxtEditor= y aquí escribe la ruta a tu nuevo editor de textos.

Actualizar lista de servidores al conectar a un servidor.
Los servidores eDonkey se comunican entre ellos hasta cierto punto. Con esta opción activada eMule conseguirá una lista de servidores que contiene el servidor al que estas conectado.

Actualizar lista de servidores al conectar un cliente.
Esta opción funciona cuando un cliente eMule se conecta a tu eMule. Ambos clientes compararan su lista de servidores activos y actualizaran sus listas de acuerdo a la comparación realizada.

Usar sistema de prioridades.
Activando el menú contextual sobre cada servidor tendremos la opción de asignar prioridades a los distintos servidores.

La prioridad que establezcamos hará que eMule tenga preferencia por uno u otro servidor a la hora de conectarse.

Control inteligente de LowID al conectar.
Si anteriormente has conseguido High ID, esta opción, asumiendo que tienes todo correctamente configurado, te desconectará de un servidor que sin razón aparente te esté dando Low ID. Si recibes 3 Low ID seguidas serás considerado como usuario de Low ID hasta que no consigas una High ID de nuevo.

Conexión Segura.
eMule intenta conectarse a la vez a dos servidores para acelerar el proceso de conexión. Cuando la opción de Conexión Segura está activada, solo se intentará la conexión con un servidor para minimizar las opciones de Low ID. Habitualmente no es necesario. De todas manera recuerda que eMule solo se conecta a un servidor, nunca a más de uno.

Auto conexión solo a servidores fijos.
El menú contextual sobre cada servidor permite añadir ese servidor al archivo staticservers.dat que reside en la carpeta de instalación de eMule. Esta lista se cargará al inicializarse eMule. ¡Añade solamente a la lista servidores con IP fija o que tengan la característica DynDNS! Esta opción hace que eMule se conecte únicamente a los servidores que contenga la lista. Tener esta opción activada y no tener servidores válidos en la lista provocará que eMule no se conecte.

Establecer alta prioridad a los servidores añadidos manualmente.
Con esta opción activada se asignará automáticamente prioridad alta a los servidores añadidos manualmente a la Lista de Servidores.

Aplicable a las versiones superiores a 0.29b
09.10.2004 8:14


540

 Directorios

Archivos entrantes
Se señala en qué carpeta serán guardadas las descargas ya completadas (directorio Incoming). Si se cambia la ruta que viene definida por defecto, deberá indicarse una ruta válida a la nueva carpeta. eMule no creará esa carpeta.

Archivos temporales
Directorio donde se guardan las descargas en progreso. A causa del sistema de múltiples descargas eMule crea archivos vacíos (*.part) con el tamaño que tendrán esos mismos archivos cuando estén completamente descargados.
Si esta ruta a la carpeta se cambia, se deberá tener en cuenta como en el caso de Archivos entrantes que eMule no crea la carpeta y además deberemos reinicializar eMule para que los cambios tengan efecto.

Directorios compartidos
Estas carpetas serán compartidas en la red y su listado podrá ser visto por otros usuarios que sean amigos según pueda habilitar el usuario la opción de los programas p2p eMule, eDonkey o mldonkey (dependiendo de la configuración de Preferencias - > Archivos). Si quieres compartir todas las subcarpetas pulsa CTRL mientras marcas la casilla de la carpeta padre. No funciona con unidades ni particiones completas.

o Carpetas UNC (Red)
UNC significa Uniform Naming Convention. Es el método común para acceder a los recursos compartidos (carpetas o discos duros completos) en una red sin tener que mapear estos recursos. Todas las carpetas siguen este formato:

\\servidor\recurso\...

Ejemplo:
\\test\DiscoD\eMule sería la ruta a la carpeta eMule en el disco compartido DiscoD que está alojado en el ordenador llamado test

Algunas recomendaciones al compartir archivos:
Cuando un cliente de eMule se conecta a un servidor transmite una lista de los archivos compartidos. El servidor guarda esta lista y la hace accesible a las búsquedas de archivos y búsquedas de fuentes. Este tráfico de archivos carga las tareas sobre la CPU del servidor, a más archivos mayor será la carga que tenga que soportar el servidor y por lo tanto será menor el numero de usuarios que pueda manejar.

Sigue estos consejos cuando compartas archivos en la red:
> | Las carpetas Incoming y Temp ya están compartidas así que no hace falta añadirlas.
> | La red eDonkey no está bien adaptada para compartir muchos archivos pequeños, por ejemplo una gran cantidad de archivos mp3. Mejor comprímelos en un solo archivo cuando los compartas.
> | No compartas carpetas como \Archivos de Programa o \Windows ni discos duros completos.

Aplicable a las versiones superiores a: .29b
12.09.2004 8:48


541

 Archivos

Ver mis compartidos
Esta opción permite mostrar la lista de tus archivos compartidos dependiendo de quién la pida (a todo el mundo, sólo a su lista de amigos o no permitir mostrarla)

Gestión Inteligente de Corrupción (ICH)
La transferencia en la red eDonkey esta dividida en trozos. Un trozo son unos 9MBs. Cada trozo completamente descargado es revisado por si estuviera corrupto; si el trozo no está corrupto pasa a ser compartido.
Normalmente los trozos corruptos deben ser descargados de nuevo completamente. ICH intenta reducir el número de MBs que necesiten ser descargados de nuevo y así puede ahorrar tiempo si una corrupción es detectada.

Al iniciar
o Añadir archivos para descargar en modo pausado
Cuando la lista de descargas llega a un total de 20 o más archivos, esta opción es muy útil porque todas las nuevas descargas serán añadidas en modo Pausado en vez de Esperando. Así es posible añadir más archivos sin provocar una sobrecarga en la conexión de eMule. Ver Descargar siguiente archivo pausado cuando otro se complete.

o Añadir nuevos archivos compartidos con autoprioridad
Los archivos completos o recién compartidos serán fijados con autoprioridad. Con la autoprioridad activada eMule asignará la prioridad de un archivo de acuerdo con las peticiones recibidas por cada archivo. Los archivos con pocas peticiones serán fijados en alta prioridad mientras que los archivos con muchas peticiones serán fijados en prioridad baja. Esta opción ayuda a que los archivos poco extendidos sean más accesibles en la red por lo que se recomienda su utilización.

o Añadir nuevas descargas con autoprioridad
Similar a la opción anterior ésta se aplica a los archivos que se añadan a la lista de transferencias. Se fijará su prioridad dependiendo del número de fuentes que tenga el archivo.

Fuentes encontradas | Prioridad
0 - 40 | Alta
41 - 80 | Normal
más de 81 | Baja

o Limpiar nombre de archivo
Esta opción limpia automáticamente los nombres de archivos siempre que se añada una nueva descarga a la lista de descargas. Los símbolos especiales como _ , . , [] son borrados o reemplazados por un espacio en blanco y se colocará la primera letra de cada palabra en mayúscula. Además se pueden definir nuevos símbolos o cadenas para ser borrados del nombre del archivo con el botón Editar. A pesar de que existen símbolos definidos, se pueden añadir fácilmente nuevos separándolos por el carácter | (barra vertical o pipeline)

Advertencia:
Las imágenes creadas por diferentes softwares de grabación suelen ser mas de un archivo, por ejemplo: *.cue/*.bin (CDRWin), *.mds/*.mdf (Alcohol120%), *.ccd/*.sub (CloneCD), *.bwt/*.bwi/*.bws (BlindWrite). Esta opción no debería usarse cuando se descarguen este tipo de archivos. Cambiar el nombre de los archivos produciría errores a la hora de grabarlos, ya que el nombre correcto también se guarda en aquellos que le complementan.
Si cambias el nombre del archivo deberás cambiarlo también en los archivos dependientes. Para los archivos *.cue puedes hacerlo fácilmente con el bloc de notas de Windows pero otros formatos exigen un editor hexadecimal como Ultraedit o Winhex.

Intentar transferir partes completas en todas las subidas
Activando esta opción se obliga a eMule a subir hasta que el trozo esté completo. La ventaja de esto es que aumentarán las fuentes del archivo ya que sólo se pueden compartir trozos completos. Cuando se comparta un archivo nuevo es altamente recomendable que se active esta opción.

Intentar descargar antes la primera y última parte
Para previsualizar un archivo se necesita tener la primera y la última parte descargadas. Esta opción dará prioridad a la descarga de esas partes. No está recomendado activarla porque causará una distribución anómala del archivo y su disponibilidad también se verá afectada.

Buscar en el portapapeles enlaces eD2k
Copiando un enlace eD2k mediante Control+C desde una web o cualquier otra fuente aparecerá una ventana emergente preguntando si ese archivo debería ser añadido a la lista de descargas.

Usar método avanzado para calcular el tiempo remanente
Esto afectará a cómo eMule calcula el tiempo restante para una descarga. El método por defecto se basa en la velocidad actual de descarga para este archivo, mientras que el método avanzado toma la velocidad media desde que este archivo se añadió a las descargas. El cálculo avanzado puede dar resultados falsos si la descarga ha sido añadida en una versión anterior a la v.43a.

Descargar siguiente archivo pausado cuando otro se complete.
Si un archivo se completa y tienes archivos pausados en la lista de descargas, una de ellas comenzará a descargarse. Pausando archivos o añadiendo archivos en modo pausado junto con esta opción conseguirás tener un número constante de fuentes (para una conexión ADSL normal no se deberían superar las 3000) sin saturar el eMule debido a demasiadas fuentes.

o Misma categoría
Esta opción sólo está disponible si la opción anterior está activada. Si se usa esta opción eMule descargará un archivo que corresponda a la misma categoría que el archivo descargado.

o solo en la misma categoría
Esta opción forzará que solamente se descargará un archivo que esté en la misma categoría que el último que ha finalizado.

Reproductor de vídeo
Si esta casilla esta vacía eMule reproducirá el archivo elegido con el reproductor multimedia asociado por defecto. Si se señala una ruta a un reproductor distinto, se usará éste. Habitualmente la mayoría de reproductores necesitan un archivo temporal para reproducir los archivos ya que no pueden manejar ficheros con secciones vacías de manera correcta. Si se señala un reproductor en la casilla debería marcarse la opción Crear copia de seguridad para previsualizar. Un reproductor que no necesita archivos temporales para la reproducción es VLC - VideoLAN Client que podría usarse para previsualizar los archivos. Para más información consultar la sección Previsualizar Archivos.

Aplicable a las versiones superiores a: .43a
28.09.2004 13:39


542

 Notificaciones

Las notificaciones se activan con eventos específicos mostrando un pequeño gráfico como ventana emergente en la esquina inferior derecha de la pantalla.
Esta ventana emergente aparecerá incluso cuando se visualicen películas o cuando se juegue con videojuegos.

Mensaje de alerta (mensajes emergentes o pop-up's)
o Usar sonido
Cuando se marca esta casilla se ha de introducir un fichero de sonido en el campo de abajo, que se escuchará cuando se produzca un suceso.

Notificar
o Nueva entrada al registro
Todos los mensajes nuevos en 'Servidores -> Registro' aparecerán como mensajes emergentes.

o Al iniciar una nueva sesión de chat
Al iniciarse una nueva sesión en la pestaña Mensajes.

o Al recibir un nuevo mensaje de chat
Al recibir un nuevo mensaje. El icono [image] también alerta de esto

o Descarga añadida / Descarga finalizada
Cuando se finalice o se añada una descarga, ya sea mediante un enlace de web, de IRC o de una búsqueda

o Al detectar una nueva versión de eMule
Una ventana emergente se activará informando sobre la detección de una versión de eMule que se puede descargar en www.emule-project.net

o Espacio en disco insuficiente, desconexión del servidor.
Si no hay espacio suficiente en el disco duro, el estado de la descarga cambiará a pausado o en el caso de que esté terminada, a erróneo.

Aplicable a versiones superiores a 0.27a
09.10.2004 8:00


543

 Estadísticas

Gráficos
o Intervalo de actualización
Este valor determina cada cuánto tiempo se actualizan los gráficos. Fijando este valor muy bajo puede influir en un excesivo uso de CPU.

o Tiempo de promedio del gráfico
Por defecto los gráficos promedio se calculan con los datos obtenidos en los últimos 5 minutos. Éste es un valor indicador del rendimiento a largo plazo

o Colores
Selecciona qué parte del gráfico quieres modificar en el menú desplegable y a continuación fija el color de esa parte en la selección de color. Se puede modificar incluso el color de la barra de velocidad que tiene el icono de eMule cuando está minimizado en el área de notificación.

o Escala Eje-Y. Estadísticas de Conexión
Es el gráfico que está debajo del árbol de detalle de estadísticas indicando el número actual de conexiones activas y número de descargas y subidas. Este gráfico está normalmente fijado en valores de 0 a 100 pero esta opción te permite cambiarla alterando la horquilla de valores del gráfico, y así incrementar o decrementar la resolución del mismo.

o Índice de conexiones activas
Dependiendo de la conexión y configuración a Internet el número de conexiones activas es muy dinámica, pero suele estar por encima de 100. Para poder visualizar mejor el gráfico de conexiones esta opción permite alterar la escala. Por ejemplo, un valor de 1:4 dividirá el número de conexiones activas por 4 mostrando el gráfico en concordancia con este valor.

Nota:
Las dos opciones de arriba son útiles para mejorar el aspecto de las gráficas y asimismo poder mostrar el gráfico completo en 'Estadísticas de Conexión' (la gráfica que se encuentra en la parte inferior izquierda de "Estadísticas"). Disminuir el número del apartado 'Escala Eje-Y / Estadísticas de Conexión' aumentará la proporción de tamaño de la gráfica de Conexiones Activas. De igual modo, modificando el valor en Índice de conexiones activas conseguiremos adaptar la gráfica al tamaño de la ventana correspondiente.

Árbol de estadísticas
o Intervalo de actualización
Intervalo de actualización del Árbol de Estadísticas detallado. Fijar este valor muy bajo puede influir en un mayor uso de CPU.

Aplicable a versiones superiores a 0.29a
18.09.2004 11:39


544

 IRC

Servidor
El servidor IRC oficial y el que viene por defecto es ircchat.emule-project.net, aunque pueden utilizarse irc.freshIRC.com e irc.freshirc.de.

Alias
Especifica un alias (nick) para IRC distinto al introducido en la pestaña general.
¡Por favor, usa tu propio alias, y no el que viene por defecto, cuando entres en un canal IRC!

Lista de canales
o Sonido en eventos
Esta es una función conocida en el cliente mIRC. Puede usarse para reproducir archivos de sonido que otros usuarios en el canal tengan. Los sonidos para IRC deben situarse en la carpeta de instalación de eMule en la subcarpeta .\Sounds\IRC. Solo se pueden usar ficheros *.wav.
En el canal puede usarse el comando /sound ficherodesonido.wav para reproducirlo en todo el canal. El comando /sound alias ficherodesonido.wav reproducirá el archivo solamente para ese alias.

Aviso:
Esta funcionalidad puede molestar especialmente a otros usuarios, especialmente en canales grandes. Utilizalo con cuidado o te arriesgas a ser expulsado o baneado.

o Usar Filtro Lista de canales
Los filtros se pueden hacer tanto por nombre como por número de usuarios. La lista de canales sólo mostrará canales cuyo nombre sea parecido o tenga más usuarios de los introducidos

Al conectar
o Usar cadena personalizada
Esta opción permite especificar algunas acciones al realizar la conexión. Las más usadas serán:
/join [#nombre de canal]
/ns identify [pwd] command.
Se podrán encadenar varios comandos usando|.

Ejemplo
/ns identify [pwd] | /join #emule

Opciones varias
o Conectar a canales de ayuda
Activando esta opción eMule conecta directamente con los canales de ayuda oficial.

o Añadir Fecha/Hora en los mensajes
La hora actual se mostrará delante de cada mensaje del Irc

o Cargar lista de canales al conectar
Automáticamente se despliegan todos los canales disponibles del servidor conectado como pestañas separadas

o Ignorar mensajes de información
No se muestran mensajes de información del canal. Hace que el chat tenga un aspecto más limpio

o Ignorar mensajes de eMule
Similar al anterior, ignorar mensajes del protocolo eMule en el canal .

o Permitir a otros usuarios añadirte como amigo
El chat IRC de eMule permite añadir amigos directamente desde la lista de alias utilizando el botón derecho del ratón. Desactivando esta opción se denegará la petición de ser añadido a la lista de amigos . Los usuarios que intentan añadir el amigo no recibirán ningún aviso si se ha denegado.

o Aceptar enlaces ED2K en IRC(usar con precaución!)
Si aceptas esta función serán añadidas las descargas de todos los enlaces ed2k publicados en el canal.
Para evitar la creciente descarga de enlaces no deseados debe usarse esta opción junto con la siguiente opción Solo de amigos. Si aceptas esta opción, sólo se añadirán las descargas provenientes de amigos de la pestaña mensajes del formulario principal de eMule

Aplicable a versiones superiores a: .43a
18.09.2004 11:42


546

 Programador

El programador se usa para variar ligeramente la configuración de eMule y aplicar los cambios a una hora y día de la semana concretos. Puede ser usado para activar eMule y descargar durante el horario nocturno aprovechando los restos de ancho de banda dejados por otras aplicaciones respecto al horario de trabajo.

El programador permite crear perfiles con una o varias acciones a ejecutar a una hora o día concretos.
La primera lista muestra los perfiles creados con el Título, Días de acción y Hora de comienzo. Según se seleccionen los perfiles se mostrarán las acciones elegidas y el tiempo en el área Detalles.

o Activado
Activa el programador

o Eliminar
Borra el perfil seleccionado

o Nuevo
Crea un nuevo perfil de acción. Los nuevos perfiles son automáticamente mostrados en el área Detalles para realizar la correcta configuración.

Detalles
En este área se muestran las configuraciones para el perfil de acción elegido.

o Activado
Esta casilla de verificación activa el perfil elegido. Uno o más perfiles pueden estar activos a la vez

o Título
Descripción o título del perfil

o Tiempo
Las acciones pueden llevarse a cabo diariamente o solo en días concretos de la semana. Cada acción deberá tener hora de inicio y fin.
Si ninguna acción es válida a su hora de inicio, eMule automáticamente usa los valores por defecto o los marcados en Preferencias.

Creando acciones en un perfil
Primero debemos crear un nuevo perfil a través del botón Nuevo. Después de introducir el Título y la Hora de comienzo y Finalización para el perfil, crearemos las acciones a través del menú que aparecerá pulsando el botón derecho del ratón sobre la lista.

o Añadir
Crea una nueva acción en el perfil seleccionado. Después de elegir qué tipo de acción vamos a crear, aparecerá un mensaje con una caja de texto. Escribe el valor apropiado para la acción a cambiar:

> | Limite de subida Define el limite de velocidad de subida en kB/s que eMule usará.
> | Limite de bajada Define el limite de velocidad de descarga. Valor en kB/s
> | Limite de fuentes Cambia el número de fuentes permitidas (Limite duro) para una descarga
> | Limite de conexiones/5segs Cambia el número de nuevas conexiones creadas en 5 segundos. Este valor puede causar serios efectos en la ejecución de eMule. Ver Preferencias -> Opciones adicionales.
> | Conexiones máximas Sobrescribe conexiones máximas de Preferencias -> Conexiones.
> | Categoría: Parar descargas Esta acción para todas las descargas de la Categoría elegida.
> | Categoría: Reanudar descargas Reanuda todas las descargas de la categoría dada

Todos los cambios en la configuración del perfil deben ser confirmados con el botón Aplicar

o Editar
Cambia el valor de la acción seleccionada

o Eliminar
Borra la acción seleccionada

Se aplica a las versiones posteriores a .28a
18.09.2004 11:47


547

 Servidor web

El Servidor Web ofrece acceso remoto a eMule. Lee en este manual en la sección características, el apartado sobre el Servidor web.

Plantillas:
Para que funcione el Servidor Web el fichero eMule.tmpl tiene que estar presente. Este fichero contiene la presentación y el diseño del Servidor Web. Este fichero viene junto con las versiones de eMule o puede ser descargado de http://www.emule-project.net.
Los recursos de imágenes deben ser alojados en el directorio Webserver del directorio de eMule.

General

o Activado
Si pulsas sobre activado el Servidor Web quedará activo. Después de activarlo la plantilla que generará el Servidor Web, tiene que ser recargada pulsando el botón Recargar. Si no se encuentra un fichero eMule.tmpl válido se mostrará un mensaje de error: No se pueden cargar las plantillas: No se puede abrir el archivo \..\eMule.tmpl.
No habilites el Servidor Web si no vas a usarlo. Disponer de un Servidor Web es un riesgo potencial de seguridad.

o Compresión Gzip
Usará la comprensión para no ocupar ancho de banda cuando se genere tráfico relacionado con el Servidor Web.

o Puerto
Establecerá el puerto que usará el Servidor Web. Por defecto es el 4711 y normalmente no será necesario cambiarlo. El puerto es parte del enlace web del servidor.
Si el ordenador que está intentando acceder al Servidor Web tiene el puerto bloqueado por un cortafuegos o un proxy, puedes cambiar el puerto al 80 que es el puerto por defecto para navegar por internet y raramente está bloqueado.
Si se usa un router el puerto usado ha de ser redirigido.

o Plantilla
Normalmente el fichero plantilla *.tmpl está en el directorio de instalación. El botón ... permite cambiar la ruta de este fichero fácilmente.

Administrador
Permite asignar una contraseña de acceso al Servidor Web. Es importante que la contraseña sea adecuada o cualquiera podrá acceder a través del Servidor Web a tu eMule. La contraseña se mostrará como 6 asteriscos. No hay contraseña por defecto.

Invitado

o Activado
Al contrario que el administrador que tiene acceso a controlar eMule, un invitado sólo verá la configuración y listas. No tendrá permisos para cambiar nada. Si no se necesita un acceso invitado no debe de ser habilitado.

o Contraseña
Define una contraseña para restringir el acceso al invitado. Tampoco hay contraseña por defecto.

Nota:
En vez de mostrar la lista elegida, el Servidor Web mostrará una página de descarga cuando se use Microsoft Internet Explorer. Para que esto no suceda marque Usar HTTP 1.1 y Usar HTTP 1.1 en conexiones proxy en Herramientas->Opciones de Internet...->Opciones Avanzadas: Configuración de HTTP 1.1

MobileMule
MobileMule es una interfaz que puede conectar a cualquier teléfono móvil compatible con java. Parecido al Servidor Web permite el control remoto de eMule via teléfono móvil. Para información adicional visite la página http://mobil.emule-project.net/.

o Activar MobileMule
Permite acceder a eMule via teléfono móvil compatible con java.

o Contraseña
No hay contraseña por defecto. Por razones de seguridad deberá siempre haber una contraseña cuando MobileMule esté activado.

o Puerto
Establece el puerto para acceder a la interfaz MobileMule. Si el ordenador donde se está ejecutando eMule está detrás de un router o cortafuegos, el puerto ha de ser redirigido/abierto o la conexión no será posible

Aplicar a versiones .42a y posteriores
18.09.2004 11:57


548

 Seguridad

Filtrar IP
El filtrado de IP es usado para restringir conexiones entrantes y salientes con otros clientes. Todos los rangos de IP que son introducidos en el fichero ipfilter.dat no pueden conectar a eMule ni puede eMule conectar con ellos. Este fichero que estará en la carpeta config, puede ser editado por medio del botón editar. Para información adicional sobre filtrado de IPs ver el tema Filtrar IP de este manual.
eMule tiene que recargar el archivo ipfilter.dat antes de aplicar los cambios.

o Nivel de filtrado
Cada entrada del fichero ipfilter.dat tiene asignado un nivel de acceso. Este valor designa la confianza en la entrada de IPs. Los valores altos (por defecto 128+) son considerados seguros mientras que los valores bajos serán bloqueados. El nivel de filtrado define el límite de bloqueo. Cada entrada en ipfilter.dat que tenga un acceso bajo respecto al valor del nivel de filtrado le será denegada la conexión a eMule. El valor por defecto no debe ser cambiado.

o Filtrar servidores
Las reglas de filtros IP son normalmente válidas solo para otros clientes. Esta opción añade la posibilidad de filtrar servidores también.

o Actualizar desde URL
Tecleando una dirección (http://www.iespana.es/IPFILTER/ipfilter.dat) de un fichero ipfilter.dat y pulsando Load serán añadidas los rangos IPs al fichero ipfilter.dat de eMule. Ver el capitulo Filtrado de IP para enlaces y más información

Mensajes
Los mensajes no deseados pueden ser bloqueados introduciéndolos en esta caja de texto. Si el texto coincide con el mensaje no será mostrado. Se podrán introducir varios mensajes encadenándolos con | como separador.

o Aceptar sólo de amigos
Todos los mensajes excepto los que provengan de la lista de amigos serán bloqueados

o Aceptar sólo de clientes válidos
Esta función hará, que los mensajes serán aceptados sólo si el usuario que lo envía es válido y no parezca ser un fake (falsificación). Este ajuste debería estar siempre activado.

o Filtro spam avanzado
Este filtro revisará todo mensaje entrante. Si algún criterio se cumple, el emisor del mensaje será ignorado. Un mensaje será ignorado sólo en la sesión actual si:
> | Una dirección url o pagina web es enviada en el primer contacto
> | El usuario envía 5 mensajes sin recibir respuesta

Los usuarios de la lista de amigos no serán nunca marcados como spammers

Comentario
Esto funciona de manera parecida al bloqueo de mensajes anterior, pero es aplicado a los comentarios de archivos

Nota:
Los comentarios de archivos ayudarán a otros usuarios a juzgar la calidad de una descarga. Su intención no es hablar del tiempo o para anuncios de cualquier tipo. Por favor escribe comentarios apropiados

Opciones varias
o Usar identificación segura
Es recomendable usar la identificación segura. Para información adicional visita el apartado identificación segura de usuario.

o Iniciar eMule como Usuario limitado
Esta opción sólo está disponible en win 2k, XP, 2003 y permite a eMule aprovechar las opciones de seguridad que estos sistemas proporcionan.
Normalmente un usuario entra a estos sistemas con cuentas de administrador. Estas cuentas permiten tanto al usuario como a los programas que se ejecutan tener pleno control sobre el sistema. En estos casos todo código malicioso ejecutado tendrá efectos nocivos.
Ejecutar eMule como usuario sin privilegios creará un usuario propio en el sistema operativo llamado emule_secure y que tendrá permisos para acceder a las carpetas que necesite (carpeta de instalación, temp y incoming). Por otra parte esta cuenta está fuertemente restringida y con negativa de acceso a otras partes del sistema. eMule se arranca a sí mismo bajo este usuario haciendo que si un código malicioso es inyectado al sistema no tenga permisos, no pudiendo causar daños en el sistema. Esta es una medida preventiva en caso de que sea encontrada una vulnerabilidad de código y pueda ser aprovechada.
Notas:
o | eMule se encarga del acceso a ficheros que necesite. Una mayor seguridad puede ser alcanzada con una restricción a ficheros de otra carpeta o a discos enteros. Restringir acceso a ficheros sólo es posible con NTFS no con FAT
o | Las cuentas separadas ofrecen todas las posibilidades de mecanismos de control en los modernos sistemas operativos, como cuotas de disco, etc
o | Un bug en Windows XP impide todo estilo visual de trabajo cuando eMule está ejecutándose en este modo. La interfaz grafica de usuario (GUI) tendrá un look de win98 estándar. Windows XP SP2 parece que resolverá este problema.
o | Esta función no provee ningún anonimato en la red, pero hace que eMule pueda ejecutarse de un modo más resistente a posibles ataques externos

Aplicable a versiones superiores a: .42f
11.09.2004 8:05


549

 Opciones adicionales

Nuevas conexiones Máx. 5/seg
Este es el número de nuevas conexiones que eMule abre en 5 segundos. El valor por defecto es 20.

Importante:
> | Modificar incorrectamente este parámetro puede originar pantallas azules, colgar routers e inestabilidad para navegar por Internet. Asimismo las Subidas y Descargas pueden verse afectadas si aquí se introduce un parámetro incorrecto.
> | Puedes aumentar ligeramente este parámetro si usas eMule con conexiones de alta velocidad como Tx o LAN.

Máx. Conexiones a medio abrir
Este parámetro se hace necesario con el control de conexiones del Windows XP SP2. Esta actualización en XP sólo permitirá 10 conexiones medio abiertas y a partir de ahí comienza a meter las nuevas conexiones en una cola, la cual es procesada muy lentamente. Esto conlleva timeouts y otros efectos no deseados en eMule. Si emule se está ejecutando en XP SP2 no establezca este valor por encima de 9. Aunque hay parches para incrementar este valor establecido en XP, no está recomendado parchear tales partes críticas en Windows. El único efecto que tiene esta opción es que eMule obtiene fuentes un poco más despacio cuando se inicia la sesión. Esto disminuirá tras haber sido encontradas las fuentes. En otros sistemas operativos, como Windows 2000 o el obsoleto Windows 9x/ME, establece este valor a 50.

Capturar automát. enlaces ED2K sólo durante esta sesión
Esta opción asocia los enlaces eD2K únicamente mientras eMule está funcionando. Cuando se cierra eMule la asociación se borra para permitir el funcionamiento ininterrumpido de otros clientes eD2K.

Abrir/Cerrar puertos en el cortafuegos de WinXP cuando se inicia/cierra eMule
eMule es capaz de abrir automáticamente los puertos necesarios en el cortafuegos interno de Windows XP. Esta opción incrementará la seguridad al no dejar abiertos los puertos una vez que eMule se cierra y los abrirá de nuevo cuando se inicie. Esta opción sólo está disponible en Windows XP y solo para el cortafuegos interno, no el de otros fabricantes. Esta opción no funciona correctamente con Win XP SP2.

Usar Sistema de créditos (se premia a los que más suben)
Consulta primero el apartado Sistema de Créditos para obtener más información. Se recomienda enérgicamente dejar activado el Sistema de Créditos ya que disminuirá el daño que los "leechers" (aquellos que pretenden descargar sin subir nada) harán a la red.
Las razones para esta opción son:
> | Los "Releasers" (gente que distribuye originalmente un archivo) ahora pueden asegurarse de que ningún otro archivo tenga preferencia sobre los archivos que quieren distribuir desactivando esta opción.
> | Una red mixta es más resistente a posibles ataques a los fallos de un sistema.
> | El balance entre archivos difíciles de encontrar y los populares aumentará.

Filtrar IP de servidores y clientes LAN
Las fuentes conteniendo IPs de las clases privadas A (10.0.0.0 - 10.255.255.255), B (172.16.0.0 - 172.31.255.255), C (192.168.0.0 - 192.168.255.255), localhost (127.0.0.0 - 127.255.255.254) y todas las IPs comenzando por 0 (0.x.x.x) no son válidas en Internet. Dichas fuentes que se reciben mediante el intercambio de fuentes entre clientes o son enviadas por los servidores se descartan si este filtro se encuentra activo.

Nota:
Ejecutar eMule en una red local (LAN) requiere dejar esta opción desactivada o eMule no podrá encontrar ninguna fuente en esta red.

Mostrar más controles (controles básicos avanzados)
Esta opción activa todavía más funciones en eMule que normalmente no son necesarias para su funcionamiento.

o Mostrar MetaDatos
Es una de las pestañas de la opción Información que aparece con el botón derecho del ratón presionado sobre una descarga. Nos muestra información adicional que puede contener el archivo, como el ID tag de los .mp3 donde aparece el autor, año, etc.

o Manejo de Fuentes (A4AF - Ask For Another File)
Consulta la sección Manejo de Fuentes para más detalles de esta opción.

Desactivar comprobación A4AF para conservar CPU
Se desactivará el manejo de fuentes según lo descrito en Manejo de Fuentes. Sólo cuando una descarga se cancela, las potenciales fuentes A4AF se redistribuyen de acuerdo a las prioridades.

Comprobar espacio en disco (Min. espacio libre en disco [MB])
El tamaño de los archivos temporales de descarga de eMule se incrementa dinámicamente bajo demanda. La opción Comprobar espacio en disco se asegura que las descargas actuales puedan ser descargadas y completadas íntegramente. Las descargas que son demasiados grandes según el espacio libre en disco se pausan de forma que otras descargas se puedan completar.
Si estableces un valor para el Min. espacio libre en disco el comportamiento de eMule se modifica. Ahora todos los ficheros se descargan hasta que se alcanza el límite de espacio libre en disco.
Cuando el espacio libre en el disco aumenta las descargas pausadas se reanudarán automáticamente.

Nombre PC para enlaces eD2K propios
En la ventana de ficheros compartidos se pueden crear enlaces eD2K con la IP actual como una fuente. Introduciendo un nombre de servidor en este campo permite crear enlaces con un nombre en lugar de la IP. La ventaja de este enlace es que sigue siendo válido aunque cambie tu IP.
Para más información sobre nombres de hosts dinámicos consulta el apartado de Servidor web.

Desactivar descarga desde PeerCache
PeerCache es un sistema que realiza una caché de las descargas a nivel del ISP de una forma completamente anónima. Esto disminuye la cantidad de tráfico que el ISP tiene que soportar ya que parte de las descargas provendrán de su propio sistema y de esta forma se ofrece asimismo mejores velocidades de descarga para los usuarios. Para que esta característica sea efectiva tiene que ser soportada por el ISP..

Guardar a disco
La información que se muestra en las dos ventanas de log en la ventana de Servidores - Registro y Verbose - se puede guardar en disco activando la opción correspondiente. Se grabarán como eMule.log o eMule_Debug.log en la carpeta de instalación de eMule.

Información extra (respuesta adicional del programa)
Si se activa el modo de Información extra se mostrará una pestaña adicional Verbose en la ventana Servidores. La información que se muestre ahí es únicamente para desarrollo y no se proporcionará soporte sobre la misma. Esta opción causa un gran aumento en el consumo de CPU y memoria. No se recomienda para un funcionamiento normal.
La opción de Registrar nivel controla qué mensajes se muestran. El nivel 5 indica todos los mensajes extra, mientras que el nivel 1 sólo muestra los más importantes. Si quieres conocer la importancia de los diversos mensajes consúltalos en el código fuente de eMule ;)

Grabación segura de archivos .met/.dat
En sistemas operativos modernos que utilicen NTFS como sistema de archivos no suele ser necesario modificar esta opción. Si las descargas se suelen perder al sufrir cuelgues o en los cierres de eMule entonces se debería intentar usar la opción más segura.
¡Dependiendo del hardware usado, esta opción puede aumentar notablemente la actividad del disco / carga del sistema o retrasar el cierre de eMule!

o Al apagar
eMule utilizará medidas de seguridad adicionales al grabar los ficheros .met y .dat en disco al cerrar la aplicación. Esto puede prolongar el tiempo necesario para finalizar.

o Siempre
Las medidas de seguridad se usarán en cada acceso de escritura a esos ficheros

Intervalo actualiz. conexión a Servidor [min.]
Se ha informado de casos en los que eMule pierde la conexión con el servidor a intervalos regulares trabajando tras un router o configuraciones de red que usan NAT - Traducción de Direcciones de Red
Los routers a menudo tienen un tiempo límite para estas conexiones NAT tras el cual el router declara la conexión muerta y la cierra. Cuando esto sucede y eMule intenta comprobar de nuevo su servidor es necesario una reconexión completa ya que la antigua ha sido eliminada por el router.
Si esto ocurriese, consulta el valor de tiempo límite para el NAT en la configuración de tu router e introduce un valor ligeramente inferior en el campo Intervalo actualiz. conexión a Servidor. ¡Un valor de 0 significa que eMule lo maneja y normalmente no es necesario modificarlo!
No modifiques este parámetro a menos que tengas un router o una configuración de red más complicada. Si estableces un valor demasiado bajo puede ocasionar que seas expulsado de los servidores.

Sensor de Velocidad de Subida (USS)
USS es una función que monitoriza los tiempos de ping de la conexión y automáticamente ajusta la velocidad de subida de eMule de acuerdo a este valor de ping. Esto asegura que la conexión nunca se satura e intenta mantener la navegación y los juegos online fluidos. Se recomienda mantener los valores por defecto.

o Buscar la mejor velocidad de subida automáticamente
Activa USS.

o Velocidad de subida permitida más baja
Es la velocidad de subida mínima que USS debe mantener. Se recomienda que sea al menos el 50% de tu capacidad de subida.

o Tolerancia de Ping (% del ping más bajo)
Se calcula un valor medio de ping para la conexión al arrancar eMule. USS no permitirá que aumente el valor del ping más allá del porcentaje indicado, por ejemplo un valor inicial de ping de 50 ms y una tolerancia de ping de 800% significa un valor máximo de ping permitido de 400ms.

o Tolerancia de Ping (ms)
En lugar de calcular el límite máximo de ping permitido en un valor porcentual se puede especificar un valor en milisegundos. Consulte la siguiente opción.

o Método de tolerancia de Ping
Elige el método para establecer el Ping máximo permitido. Se usará el modificador porcentual o bien el de milisegundos.

o Aumentar velocidad / Disminuir velocidad
Estos dos valores describen lo rápido que el límite de subida se ajusta para permanecer dentro de la tolerancia de ping. Establecer unos valores incorrectos puede colapsar la conexión. ¡Deja los valores por defecto!

o Número máximo de pings de promedio
Establece el número de pings necesario para calcular el tiempo medio de respuesta.

Tamaño del Buffer por archivo
Algunos sistemas pueden mostrar una cierta lentitud, o pequeños bloqueos cuando eMule graba los datos a disco. Disminuyendo el tamaño del buffer puede ayudar en estas situaciones, pero se traducirá en una actividad de disco mayor causada por eMule, ya que los datos se grabarán a disco más frecuentemente. Establecer este valor demasiado bajo puede reducir notablemente el rendimiento de eMule.
Aumentando el buffer se reducirá la actividad del disco, pero con el riesgo de una mayor pérdida de datos si ocurriesen problemas

Tamaño de cola de espera
Para que el Sistema de Créditos de eMule funcione correctamente el tamaño de la cola es muy importante. Si un cliente tiene la cola llena, otro cliente con un nivel alto de créditos no tendrá oportunidades para entrar en la cola y aprovechar sus créditos. De forma que cuanto mayor sea la cola, mejor y más suavemente funcionará el sistema de créditos. Los clientes con muchos créditos avanzarán en colas grandes lo suficientemente rápido como para obtener su parte. Asimismo, el tiempo de espera en la cola no se reduce cuando se reconecta debido a un cambio de IP o algo similar. El tiempo hasta la reconexión no debe superar 1 hora o la posición en la cola se perderá.

Importante:
Una cola mayor no supone una sobrecarga para administrarla. Ni el número de conexiones ni el Ancho de Banda Excedente se verán afectados por poner un mayor tamaño de cola. Cuanto mayor sea la cola de espera puede suponer un mayor uso de memoria.

Válido para la versión 0.43a en adelante.

28.09.2004 13:59


550

 Preferences.ini

Todas las preferencias de eMule están guardadas en el fichero preferences.ini .Las opciones importantes son fácilmente accesibles a través del botón Preferencias, pero el fichero preferences.ini da acceso a algunas más. Para acceder a éstas el fichero preferences.ini tiene que ser editado y cambiadas manualmente. Trabajar sobre ficheros *.ini es sólo aconsejable para usuarios avanzados debido a que las posibles incorrecciones producirán efectos no deseados. Si una entrada no tiene un valor por defecto deberá ser añadida manualmente en la sección correcta del archivo. Cierra eMule antes de editar.
Los valores por defecto están en el comienzo de cada apartado.

Nota sobre el uso de Unicode con el Bloc de Notas:
En el caso que el Alias empleado tanto para el usuario de eMule como el del IRC contengan caracteres Unicode, si se edita mediante el Bloc de Notas el fichero preferences.ini la aplicación intentará guardar todo su contenido en formato Unicode, haciéndolo ilegible para eMule. Asegúrate de cambiar la Codificación del documento a ANSI en el diálogo "Guardar como..." del Bloc de Notas para evitar ese efecto.
Sección: [emule]
o | TxtEditor=notepad.exe
El programa por defecto para editar los ficheros webservices.dat e IPfilter.dat debe ser indicado aquí. Escribe la ruta completa del nuevo ejecutable si no es notepad.exe
o | DateTimeFormat=%A, %x, %X
Esta cadena de caracteres permite definir el formato fecha y hora usados por eMule. Consulta este artículo de msn para obtener una completa descripción de todos los formatos posibles.
o | MaxLogBuff=64 / 128 (v0.30a+)
Define la cantidad de memoria usada por eMule para mostrar el log. Para Windows 98 / ME se reservarán 64 KB, para win 2k/XP 128 KB. En win98/Me el buffer no debe ser superior a 64 KB. Los logs son rotativos, por ejemplo, si el buffer supera su límite, los mensajes más antiguos serán sustituidos cuando llegue uno nuevo (FIFO->First In First Out, primero en entrar primero en salir) . Esta configuración sustituye a MaxLogMessages de la 0.29
o | MaxChatHistoryLines=100
Define el número máximo de líneas guardadas en el histórico de los mensajes irc. Después de superar este valor el mensaje más antiguo será sustituido por uno nuevo (FIFO)
o | ExtractMetaData=2/1/0
Controla cómo serán leídos los metadatos desde ficheros (v0.30a+)
0: deshabilitado
1: habilitado para ficheros MP3 y AVI
2: valor por defecto, habilitado para ficheros MP3, AVI, MPEG y otros más
o | ServerUDPPort=65535

Normalmente el puerto local para preguntar a los servidores por fuentes o búsquedas de ficheros es elegido aleatoriamente (ver Puertos número 6). Si eMule está instalado en un ordenador conectado a una red más compleja, especialmente cuando se usa proxy, puede ser necesario fijar este valor o desactivarlo por completo. Deshabilitar este puerto significará que eMule nunca más actualizará el estado de los servidores en la lista de servidores y tampoco recibirá fuentes de éstos, tampoco realizará búsquedas globales. Exceptuando en todos los casos el servidor al que se está conectado en ese momento. Normalmente el valor por defecto no será cambiado.
Posibles valores para ServerUDPPort son:

0 | deshabilitado
1 - 65534 | fijado el puerto UDP local
65535 | puerto aleatorio (por defecto)
o | PreviewSmallBlocks=0/1
Esta función deberá activarse (=1) sólo cuando se use VLC –VideoLAN- para previsualizar las descargas. Esto permite ver ficheros multimedia cuando han sido descargados al menos 16 KB de datos para ficheros .mpeg o 256 KB para el resto de ficheros multimedia. Para más información ver Preferencias > Archivos > Reproductor de vídeo y el tema previsualizar archivos. Usando esta opción ha de ser desactivada Crear copia de seguridad para previsualizar.
o | RestoreLastMainWndDlg=0/1
Si añades RestoreLastMainWndDlg=1 en preferences.ini, recuerda qué ventana principal (Kad, Servidores, Tráfico) estaba en pantalla antes de salir o restaurar eMule.
o | RestoreLastLogPane=0/1
Es la misma configuración que la anterior pero recordando cuál de los log (Log, verbose) ha sido usado el último.
o | RemoveFilesToBin=1/0
Esta configuración afecta a la función Eliminar Del Disco en la ventana de Ficheros Compartidos pulsando el botón derecho. Si está deshabilitada (=0) los ficheros serán borrados sin mover a la papelera de reciclaje.
o | PreviewCopiedArchives=1/0
Cuando esta opción está deshabilitada (=0), eMule utilizará un nuevo método de previsualización que es más rápido y usa menos espacio de disco en la carpeta temporal. Se agradecen los comentarios sobre qué tal funciona esta opción.
o | ShowActiveDownloadsBold=0/1
Mostrará en negrita los archivos descargándose actualmente.
Sección: [Perflog]
o | File=D:\ruta\al\fichero\de\datos\perflog.csv
Si se utiliza MRTG para ver mediante gráficas el rendimiento de eMule, esta entrada indica la ruta y el nombre del archivo en el que se ha de guardar la información del rendimiento. Normalmente está establecido por el Instalador de MuleMRTG y no es necesario cambiarlo. Si se cambia, MuleMRTG ha de ser reinstalado.
o | Mode=1
Establece el modo de muestreo para la recogida de información. Si es utilizado con MuleMRTG debe establecerse a 1.

01.10.2004 8:19


551

 General

Todos los puertos listados aquí tienen que estar abiertos a través de la creación de una regla en el cortafuegos. Dado que la mayoría de cortafuegos bajo Windows son soluciones basadas en software, puedes ahorrarte bastantes problemas añadiendo al cortafuegos una regla que permita a eMule.exe todo tráfico, tanto UDP como TCP, por cualquier puerto y en ambas direcciones tanto de entrada como de salida. Esto no comprometerá tu seguridad puesto que se han detectado y eliminado todos los exploits conocidos.

Notas:
- ZoneAlarm está comprobado que causa problemas con eMule. No es aconsejable. Existen alternativas de calidad y gratuitas como Kerio Personal Firewall y Agnitum Outpost

- Os añadiré algunos ejemplos de configuración en cuanto el tiempo me lo permita. Si quieres contribuir escribe una guía sobre cómo usar tu cortafuegos preferido. Añade algunas capturas de pantalla y envíala a Monk@emule-project.net (en inglés)

21.09.2004 11:43


552

 Firewall de Windows XP

El cortafuegos del XP no es muy recomendable debido a que como tal, es un cortafuegos muy básico. Si de todas forma quieres utilizarlo estos pasos te serán útiles:

1. | Arranca eMule
2. | Haz clic sobre Preferencias > Conexión
3. | Anota el valor del puerto TCP del cliente (por defecto el 4662)
4. | Anota el valor del puerto UDP (por defecto el 4672)
5. | Cierra eMule y tu conexión a Internet
6. | Pulsa el botón Inicio, y luego sobre Mis sitios de red.
7. | Bajo Tareas de Red, haz clic sobre Ver conexiones de Red (Alternativa: botón derecho sobre Mis sitios de red y clic sobre propiedades)
8. | Clic con el botón derecho sobre la conexión que uses para Internet y elige propiedades
9. | Clic sobre la pestaña Opciones Avanzadas. Si el botón de Configuración no está disponible, ICF no está activo en esta conexión y no necesitas abrir ningún puerto (ya están abiertos).
10. | Haz clic sobre Agregar para abrir un puerto nuevo.
11. | Teclea un nombre en Descripción del servicio, por ejemplo, "eMule : TCP Incoming".
12. | Teclea 127.0.0.1 en el nombre o Dirección IP del equipo. Puedes especificar la dirección IP de un ordenador en red, sin embargo, en la mayoría de los casos usarás 127.0.0.1
13. | Teclea el puerto de cliente que has anotado en el paso #3 en el número de puerto externo e interno.
14. | Elige TCP, y clic sobre Aceptar.
15. | Clic, otra vez, sobre Agregar para abrir un puerto nuevo.
16. | Esta vez elige un nombre parecido a "eMule : UDP Incoming"
17. | Repite lo comentado en el punto #12
18. | Ahora en el número de puerto externo e interno es el valor que anotaste en el paso #4.
19. | Elige UDP, y haz clic sobre Aceptar.
Si cambias los puertos de tu cliente eMule necesitas reconfigurar las reglas creadas anteriormente en tu cortafuegos.

Si necesitas información adicional haz clic sobre los números abajo expuestos correspondientes a artículos de Microsoft Knowledge Base:

Q308127 Cómo abrir manualmente puertos en el Servidor de seguridad de conexión a Internet en Windows XP
Q283673 Cómo habilitar la función de Servidor de seguridad de conexión a Internet en Windows XP
Q307554 Los programas requieren configuraciones manuales de puerto con Servidor de seguridad de conexión a Internet

(este tutorial fue creado por -nRoK-. Gracias)

24.09.2004 15:08


553

 General

Si no se configura adecuadamente el router es posible que al conectar recibamos una ID baja. Un router funciona como una barrera detrás de la red, enmascarando la dirección IP de los ordenadores de la LAN (Local Area Network, Red de área local). Cuando otro cliente trata de establecer una conexión a tu eMule, sólo ve la IP del router, pero no la verdadera IP del ordenador donde está funcionando emule. Para prevenir esta situación, todos los puertos en la lista que tienen la dirección entrante -puerto 4662, 4771 TCP y puerto 4672 UDP-, han de abrirse.
Revisa el manual del router. Debe buscar secciones que hablen de apertura de puertos, DMZ o Zona Desmilitarizada, Filtros o Reglas. Una zona desmilitarizada es una subred que está entre una red interna (una lan, por ejemplo) y una red externa (internet mismo).
Muchos routers también tienen cortafuegos, por lo que hay que asegurarse de que los puertos también estén disponibles (ver cortafuegos > firewall).

Nota:
Cuando usamos un router en una red, la opción DHCP - Dinamic Host Configuration Protocol en el router debería estar desactivada. Asigne IPs estáticas a cada cliente en la red. Esto se puede hacer en Windows---Inicio -> Configuración -> Conexiones de red y acceso telefónico -> Conexión de área local -> Propiedades (botón derecho del ratón) -> Protocolo Internet (TCP/IP) -> Propiedades -> desactivar la opción > obtener una dirección IP automáticamente>, e introducir una IP en el rango de 192.168.xxx.xxx. Diferentes tipos de router tienen diversos rangos de IP, lo cual debe estar explicado en el manual del router.
Después de introducir una IP válida, la Máscara de Subred automáticamente cambia a 255.255.255.0. El último paso será introducir la IP del router como Puerta de enlace predeterminada.
Si tu tipo de router no está incluido, mira los ejemplos, ya que las configuraciones son bastante similares entre los diferentes routers existentes.

Parte de esta información ha sido extraída de www.adslayuda.com

21.09.2004 16:26


554

 Zyxel 650

Partimos de la suposición de que tenemos el router en multipuesto.> La apertura de los puertos podemos realizarla por Telnet o por web.
Ante todo necesitamos saber la dirección IP del router (puerta de enlace) y la dirección IP del ordenador.

Lo haremos a través de ms-dos:

  • win98: Inicio->ejecutar->command. Escribiremos winipcfg
  • win 2000 y xp: Inicio->ejecutar->cmd. Escribiremos ipconfig
Nos aparecerá por pantalla lo siguiente

C:\WINDOWS\system32\cmd.exe

Microsoft Windows XP [Versión 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig

Configuración IP de Windows

Adaptador Ethernet Conexión de área local          :

        Sufijo de conexión específica DNS :
        Dirección IP. . . . . . . . . . . : 192.168.1.34  1

        Máscara de subred . . . . . . . . : 255.255.255.0 2
        Puerta de enlace predeterminada   : 192.168.1.1   3

C:\Documents and Settings\Administrator>_

Punto 1 del gráfico anterior: ésta es la IP local de nuestro PC. En nuestro caso, 192.168.1.34)
Punto 2 del gráfico anterior: la máscara de subred.
Punto 3 del gráfico anterior: ésta es la IP de la puerta de enlace , que es la dirección IP del router. En nuestro caso 192.168.1.1, que además es la dirección IP predeterminada de este router.

A continuación se detalla cómo realizar el proceso por Telnet. Haremos: Inicio -> Ejecutar -> telnet 192.168.1.1

Se abrirá una pantalla que nos pedirá una contraseña para acceder al router. Por defecto la contraseña es 1234. Si no fuera ésa, probablemente alguien la haya cambiado.

C:\WINDOWS\system32\cmd.exe

Password: _

Al validar la contraseña, accederemos al menú principal del router.. Seleccionaremos el menú 15. NAT Setup.

C:\WINDOWS\system32\cmd.exe

                   Copyright (c) 1994 - 2003 ZyXEL Communications Corp.

                          Prestige 650HW-31 Main Menu

    Getting Started                       Advanced Managemente
      1. General Setup                      21. Filter Set Configuration
      3. LAN Setup                          22. SNMP Configuration
      4. Internet Access Setup              23. System Password
                                            24. System Maintenance
    Advanced Applications                   25. IP Routing Policy Setup
      11. Remote Node Setup                 26. Schedule Setup
      12. Static Routing Setup
      15. NAT Setup
                                            99. Exit

                        Enter Menu Selection Number: _

En la siguiente pantalla seleccionamos 2. NAT Server Sets.

C:\WINDOWS\system32\cmd.exe

                          Menu 15 - NAT Setup

               1. Address Mapping Sets
               2. NAT Server Sets

                        Enter Menu Selection Number: _

Seleccionamos 1. Server Set 1. Used for SUA only

C:\WINDOWS\system32\cmd.exe

                          Menu 15.2 - NAT Server Sets

               1. Server Set 1 (Used for SUA Only)
               2. Server Set 2
               3. Server Set 3
               4. Server Set 4
               5. Server Set 5
               6. Server Set 6
               7. Server Set 7
               8. Server Set 8
               9. Server Set 9
              10. Server Set 10

                       Enter Set Number to Edit: _

Todo lo que hemos hecho hasta ahora es para abrir los puertos. Pues ya hemos llegado.

La opción 1 es para abrir todos los puertos del router, escribiendo la IP Address, que por defecto está en cero. Es del todo desaconsejable.
Abriremos los puertos que elijamos. Aquí hay un ejemplo de varios puertos abiertos. No es aconsejable abrir rangos, debido a que son puertas que dejamos libres a elementos maliciosos.
Escribiremos en Start Port No. y End Port No. el número del puerto que queremos abrir. En IP Address colocamos la IP del PC en el que vamos a montar el servidor (en este caso 192.168.1.34).
Pulsamos Enter hasta que lleguemos al final de los campos y salgamos de la pantalla. En ese momento los puertos habrán quedado abiertos.

C:\WINDOWS\system32\cmd.exe

                    Menu 15.2 - NAT Server Setup

            Rule   Start Port No.     End Port No.    IP Address
           ______________________________________________________
              1. Default               Default         0.0.0.0
              2.   0                     0             0.0.0.0
              3.   44751                 44751         192.168.1.34
              4.   44761                 44761         192.168.1.34
              5.   0                     0             0.0.0.0
              6.   6881                  6882          192.168.1.34
              7.   6969                  6969          192.168.1.34
              8.   0                     0             0.0.0.0
              9.   0                     0             0.0.0.0
             10.   0                     0             0.0.0.0
             11.   0                     0             0.0.0.0
             12.   0                     0             0.0.0.0

        Press ENTER to Confirm or ESC to Cancel: _

Parte de esta información ha sido extraída de www.adslayuda.com

06.10.2004 16:17


555

 3Com 812

El primer paso a realizar es desbloquear el router mediante hyperterminal.

Primer paso. Conectamos el ordenador al router mediante un cable serie que une el puerto COM1 del ordenador con el puerto CONSOLE del router, el que tiene 9 agujeritos. Si no tenemos este cable, tendremos que conseguirlo o comprarlo.

Ejecutaremos, Inicio ->Programas -> Accesorios -> Comunicaciones -> Hyperterminal.
Al iniciarse el programa nos pide un nombre para la conexión, le ponemos cualquiera, le decimos que conecte por el com1 y le cambiamos la velocidad de conexión a 9600

Ahora aparecerá la pantalla en blanco del hyperterminal. Si hemos hecho todo correctamente, tendremos un cursor parpadeando.
Le damos a la tecla "enter", hasta que nos salga lo siguiente:
login incorrect
password?
Este es el momento para introducir el password, ya que por hyperterminal no se necesita usuario. La contraseña normalmente es "adminttd" en el caso de telefónica, "yacomadm" en el caso de ya.com o ninguna en algunas ocasiones (con un simple "enter" funciona).
El caso es que de una manera o de otra, introducimos la contraseña, pulsamos "enter" y deberíamos entrar al router, obteniendo el símbolo de la línea de comandos:
3com-DSL>
Es posible que aparentemente no hayamos conectado. Al "enter" hay que darle muchas veces. Si esto no funciona, cambiamos el cable de puerto y reiniciamos el hyperterminal diciéndole que conecte por el COM2. O enchufamos en el COM1 y le decimos que conecte por el COM2, etc....
Lo primero que haremos será añadir nuestro propio usuario:
3com-DSL>"add user" usuario_que_queramos "password" nuestro_password

Ahora vamos a explicar de forma sencilla y rápida como mapear puertos en el 3com812 a través de su web de configuración.
Para ello ponemos en nuestro navegador nuestra puerta de enlace o la IP pública, y seguidamente nos pedirá el usuario y la contraseña,

Utilizaremos el usuario y contraseña que previamente hemos creado.
Ejemplo:
·Usuario: adminttd ó (root! O admintde)
·Contraseña: adminttd ó (root! O admintde)
Introducimos estos datos y entramos en la pantalla principal de configuración del router, que tiene un aspecto como este:

Ahora pinchamos en la opción "Configuration" del menú general de la izquierda

Entramos en otra pantalla, y en esta escogemos la opción Remote "Site Configuration (VPI/VCI, Protocols, NAT ...)" haciendo clic en el botón "Remote Site Profiles", que es la zona coloreada de la pantalla:

Router 3COM

Global Settings
Enable Bridging Enable IP Routing Enable IPX Routing
Warning: Some changes to the Global Settings will briefly interrupt this Browser connection. Refresh this screen to reconnect.

Local LAN Configuration
IP
IPX

Remote Site Configuation (VPI/VCI, Protocols, NAT...)

Filter Configuation

Después de haber pinchado el botón "Remote Site Profiles" de la pantalla "Configuration" nos encontramos con una pantalla que se llama "Remote Sites (WAN)" con una estructura como esta:

Router 3COM

Hacemos clic sobre el botón "Modify" y pasamos a la siguiente pantalla.
Ahora estamos en "Modify" y la apariencia es esta:

Router 3COM

Remote Site Modify
Remote Site Name
internet Enable Remote Site
Network Service
PPP over ATM (PPPoA)
PPP over Ethernet (PPPoE)
RFC1483
DHCP Client
RFC1483 with MAC encapsulation
VC Parameters
VPI VCI
Quality of Service
Unspecified Bit Rate |
Constant Bit Rate | Constant Cell Rate
Enable Bridging
 Enable IP Routing Enable IPX Routing

Pulsamos "Next"
Entramos en la pantalla que se llama IP. Ahora debemos fijarnos que la casilla de NAT esté activada, y si la tenemos activada la pantalla es como la siguiente:

Router 3COM

Remote Site IP
Remote Site Name | internet
Address Translation
NAT | Default Workstation:
Accessible LAN Servers: | Static Ports
Routing Information
Use this connection as default gateway
RIP RIP Version
Routes
IP WAN Address
Numbered Interface Address
Network Mask
Security | Verify that incoming packets can be routed back to the packet's source address using Source Address Validation.
Enable the "Protect Files and Printers" filter to prevent outsiders from accessing your internal printers and files (recommended).

pulsamos en el botón TCP o UDP (según sea el puerto/s)
La pantalla con la que nos encontramos ahora se llama "Static TCP" o "UDP Port" y sólo tenemos que pulsar en "Add". No hay que hacer nada más en ella, sólo es una referencia para ver que puertos tenemos abiertos.
NOTA: En la lista del medio estarán visibles lo puertos que hemos ido abriendo según nuestras necesidades. Hemos llegado a la pantalla importante que se llama "Static TCP" o "UDP Port Add" y la rellenamos de la siguiente forma (el ejemplo es en un puerto TCP):

Router 3COM

Remote Site Name: internet
Public TCP Port:
Private IP Address:
Private TCP Port:

Atención porque en la casilla "Private IP Address", hemos puesto la IP Privada el PC, NO la del router. Suponemos que el ordenador que se llama xxx.xxx.xxx .2 es que tiene instalado la aplicación. En la casilla de "Public TCP Port" estamos abriendo el puerto del router para que deje salir la información. Y en la casilla "Private TCP Port" le estamos diciendo al router el puerto del ordenador al que equivale.
Pulsamos en "Add" y aparece una pantalla listando los puertos que están abiertos.
Una vez echo esto sólo nos falta guardar los cambios en el router. Pulsamos en "Save Configuration" de la zona de menú del lado izquierdo, y volvemos a pinchar en el botón "Save Configuration" de la pantalla principal, después de unos instantes ya están guardados los cambios y el router tendrá abierto/s los puerto/s que deseábamos.

Una vez realizada esta operación, necesitamos reiniciar el router, para lo cual pulsaremos "Tools" de la zona de menú del lado izquierdo y una vez ahí la opción "Reboot/Delete Configuration"

Ahora nos encontramos en el menú "Manager Reboto" es muy importante que antes de hacer nada verifiquemos que la opción "Reboot device" esté marcada y una vez verificado esto pulsamos en "Submit" al cabo de unos momentos veréis que se interrumpe la conexión y el router empieza el proceso de sincronización

Cuando todos los "leds" del mismo vuelvan a su color normal (verde) comprobareis que todo nos funciona correctamente y además ya tiene el puerto abierto para utilizarlo con la aplicación que así lo necesite.
Si con todo lo efectuado, viéramos que no conseguimos nuestro objetivo de abrir los puertos, podría ser debido a que el router tiene unos filtros que nos impiden que nuestra operación surta efecto. En ese caso recomendamos visitar alguna página que nos ayude a hacerlo.

Parte de este información ha sido extraída de www.adslayuda.com

09.10.2004 7:40


556

 SpeedStream 5660

La apertura de los puertos podemos realizarla por Telnet o por Web.
Ante todo necesitamos saber la dirección IP del router (puerta de enlace) y la dirección IP del ordenador.

Lo haremos a través de ms-dos:

  • win98: Inicio->ejecutar->command Escribiremos winipcfg
  • win 2000 y xp: Inicio->ejecutar->cmd Escribiremos ipconfig
Nos aparecerá por pantalla lo siguiente

C:\WINDOWS\system32\cmd.exe

Microsoft Windows XP [Versión 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig

Configuración IP de Windows

Adaptador Ethernet Conexión de área local          :

        Sufijo de conexión específica DNS :
        Dirección IP. . . . . . . . . . . : 192.168.1.34  1

        Máscara de subred . . . . . . . . : 255.255.255.0 2
        Puerta de enlace predeterminada   : 192.168.1.1   3

C:\Documents and Settings\Administrator>_

Punto 1 del gráfico anterior: ésta es la IP local de nuestro PC. En nuestro caso, 192.168.1.34
Punto 2 del gráfico anterior: la máscara de subred.
Punto 3 del gráfico anterior: ésta es la IP de la puerta de enlace , que es la dirección IP del router. En nuestro caso 192.168.1.1

A continuación se detalla cómo realizar el proceso por Telnet. Haremos: Inicio -> Ejecutar -> telnet 192.168.1.1

Se abrirá una pantalla que nos pedirá una contraseña para acceder al router. Por defecto las contraseñas pueden ser, 1234, admintt, adminttd, admintde, admintte, ttdadmin. Si no fuera una de esas, probablemente alguien la haya cambiado.

C:\WINDOWS\system32\cmd.exe - telnet 192.168.1.1

Password: ********

Type "?" at the command prompt for a list of commands.
Type "help" at the command prompt for general help.
For detailed help on a specific command, type comand name
followed by a "?", for instance, "show ?".

Command->_

En estos momentos estamos dentro del router. Nos aparecerá un mensaje que nos indica que para consultar los comandos disponibles para operar, introduzcamos alguna de las siguientes instrucciones.

C:\WINDOWS\system32\cmd.exe - telnet 192.168.1.1

Command-> ?
----------------------------------------------------------------------------
Command          Description
----------------------------------------------------------------------------
show             Shows system status and configuration parameters
set              Sets configuration parameters
delete           Deletes DNS, DHCP and NAPT mappings, routes and IP filters
default          Sets various parameters to factory defaults
clear            Clear statistics
reboot           Reboots the router
firmware         Downloads new firmware to the router
getconfig        Set router configuration from a file
putconfig        Save router configuration to a file
quit             (exit, logout, logoff) exists command session
logout           (exit, logout, logoff) exists command session
logoff           (exit, logout, logoff) exists command session
exit             (exit, logout, logoff) exists command session
atmping          Tests the ATM link by transmitting an OAM loopback cell
ping             Sends datagram round-trip to specified IP host
traceroute       Traces the route (hops) from the router to an IP address

For help on command options, type command followed by "?", e.g. "show ?".

Command->_

Ahora introducimos el comando set naptserver:

C:\WINDOWS\system32\cmd.exe - telnet 192.168.1.1

----------------------------------------------------------------------------
show             Shows system status and configuration parameters
set              Sets configuration parameters
delete           Deletes DNS, DHCP and NAPT mappings, routes and IP filters
default          Sets various parameters to factory defaults
clear            Clear statistics
reboot           Reboots the router
firmware         Downloads new firmware to the router
getconfig        Set router configuration from a file
putconfig        Save router configuration to a file
quit             (exit, logout, logoff) exists command session
logout           (exit, logout, logoff) exists command session
logoff           (exit, logout, logoff) exists command session
exit             (exit, logout, logoff) exists command session
atmping          Tests the ATM link by transmitting an OAM loopback cell
ping             Sends datagram round-trip to specified IP host
traceroute       Traces the route (hops) from the router to an IP address

For help on command options, type command followed by "?", e.g. "show ?".

Command-> set naptserver
Transport protocol [ tcp udp gre ]: tcp
Service [name or port number]: 4000
Server IP Address [self or IP address]: 192.168.1.34
Command->_

Nos irá preguntando los datos:

Transport protocol [tcp udp gre ]: (para elegir el protocolo entre estos 3) en el ejemplo TCP
Service [name or port number]: Podemos elegir uno de los servicios preconfigurados (web, ftp, telnet...) o bien introducir el número de puerto. En el ejemplo 4000
Server IP Address [self or IP address]: Aquí introducimos la ip privada del pc que vaya a hacer de servidor de nuestra aplicación. En el ejemplo 192.168.1.34 (hay que borrar primero self, que sale puesto)

De esta manera habremos abierto el puerto 4000 TCP al pc cuya IP privada es 192.168.1.34. El puerto queda almacenado y activado.

Parte de esta información ha sido extraída de adslayuda.com

06.10.2004 15:58


557

 Alcatel Speed Touch

La apertura de los puertos podemos realizarla por Telnet o por Web.
Ante todo necesitamos saber la dirección IP del router (puerta de enlace) y la dirección IP del ordenador.

Lo haremos a través de ms-dos:

  • win98: Inicio->ejecutar->command Escribiremos winipcfg
  • win 2000 y xp: Inicio->ejecutar->cmd Escribiremos ipconfig
Nos aparecerá por pantalla lo siguiente

C:\WINDOWS\system32\cmd.exe

Microsoft Windows XP [Versión 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig

Configuración IP de Windows

Adaptador Ethernet Conexión de área local          :

        Sufijo de conexión específica DNS :
        Dirección IP. . . . . . . . . . . : 192.168.1.34  1

        Máscara de subred . . . . . . . . : 255.255.255.0 2
        Puerta de enlace predeterminada   : 192.168.1.1   3

C:\Documents and Settings\Administrator>_

Punto 1 del gráfico anterior: ésta es la IP local de nuestro PC. En nuestro caso, 192.168.1.34
Punto 2 del gráfico anterior: la máscara de subred.
Punto 3 del gráfico anterior: ésta es la IP de la puerta de enlace , que es la dirección IP del router. En nuestro caso 192.168.1.1

A continuación se detalla cómo realizar el proceso por Telnet. Haremos: Inicio -> Ejecutar -> telnet 192.168.1.1

Nos pedirá "Login"; en este caso le daremos a "intro" y no pondremos nada y entonces nos pedirá "pass2" , ahí pondremos la password 1234 .Una vez introducido esa pass nos saldrá una pantalla como esta:

Telnet

*
*                             ______
*                          __/_____/\
*                         /        /\\ Alcatel, Speed Touch 510 ADSL modem
*                  ______/__      /  \\
*                _/        /\____/__  \    Version R3.7.1.6
*               //        /  \      /\ \
*       _______//________/    \    / _\/_______  Copyright (c) 1999-2001 Alcatel
*      /      /  \       \    /   / /         /\
*   __/      /    \       \  /   / /         / _\__
*  / /      /      \_______\/   / /         / /   /\
* /_/______/___________________/ /_________/ /___/  \
* \ \      \    ___________    \ \         \ \   \  /
*  \_\      \  /           /\   \ \         \ \___\/
*     \      \/           /  \   \ \         \  /
*      \_____/           /    \   \ \_________\/
*           /___________/      \   \  /
*           \   _____   \      /____\/
*            \ /    /\   \    /___\/
*             /____/  \   \  /
*             \    \  /____\/
*              \____\/
*
-----------------------------------------------------------------------
=>_

Ahora escribiremos lo siguiente

Telnet

=>?_

Este símbolo nos abre la ayuda y nos muestra las distintas opciones:

Telnet

-----------------------------------------------------------------------
=>?
Following commands are available :
help              : Displays this help information
menu              : Displays menu
?                 : Displays this help information
exit              : Exits this shell.
..                : Exits group selection.
saveall           : Saves current configuration.

Following command groups are available :
adsl          atm         bridge           cip              config
dhcp          dns         env              firewall         ip
ipoa          mer         nat              phonebook        ppp
pptp          qosbook     software         system           td
upnp

=>_

Teclearemos, "nat".

Telnet

=>nat
[nat]=>_

Una vez realizado esto simplemente cambiará el "tag" por el "[nat]=>".
El siguiente paso para abrir el puerto es escribir "create".
Ahora nos irá pidiendo la información que hemos averiguado al principio, la IP privada.

protocol = introduciremos TCP o UDP.
inside_addr = introduciremos la IP privada de nuestro pc, la del ipconfig.
[inside_port] = introduciremos el puerto que queremos abrir.
outside_addr = introducimos 0.0.0.0
[outside_port] = Generalmente hemos de introducir el mismo puerto que en el apartado anterior "inside_port".
[foreign_addr] = Introduciremos la IP de nuestro pc como en "inside_addr" .
[foreign_port] = Introducimos el puerto que queremos abrir. El mismo que las dos veces anteriores.

Ahora se nos dará un resumen de todo lo que hemos hecho y estaremos seguros que la apertura se ha realizado. No está de más que introduzcamos "bindlist", como nueva medida de seguridad.
Por último, tecleamos "config save" para guardar todos los cambios.

Parte de esta información ha sido extraída de adslayuda.com

06.10.2004 16:00


558

 Comtrend 500

Hemos de tener el router conectado al ordenador mediante una tarjeta ethernet.
Ante todo necesitamos saber la dirección IP del router (puerta de enlace) y la dirección IP del ordenador.

Lo haremos a través de ms-dos:

  • win98: Inicio->ejecutar->command. Escribiremos winipcfg
  • win 2000 y xp: Inicio->ejecutar->cmd. Escribiremos ipconfig

Nos aparecerá por pantalla lo siguiente

C:\WINDOWS\system32\cmd.exe

Microsoft Windows XP [Versión 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig

Configuración IP de Windows

Adaptador Ethernet Conexión de área local          :

        Sufijo de conexión específica DNS :
        Dirección IP. . . . . . . . . . . : 192.168.1.34  1

        Máscara de subred . . . . . . . . : 255.255.255.0 2
        Puerta de enlace predeterminada   : 192.168.1.1   3

C:\Documents and Settings\Administrator>_

Tu IP privada en este caso es 192.168.1.34
Ejecutamos el internet explorer e, introducimos la Puerta de Enlace que hemos averiguado anteriormente. En este caso, http://192.168.1.1

Se nos abrirá la siguiente pantalla donde escribiremos el Login y el password, habitualmente "root" para ambos. Después pinchamos en "LOGIN".

Ya estamos dentro del router. A continuación pinchamos en "BASIC CONFIG"

Ahora, en la nueva pantalla, lo mismo que el paso anterior con NAT

En la misma pantalla nos aparecerá ahora " Server-Virtual Server Mapping-Fixed Port Translation". Le pinchamos.

Ya podemos empezar a introducir o modificar los Puertos. Nos aparece esta pantalla.

Ahora sí que empezamos a introducir los datos:

Protocol. Abriremos el Puerto en TCP o UDP.
Interface. Seleccionaremos ATM1.
Service Name. Describiremos brevemente el puerto.
Service Port. Ponemos el puerto que queremos abrir.
Private IP Adress. Introducimos la IP privada.
Private Port. Ponemos el Puerto que queremos abrir. El mismo que en "Service Port".
Ip Protocol Number. Introducimos 0.
Global IP Adress. Lo dejamos vacío, como ha de estar en estos momentos.
Pinchamos en "ADD".

No nos olvidemos de guardar y apagar y encender el router después de cada cambio.

Parte de esta información ha sido extraída de adslayuda.com

06.10.2004 16:19


663

 D-link Di-604

Ante todo necesitamos saber la dirección IP del router (puerta de enlace) y la dirección IP del ordenador.
Lo haremos a través de ms-dos:

  • Win98: Inicio->Ejecutar->command. Escribiremos winipcfg
  • Win 2000 y XP: Inicio->Ejecutar->cmd. Escribiremos ipconfig
Nos aparecerá por pantalla lo siguiente:

C:\WINDOWS\system32\cmd.exe

Microsoft Windows XP [Versión 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig

Configuración IP de Windows

Adaptador Ethernet Conexión de área local          :

        Sufijo de conexión específica DNS :
        Dirección IP. . . . . . . . . . . : 192.168.0.117 1
        Máscara de subred . . . . . . . . : 255.255.255.0 2

        Puerta de enlace predeterminada   : 192.168.0.1   3

C:\Documents and Settings\Administrator>_

Punto 1 del gráfico anterior: ésta es la IP local de nuestro PC. En nuestro caso, 192.168.0.117
Punto 2 del gráfico anterior: la máscara de subred.
Punto 3 del gráfico anterior: ésta es la IP de la puerta de enlace , que es la dirección IP del router. En nuestro caso 192.168.0.1

Ahora procedemos a abrir los puertos en el router a través del interfaz web. Para ello introducimos en la barra de direcciones del navegador la dirección del router que hemos obtenido (192.168.0.1).
A continuación nos identificamos como Admin y veremos la pantalla principal. En ella pulsamos en Advanced, creamos la regla primero para el puerto TCP:
Pulsamos en Apply y tras eso creamos la regla para el puerto UDP:

Le volvemos a dar a Apply y habremos acabado.

06.10.2004 16:20


559

 Puertos

La siguiente lista muestra los puertos usados por eMule cuando utilizamos la configuración que viene por defecto. Si se cambia alguna opción en Preferencias -> Conexión, se tendrá que tener en consideración en el momento de configurar el cortafuegos o el router.

1) | Puerto local: | 4662
 | Puerto Remoto: | cualquiera
 | Protocolo: | TCP
 | Dirección: | Entrante
 | Utilidad: | Puerto del Cliente / Conexiones desde otros clientes, Intercambio de fuentes entre Clientes
 | Nota: | Para cambiar el puerto dirigirse a Preferencias -> Conexión -> Puerto TCP. Este puerto ha de abrirse en el router. AL cambiar este Puerto en Preferencias también ha de abrirse en el router.
2) | Puerto local: | Cualquiera
 | Puerto Remoto: | 4662
 | Protocolo: | TCP
 | Dirección: | Saliente
 | Utilidad: | Puerto del Cliente / Conexiones a otros clientes, Intercambio de fuentes entre clientes
 | Nota: | 4662 es el Puerto por defecto, pero otros clientes pueden tener configuraciones diferentes. Cambie el Puerto remoto a cualquier otro cuando configure el cortafuegos.
3) | Puerto local: | 4672
 | Puerto remoto: | cualquiera
 | Protocolo: | UDP
 | Dirección: | entrante
 | Utilidad: | Protocolo extendido de emule, Posición en la cola, volver a preguntar por un archivo mediante Ping.
 | Nota: | Este puerto ha de cambiarse en el router. Al cambiar este Puerto en Preferencias también ha de abrirse en el router. Si no puede cambiar el puerto, compruebe la casilla desactivar en Preferencias -> Conexión -> Puerto UDP
4) | Puerto local: | cualquiera
 | Puerto remoto: | 4672
 | Protocolo: | UDP
 | Dirección: | saliente
 | Utilidad: | Protocolo extendido de emule, Posición en la cola, Volver a preguntar por un archivo mediante Ping.
 | Nota: | 4672 es el Puerto por defecto, pero otros clientes pueden tener configuraciones diferentes. Cambie el Puerto remoto por cualquier otro cuando configure el cortafuegos.
5) | Puerto local: | cualquiera
 | Puerto remoto: | 4661
 | Protocolo: | TCP
 | Dirección: | saliente
 | Utilidad: | Conectarse al servidor
 | Nota: | 4661 es el Puerto por defecto de un servidor. Muchos servidores utilizan puertos diferentes. Al configurar el cortafuegos, el Puerto Remoto puede ser, de nuevo, cualquiera.
6) | Puerto local: | cualquiera
 | Puerto remoto: | 4665
 | Protocolo: | UDP
 | Dirección: | saliente
 | Utilidad: | Fuente preguntando a los servidores
 | Nota: | Los servidores que usan el puerto 4661 TCP (ver#5) por defecto, fijan automáticamente su puerto para la fuente que pregunta, al 4665 UDP. Si un servidor usa un Puerto diferente en #5 el correspondiente Puerto UDP se fija a [Puerto de la conexión + 4]. Aquí, para el cortafuegos, el Puerto Remoto puede ser cualquiera.
7) | Puerto local: | 4711
 | Puerto remoto: | cualquiera
 | Protocolo: | TCP
 | Dirección: | entrante
 | Utilidad: | Servidor Web
 | Nota: | Este es el Puerto por defecto para el Servidor Web. Cuando se esté utilizando un router, este Puerto ha de ser abierto, si no la conexión al Servidor Web no se podrá realizar.

21.09.2004 11:55


560

 Actualizando la lista

En eMule, los servidores eDonkey2000 se usan para facilitar un punto de entrada a esa red. Es necesaria una conexión a un servidor para acceder a los recursos de la red y para que tu cliente sea visto por el resto de clientes de la misma.

En esencia, un servidor únicamente facilita un índice de los ficheros que son compartidos por los usuarios. La búsqueda de descargas o de fuentes se realiza a través de los servidores.

La actualización del listado de servidores sólo es necesaria para la primera conexión a la red. Cuando eMule consigue conectar a un servidor, dispone de funciones de actualización propias como son el Intercambio de Fuentes entre clientes o las actualizaciones automáticas de la lista de servidores.

En eMule la lista de servidores se puede actualizar de diferentes modos:

Parámetros útiles en Preferencias -> Servidor
o Auto-actualizar lista de servidores al iniciar
En la carpeta config bajo el directorio donde está instalado eMule se encuentra el fichero adresses.dat. Editarlo con un editor ASCII (por ejemplo el Bloc de Notas) e introducir una dirección URL válida que apunte a un fichero a server.met. Sólo se puede introducir una URL.
Activando esta opción, eMule actualizará al arrancar su listado de servidores desde la URL designada en adresses.dat.

o Actualizar lista de servidores al conectar a un servidor
En cierto modo los servidores eDonkey se conocen entre ellos. Activando esta opción eMule descargará la lista de servidores conocidos del servidor al que estés conectado.

o Actualizar lista de servidores al conectar un cliente
Esta opción actualiza a través de la conexión de tu cliente eMule con otro. Ambos clientes comparan sus listas de servidores y las actualizan mutuamente.

Nota:
Los dos últimos apartados mantienen permanentemente actualizada la lista de servidores. La actualización periódica de la lista de servidores no es necesaria.

Actualizar la lista de servidores desde una dirección URL

Introduce la dirección URL de un server.met en este apartado y presiona 'Actualizar'. La pestaña Registro muestra la información del número de servidores añadidos.

Añadir un único servidor

Introduce la dirección IP y el nombre del servidor para añadir manualmente una entrada a tu lista. Si en la pestaña Registro aparece el mensaje "¡Servidor no añadido!" es que ese servidor ya existía antes en tu lista.

Añadir servidores a través del IRC
Los canales oficiales de IRC de eMule disponen del comando !serverlist. Este comando te envía un mensaje con direcciones URL de listas de servidores. A través del chat de IRC los enlaces a ficheros server.met pueden ser añadidos directamente a la lista con un click.

Añadir servidores desde un enlace web
El protocolo eDonkey2000 permite enlaces a través de html, por ejemplo ed2k://|servidor|IP|puerto|/ añade directamente un servidor a la lista de tu eMule.

24.09.2004 15:04


561

 Direcciones de listas

eMule usa los mismos servidores que eDonkey2000, por tanto sus listas de servidores también son válidas para eMule.

Enlaces Web donde encontrar listas de servidores:
 | TheDonkeyNetwork
 | Lista de servidores para eDonkey2000 y eMule

Enlaces directos a listas 'well known ocbMaurice':
 |  | Lista por defecto
 |  | Todos los Servidores
 |  | Servidores activos
 |  | Los mejores Servidores
Notas:
> | Usando Google o cualquier buscador encontrarás muchos enlaces con ficheros server.met.
> | Puede que en este momento alguna de las direcciones anteriores esté inactiva o incluso muerta. Utiliza esta ayuda sólo como un punto de partida.
> | Agradecimientos a la gente que proporciona estos enlaces. Buen trabajo.

24.09.2004 15:05


562

 Uso de DNS dinámicas

El uso de direcciones IP dinámicas es una manera de incrementar el número de direcciones IP disponible para los clientes de los ISP. Muchos proveedores de servicio de internet (ISP) usan este sistema, por el que después de perder o cerrar la conexión, el cliente recibe una nueva IP, de valor diferente, al volver a conectar.

Esto puede ser un inconveniente para los servidores, ya que provoca el cambio de su dirección IP que es conocida por la red y por los usuarios.

Existen varios servicios gratuítos que ofrecen la posibilidad de solventar este inconveniente al asignar nombres estáticos (es decir, que no cambian) a direcciones IP dinámicas.

Introduce [emDynIP: NombreHostDinamico.host:Puerto] como mensaje de bienvenida en el servidor dServer.
Para un servidor con configuración por defecto, el puerto debería ser el 4661.

Esto fuerza a eMule a usar el nombre de host estático en lugar de la IP dinámica al conectar.
También permite la ventaja de añadir el nombre del host a la lista de servidores fijos en el fichero "staticservers.dat" con lo que esta dirección nunca se perderá.

Notas:
> | La longitud del nombre del host estático debe ser inferior a 51 letras.
> | Esta información es sólo para quien use un servidor en la red ed2k. Si sólo usas el cliente de eMule, no necesitas esta información.
> | Agradecimientos a todos los que tienen un servidor dServer en marcha. Estais prestando un gran servicio a la comunidad.

24.09.2004 15:05


563

 Buscando archivos

Buscar archivos en eMule significa normalmente que todos los servidores en la lista de servidores son preguntados si conocen a otro cliente que tenga un archivo con el que coincidan los términos de tu búsqueda. Los propios servidores no almacenan ningún archivo, sólo generan una lista de los archivos de los usuarios conectados.
La función de búsqueda avanzada en eMule permite hacer búsquedas precisas para los archivos en la red. Una búsqueda realizada con precisión es mejor, ya que las búsquedas realizan una considerable carga en los servidores. Por eso, eMule sólo busca un máximo de 201 resultados de cualquier búsqueda, o 300 si el servidor y nuestra versión soportan compresión gzip. Estas cifras en los resultados dependerán del servidor al que estemos conectados, ya que ese es un valor configurable a voluntad por el propio administrador. Si el servidor conectado puede dar más de 200 resultados, el botón Más aparecerá activo y permitirá preguntar por hasta 1200 resultados del servidor local.

Buscar
o Nombre
Este campo toma el término a buscar. Se pueden introducir múltiples términos y eMule mostrará sólo los que coinciden con todos ellos en el nombre del archivo. Para una búsqueda más precisa y flexible, vea la búsqueda booleana más abajo.
Esta casilla posee autocompletado, que almacena los términos introducidos en búsquedas previas. Para limpiar esta lista, mantenga pulsado CONTROL o ALT y pulse el botón DEL (o SUPR en su defecto), o use el botón Restablecer en Preferencias -> Mostrar. También puede desactivar esta opción aquí.

o Búsqueda con Unicode
Esta caraterística ha sido añadida a la versión 44a de eMule y permitirá la búsqueda de archivos con letras no latinas, p.e. Japonés, Hebreo, Árabe, etc. Como los clientes Unicode no están tan extendidos por el momento y las búsquedas Unicode pueden no ser tan productivas como las búsquedas ANSI, esta opción puede utilizarse para búsquedas específicas en Unicode. Sólo está activa si se introduce una letra Unicode.

o Tipo
El tipo puede usarse para filtrar los resultados por determinado grupo de extensiones. El tipo de descarga y su extensión asociada son las siguientes:
Todos | sin filtro
Archivos | .ace, .arj, .gz, .hqx, .lha, .rar, .sea, .sit, .tar, .tgz, .uc2, .zip, .7z
Audio | .669, .aac, .aif, .aiff, .amf, .ams, .ape, .au, .dbm, .dmf, .dsm, .far, .flac, .it, .mdl, .med, .mid, .midi, .mod, .mol, .mp1, .mp2, .mp3, .mp4, .mpa, .mpc, .mpp, .mtm, .nst, .ogg, .okt, .psm, .ptm, .ra, .rmi, .s3m, .stm, .ult, .umx, .wav, .wma, .wow, .xm.
Imágenes | .bmp, .dcx, .emf, .gif, .ico, .jpeg, .jpg, .pct, .pcx, .pic, .pict, .png, .psd, .psp, .tga, .tif, .tiff, .wmf, .xif
Imagen de CD | .bin, .bwa, .bwi, .bws, .bwt, .ccd, .cue, .dmg, .dmz, .img, .iso, .mdf, .mds, .nrg, .sub, .toast
Programas | .bat, .cmd, .com, .exe, .ace, .arj, .gz, .hqx, .lha, .rar, .sea, .sit, .tar, .tgz, .uc2, .zip, .bin, .bwa, .bwi, .bws, .bwt, .ccd, .cue, .dmg, .dmz, .img, .iso, .mdf, .mds, .nrg, .sub, .toast, .7z
Videos | asf, .avi, .divx, .m1v, .m2v, .mov, .mp1v, .mp2v, .mpe, .mpeg, .mpg, .mps, .mpv, .mpv1, .mpv2, .ogm, .qt, .ram, .rm, .rv, .vivo, .vob, .wmv

o Método
El método es la forma en que eMule hará las búsquedas. También hay motores de búsqueda web disponibles para la red eMule. Los resultados de esta búsqueda serán mostrados en el navegador.
> | Servidor Sólo se buscará en el servidor donde el cliente esté actualmente conectado.
> | Global (Servidor) Todos los servidores de la lista son preguntados. Cada servidor es preguntado individualmente. La barra verde de abajo muestra el progreso de la búsqueda.
> | Kademlia Se buscan los términos dados en toda la red Kademlia. Con este método no buscarás en la red eD2k. Los resultados pueden tardar un rato. Si una expresión de búsqueda popular no devuelve resultados, entonces posiblemente el puerto UDP esté bloqueado por un cortafuegos o un router.
> | Filedonkey Motor de búsqueda basado en web.

Filtro
o tamaño máx. / tamaño mín.
El tamaño mínimo y máximo es usado para restringir la búsqueda con resultados acordes al tamaño del archivo. Sólo se muestran los resultados mayores al tamaño mínimo y menores al tamaño máximo seleccionado. Si no se introduce ninguna abreviación, se asume Megabytes.
Unidad | Abreviaciones válidas
Bytes | b | byte | bytes
KiloBytes | k | kb | kbyte | kbytes
MegaBytes | m | mb | mbyte | mbytes
GigaBytes | g | gb | gbyte | gbytes

Ejemplo:
Tamaño mínimo = 200
Sin ningúna unidad especificada, sólo se mostrarán archivos con un mínimo de 200 mega bytes de tamaño.
Tamaño máximo = 1gb
El archivo no excederá el tamaño de 1 giga byte.

o Disponibilidad
Denota el número mínimo de fuentes que un archivo, de forma individual, debe tener para que se cuente como un resultado de la búsqueda.

Nota::
Este filtro no trabaja respecto a la disponibilidad global del archivo, sólo respecto a su disponibilidad en el servidor. Poner un valor demasiado alto en este campo puede llevarnos a no recibir ningún resultado, ya que el servidor quizás no tenga archivos con tantas fuentes.

o Extensión
Sólo los archivos con la extensión dada serán encontrados. La extensión tiene que ser introducida sin el punto que la precede. Por ejemplo, la extensión será avi, no .avi, y encontrará sólo los archivos de este tipo.

Búsqueda booleana
Esta función es usada para crear búsquedas complejas usando los operadores booleanos (o lógicos) NOT, AND y OR. Estos operadores siempre tienen que ser introducidos en mayúsculas, de lo contrario serán contados como palabras normales.
> | NOT Este operador se llama realmente NAND, que significa "and not" ("y no"). La palabra que siga a NOT será excluída de los resultados, y ninguno contendrá esta palabra. Formato: Término1 NOT Término2
> | AND Es el operador por defecto si no se especifica ninguno. Los resultados de las búsquedas con AND deben contener todos los términos vinculados con este operador. Formato: Término1 AND Término2 (equivale a Término1 Término2)
> | OR El operador OR significa que cualquiera de los términos introducidos vinculados con dicho operador serán un resultado. Formato: Término1 OR Término2
Notas:
> | Las búsquedas en Kademlia tienen siempre que empezar con un término de 3 o más letras. Después del primer término no debe de haber ningún otro operador booleano aparte de AND.
> | Excepto para FileDonkey, la búsqueda booleana puede combinarse con cualquier otro método o filtro.
> | Los operadores son evaluados de acuerdo a su precedencia matemática: NOT -> AND -> OR. Esta precedencia puede ser cambiada usando ( ) (paréntesis) alrededor de las expresiones que deben de ser evaluadas primero.
> | Para introducir en nuestras búsquedas palabras usadas como operadores boleanos o signos de paréntesis, deberemos "anular" esa condición boleana poniendo esos términos entre comillas, por ejemplo -> linux "and" security "("second edition")" .
> | Las búsquedas vinculadas con OR y NOT no son tan restrictivas como las búsquedas con AND. AND requiere todos los términos a coincidir mientras que OR y NOT permiten coincidencias parciales en otras palabras.
> | OR y NOT también tienen en cuenta la información de MetaDatos incluída en los ficheros, tal como los tags de mp3 o la información de autor / comentarios de los archivos.
Ejemplos:
> | Búsqueda: | término1 término2 OR término3 término4
 | Interpretación booleana | (término1 AND término2) OR (término3 AND término4)
 | Explicación: | Encuentra archivos que deben contener, o bien término 1+2 o término 3+4 en el nombre del archivo.
> | Búsqueda: | término1 término2 OR término3 término4 NOT término5
 | Interpretación booleana | (término1 AND término2) OR ((término3 AND término4) NAND término5)
 | Explicación: | Todos los archivos que coincidan con término 1+2 o término 3+4 que no contenga término 5.
> | Búsqueda | término1 término2 NOT término5 OR término3 término4 NOT término5
 | Interpretación booleana | ((término1 AND término2) NAND término5) OR ((término3 AND (término4) NAND término5)
 | Explicación: | Similar al ejemplo anterior, con la única diferencia que el término 5 nunca debe aparecer con 1+2 ni con 3+4.
> | Búsqueda | (término1 término2 OR término3 término4) NOT término5
 | Interpretación booleana | ((término1 AND término2) OR (término3 término4)) NAND término5
 | Explicación: | La misma búsqueda anterior, pero con una forma más elegante con la que usar paréntesis para aplicar la expresión NOT término5 a toda la expresión OR.
> | Búsqueda | (término1 "OR" término2) NOT término3
 | Interpretación booleana | (término1 AND or AND término2) NAND término3
 | Explicación: | Usando " " para incluir el término, el operador OR no es contado como tal sino como una expresión regular. Los resultados deben de contener término1 y 2 y también la palabra "or", pero no contener término3.

Interpretando los resultados
o Disponibilidad (fuentes)
La disponibilidad es el número de fuentes encontradas en los servidores para una descarga. No es el número total de fuentes en toda la red pero da a conocer cuánto está distribuido el archivo. Si hay diferentes coincidencias para una búsqueda el archivo con la mayor disponibilidad debería de ser elegido. Ver también Código de colores de los resultados de búsqueda.
El valor entre paréntesis detrás de la disponibilidad son fuentes que pueden ser añadidas directamente a la descarga sin que eMule tenga que buscarlas de nuevo.

o Código de colores de los resultados de búsqueda

> | Negro, azul oscuro, azul claro Indica el número de fuentes encontrados para un archivo específico. Negro = 1 - 3 fuentes, azul oscuro = 4 - 9 fuentes, azul claro = 10+ fuentes.
> | Rojo Son archivos que ya están en la lista de descarga.
> | Verde Son archivos que ya están descargados y completados.

o Buscando entre los resultados
Pulsando CONTROL + F se muestra un diálogo de búsqueda que puede buscar por términos (nombre de archivo), ID, tamaño, tipo y disponibilidad. La tecla F3 salta al próximo resultado encontrado con el mismo término de búsqueda mientras que SHIFT + F3 salta al previo.

o Múltiples nombres de archivo encontrados para un mismo archivo
Los archivos son identificados por su hash y no por los nombres. Una búsqueda puede devolver diferentes nombres para el mismo archivo. Esto se muestra delante del resultado mediante una cruz desplegable (+) al igual que en el Explorador de Windows. Si un resultado tiene diferentes nombres de archivo que no coinciden entre su mismo contexto, puede que sea un fake (un archivo con un nombre que no es el real).

Aplicado a las versiones: .42a +

28.09.2004 13:24


564

 Sistema de créditos

El sistema de créditos se usa para premiar a los usuarios que contribuyen con la red, por ejemplo, transfiriendo a otros clientes.
El estricto sistema de colas de eMule está basado en el tiempo que un usuario ha estado esperando. El sistema de créditos provee un mayor modificador (que es como eMule denomina al multiplicador que modifica el número que obtiene un cliente en una cola de peticiones) a este tiempo de espera tomando en consideración los datos de lo subido y lo bajado entre los dos clientes. Mientras más suba a un cliente, más rápido avanza en la cola del cliente.
El modificador se calcula tomando en cuenta la cantidad de datos transferidos entre los dos clientes. Los valores usados pueden ser vistos en el diálogo de detalles del cliente. Para ver dicha información, pulse con el botón derecho en cualquier usuario y seleccione Mostrar detalles.

Hay dos diferentes modificadores calculados:
 | Ratio1 = Total subido x 2 / Total bajado
 | Ratio2 = Raíz Cuadrada(Total subido + 2)
Ambos radios son comparados y el valor más bajo es usado como modificador.
También existen algunas condiciones:
 | > | Subido total < 1MB => Modificador = 1
 | > | Descargado total = 0 => Modificador = 10
 | > | El modificador no puede ser menor que 1 ni mayor que 10

Notas:
> | Todos los clientes que te transfieren son premiados por el sistema de créditos. Esto no cambia si el cliente soporta el sistema de créditos o no.
> | Si no lo soporta, no ganarás ningún crédito cuando le transfieras.
> | Los créditos no son globales. Son intercambiados entre dos clientes específicos.
> | Los créditos se almacenan en el archivo clients.met. El hash de usuario es usado para identificar al usuario.
> | Tus propios créditos son guardados en el cliente remoto. Esto evita la manipulación de créditos.
> | No hay ningún modo de ver tus propios créditos.

24.09.2004 14:55


565

 Identificación segura de usuario

Los clientes en la red son identificados por un valor único llamado hash de usuario. Este hash es almacenado en el archivo preferences.dat y es usado para ganar créditos con otros usuarios.
eMule puede usar una encriptación asimétrica para evitar la manipulación de otros hash de usuarios. Este método usa una clave privada y una clave pública para asegurar el hash de usuario y la identificación apropiada con otros clientes.

La identificación de usuario segura puede activarse en Preferencias -> Seguridad. Es recomendable usarlo.

¿Cómo funciona la identificación segura?

El cliente A quiere confirmar que sus créditos son seguros y sólo pueden ser usados por él. Se crea una clave privada RSA de 384 bit y la almacena en el archivo cryptkey.dat.
Esta clave privada se crea cuando la encriptación se usa por primera vez. Perder esta clave significa que el cliente A pierde todos sus créditos, puesto que no es posible probar que él es el auténtico propietario de ellos.

Cuando dos clientes que soportan encriptación intercambian datos por primera vez, ambos se envían una clave pública con un valor aleatorio. Cada uno almacena la clave del otro en su archivo clients.met. Sólo la clave es guardada, el valor aleatorio es generado de nuevo en cada conexión.

Si el cliente A quiere identificarse él mismo en el cliente B más tarde, crea una firma digital y la envía a B. Esta firma se crea desde su clave privada, la clave pública de B y un valor aleatorio. Es válido a menos que el cliente A cambie su IP o el cliente B cierre eMule.

Tras recibir la firma de A el cliente B comprueba si está creada desde su clave pública (de B) y el correcto valor aleatorio. Si además coincide con la clave pública del cliente A, entonces el cliente A está correctamente identificado.

Notas:
> | Si el archivo cryptkey.dat se pierde o se borra, el preferences.dat tiene que ser eliminado o no se podrán recoger nuevos créditos en los clientes ya conocidos.
> | Cuando se cambia a una identificación segura, los créditos "inseguros" se pierden. Por razones de seguridad, no hay forma de transferir estos créditos al sistema seguro.

Se aplica a las versiones: .29b +

24.09.2004 14:58


566

 Expulsión de clientes agresivos

Si otro cliente quiere descargar un archivo de ti, lo pedirá y preguntará por él cada 10-20 minutos para confirmar que todavía eres una fuente válida. Sin embargo, se puede modificar un cliente eMule para que pregunte con más frecuencia. Un cambio así daría al cliente modificado una mayor probabilidad de conseguir un puesto en la cola de subida a usuarios que usen clientes basados en eDonkey.
eMule no tiene en cuenta dicha frecuencia y las probabilidades de conseguir un mejor puesto en la cola de subida no aumentarán. Este comportamiento provoca pérdidas de recursos (conexiones y ancho de banda) y dichos clientes serán bloqueados.
El nuevo sistema de control de clientes bloqueará a los que pregunten demasiado a menudo (más de una vez por un archivo en 10 minutos), y no se les permitirá descargar de ti. La "lista negra" (la que contiene a los usuarios bloqueados) se limpia cada vez que se reinicia eMule.

Ejemplos de cómo puedes ser bloqueado (no podrás descargar de otros clientes que usen eMule):

> Configurando el parámetro que gestiona la frecuencia con la que se pide un archivo (reask) menor a 10 minutos.
> Pausando y reanudando tus descargas para incrementar tu velocidad de descarga - lo cual significará una nueva petición de archivo muy frecuente (sólo en los clientes eDonkey).
> Reiniciando tu cliente cada 2 minutos (lo que implica una nueva petición).

Aclarar que eMule no tiene en cuenta qué cliente pregunta (eMule/eDonkey/mldonkey). Cada cliente que pregunta con demasiada frecuencia será bloqueado.

24.09.2004 15:02


567

 Intercambio de fuentes
eMule es capaz de obtener las fuentes de otros clientes que estén realizando la misma descarga.

Para compartir correctamente los archivos, cada 10 minutos se pregunta aleatoriamente a un cliente de la lista de fuentes de una descarga en particular por sus fuentes.
Si el archivo tiene pocas fuentes (menos de 40), se pregunta a cada cliente que tenemos en cola por la lista de sus fuentes en dicho intervalo.

Sólo las fuentes con partes no encontradas se tienen en cuenta. Esto se hace a través del protocolo TCP y los paquetes son comprimidos para ahorrar ancho de banda.

Notas:
> | El protocolo usado no es compatible con el protocolo de propagación de fuentes de mldonkey.
> | El intercambio de fuentes de cliente a cliente se hace sobre el puerto 4662 del cliente usando el protocolo TCP.
> | Las fuentes con Low ID no son intercambiadas.

Se aplica a la versión: 0.22a +

20.08.2004 9:59


568

 Previsualizar archivos multimedia
Previsualización básica
Tan sólo pulsa con el botón derecho del ratón en el archivo y elige Previsualizar. eMule creará un archivo temporal en la carpeta 'temp' y lo abrirá con el reproductor multimedia asociado.

Formatos soportados hasta el momento:

- *.avi
- *.mpg
- *.mpeg
- *.divx
- *.xvid
- *.zip
- *.rar
- *.ace
- Cualquier formato multimedia si se usa VLC

Notas:
> | La previsualización sólo funciona cuando el primer y el último trozo ya han sido descargados y existe el suficiente espacio libre en el disco donde esté la carpeta de archivos temporales.
> | Necesitarás el códec correcto para el archivo que vayas a ver. Si no existe, se producirá un error o el archivo se reproducirá con audio, pero sin vídeo. Si no sabes qué códec necesitas, prueba un paquete de codecs.

Previsualizar archivos multimedia con VLC

VLC es un reproductor que permite visualizar prácticamente cualquier archivo multimedia. VLC trata el archivo multimedia incompleto como si se tratara de un stream que reproduces on-line a través de internet y es capaz de reproducirlo aunque esté dañado, incompleto o su contenido esté en la red.
Es el mejor reproductor para previsualizar archivos en eMule.

Usando VLC:
> | Descargar VideoLAN Client - VLC
> | Configura la ruta completa al archivo vlc.exe (normalmente C:\Archivos de programa\VideoLAN\VLC\vlc.exe) en Preferencias -> Archivos -> Reproductor de vídeo
> | Desactiva crear copia de seguridad en el mismo diálogo.
> | En Preferencias -> Preferences.ini configura PreviewSmallBlocks a 1. Aviso: Esta configuración bloqueará cualquier otro reproductor que no sea el VLC.

VLC y eMule Part File Access Module

eMule Part File Access Module es un plugin (un módulo adicional) para VLC desarrollado específicamente para reproducir archivos incompletos o dañados. Usando este plugin, dicho contenido puede ser reproducido sin bloqueos de imagen y sin pararse a buscar. Por ejemplo, se puede saltar a cualquier posición del vídeo. Leer la información de las partes disponibles para una descarga incompleta de eMule (archivos .part.met) ahorra tiempo de búsqueda de partes válidas.

o Descargando e instalando el plugin

> | Descarga el plugin de la página de eMule Project en la sección de Descargas.
> | Descomprime el archivo zip y copia el archivo libaccess_partfile_plugin.dll al directorio de plugins de VLC (normalmente c:\Archivos de programa\VideoLAN\VLC\plugins)
> | Configura eMule para usarlo con VLC como se describió antes.
> | Importante: El plugin sólo es compatible con la versión correspondiente de VLC:
 |  | Part File Access Modul v1.1 <=> VLC v0.6.2
 |  | Part File Access Modul v1.2 <=> VLC v0.7.0
 |  | Part File Access Modul v1.3 <=> VLC v0.7.1

o Configurando el plugin

Después de iniciar VLC, el diálogo de configuración del plugin puede verse en Configuración -> Preferencias -> Módulos -> access -> access_partfile

Enable plugin for MPEG / AVI / non MPEG or AVI part files
Estas tres opciones "activadas" deciden qué archivos deberían ser procesados por el plugin. "non MPEG or AVI part files" son archivos como .ogg, .ogm, .mp3, .mkv, etc.
Si es posible, VLC intentará usar sus módulos de acceso en lugar del plugin si alguna de estas opciones no está activada.

Provide a seekable stream for MPEG / AVI / non MPEG or AVI part files
A menudo, al intentar visualizar un archivo dañado o incompleto no nos es posible avanzar o retroceder a través de su índice, por ejemplo la barra de progreso o la función de avance rápido no puede usarse. Activando esta opción permitirá esta funcionalidad para las descargas incompletas de eMule.
Estas opciones sólo funcionan si el plugin está activado para el tipo de archivo específico. En algunos casos, especialmente con AVI u otro que no tenga contenido MPEG puede no funcionar correctamente.

Enable plugin for all type of files (eMule part files and regular files)
Este plugin está diseñado para usar con los archivos .part de eMule. El módulo de acceso por defecto en VLC tiene un fallo que puede bloquear todo el sistema cuando se intenta abrir un contenido incompleto o dañado. Este plugin provee una solución para este fallo con la opción de abrir todo el contenido soportado por VLC con este plugin en lugar del módulo por defecto. Activar esta opción provocará que todo el contenido soportado sea procesado por este plugin, sin importar que se haya abierto desde eMule, desde el explorador o desde la línea de comandos.
El eMule Part File Access Module es un reemplazo completo del módulo de acceso por defecto de VLC.

Diferentes aplicaciones para previsualizar
No todos los reproductores permiten ver igual de bien todos los tipos de archivos. Uno de los más flexibles es por supuesto Video Lan Client, pero otros como Media Player Classic o Zoom Player también funcionan muy bien con los archivos incompletos.
Se puede configurar eMule para que elija entre diferentes reproductores. Para ello, el archivo PreviewApps.dat tiene que crearse en la carpeta config de eMule. Es un archivo de texto plano creado, por ejemplo, con Bloc de Notas. Las aplicaciones usadas para previsualizar tienen que introducirse con el siguiente formato:

<Etiqueta> = <Ruta de la aplicación> <Argumentos de la aplicación>
<Etiqueta> | Es el nombre que aparecerá en el menú Previsualizar representando el nombre de la aplicación.
<Ruta de la aplicación> | Esto debe de reemplazarse con la ruta completa al ejecutable del archivo. Rutas con espacios deben de escribirse entre comillas ("")
<Argumentos de la aplicación> | Son los argumentos en línea de comandos opcionales para la aplicación.
Ejemplos:
VideoLAN Client 0.6.2=C:\Programas\VideoLAN-0.6.2\VLC\vlc.exe
VideoLAN Client 0.7.1=C:\Programas\VideoLAN\VLC\vlc.exe --config "%USERPROFILE%\Applicationdata\vlc\vlcrc-0.7.1"
Media Player Classic="C:\Programas\Media Player Classic\mplayerc.exe"
Notas:
o | Iniciar eMule como usuario limitado puede provocar que algunas aplicaciones no funcionen correctamente dado que todos los programas iniciados tienen restricciones de permisos.
o | Los argumentos de línea de comandos pueden ser variables de sistema como %USERPROFILE%. En este caso, la variable será reemplazada por la ruta de "Documents and Settings" con la apropiada carpeta de usuario. Se suele usar para configurar algunas aplicaciones para que funcionen correctamente con usuarios sin privilegios.

Previsualizar capturas de archivos de vídeo
Si otro cliente permite ver la lista de sus archivos compartidos (Preferencias -> Archivos -> Ver mis compartidos) es posible conseguir una imagen de sus archivos de vídeo compartidos.
Tan solo pulsa con el botón derecho en un vídeo y selecciona Previsualizar. Pedirá cinco capturas de este archivo. Las capturas serán mostradas en un visor separado tan pronto como sean recibidas. Puede tomar un rato hasta que se reciban. Esta función sólo está disponible a partir de la versión 0.30b.

Se aplica a la versión: .42b +

24.09.2004 15:10


569

 Firma en línea
Si la opción Activar Online-Signature está activada en el diálogo de preferencias, eMule creará el archivo onlinesig.dat en el directorio de su instalación.

Formato del archivo onlinesig.dat:
[Estado de conexión] | [Servidor conectado] | [IP:puerto]
[Velocidad de descarga actual] | [Velocidad de subida actual] | [Usuarios en cola]

En el futuro, puede que esta función sea ampliada para añadirle un servicio de identificación remota, aunque actualmente hay una herramienta creada por Dra.:.god llamada Online Signature. Ésta te permite modificar una imagen con los datos del archivo onlinesig.dat y enviarla a un espacio web a través de FTP.

Se aplica a la versión: .22a +

20.08.2004 10:01


570

 Charla por IRC

El módulo Charla en IRC (Internet Relay Chat) de eMule te conectará con alguno de estos servidores:

irc.freshIRC.com
ircchat.emule-project.net
irc.freshirc.de

Si estás buscando ayuda o quieres visitarnos ve a:

> #emule (en Inglés)
> #emule-german
> #emule-french
> #emule-spanish

Mira Preferencias -> IRC para los detalles de configuración del IRC.

Reglas:

> No mandes mensajes privados a los operadores (gente con @ delante de su nombre)
> No pidas ni ofrezcas productos o cualquier otro material con derechos de copia (copyright)
> No llenes los canales con scripts
> Nada de publicidad en los canales

Para versiones: 0.22b +
24.09.2004 15:13


571

 Amigos

La red eDonkey es grande, así que encontrar otra vez a alguien es difícil. La característica Amigos ofrece una manera fácil y conveniente de no perder de vista a la gente con el mismo interés o gustos. Especialmente para grupos con ficheros en lanzamiento esta es una valiosa adición.

Menú Contextual de la Fuente (pulsar botón derecho en una fuente de la lista de transferencia)

o Mostrar detalles
Muestra información sobre los datos transferidos, índices y modificadores de este usuario.

o Añadir a Amigos
Un usuario añadido como Amigo muestra el icono de Amigo en lugar del icono de cliente y aparece en la lista de la pestaña de Mensajes.

oEnviar un mensaje
Inicia una charla privada con este usuario (chat privado).

o Ver archivos
Dependiendo de lo establecido en Preferencias -> Archivos puedes solicitar la lista de los archivos compartidos de un Amigo. Ten en cuenta que la configuración por defecto del eMule para Ver Archivos es denegar esa petición. Si la petición es aceptada, los archivos de este usuario son mostrados en la pestaña de Búsqueda.

Acciones con Amigos
Los Amigos añadidos son listados en la pestaña de Mensajes y permite varias acciones.

o Mostrar detalles
Igual que lo arriba indicado.

o Quitar Amigo
Quita un Amigo de la lista.

o Enviar un mensaje
Igual que lo arriba indicado.

o Ver Archivos
Igual que lo arriba indicado.

o Establecer un puesto Amigo
Se puede asignar a un Amigo un puesto reservado de subida tal que le permita realizar una conexión directa sin tener que esperar en la cola.
Sólo está permitido un puesto reservado.

Iconos de Amigos

Este amigo está actualmente transfiriendo o conectado.

Un amigo está en la lista actual de clientes conocidos.

Su estado es desconectado o desconocido.

Nota:
El estado de los Amigos no es actualizado con regularidad para conservar ancho de banda. Para conocer el estado actual se ha de realizar una acción.

Para versiones: .23a +
09.10.2004 8:03


572

 Filtro de IP

A veces ocurre que los usuarios envían, intencionadamente o sin saberlo, información corrupta. Esto puede impedir que un archivo se complete apropiadamente o que el archivo se vuelva totalmente corrupto.
eMule introduce un filtrado básico de IPs. El rango de IPs a filtrar está almacenado en un archivo llamado ipfilter.dat, el cual está guardado en la carpeta Config del eMule. Esta lista negra tiene el siguiente formato (igual que cDonkey):

# Ejemplo de un archivo "ipfilter.dat"
#
# Todos los rangos IP introducidos serán bloqueados en eMule para subidas y descargas
# Sé extremadamente cuidadoso con lo que introduces aquí. Las entradas incorrectas pueden bloquear totalmente el acceso de eMule a la red
#
# Formato:
# Rango-IP , Nivel de Acceso , Descripción
#
# Nivel de acceso:
# <127 bloqueado
# >=127 permitido

064.094.089.000 - 064.094.089.255 , 000 , Gator.com

Esta entrada bloqueará las IPs desde 064.094.089.000 hasta 064.094.089.255, p.e. eMule no conectará a ninguna IP dentro de este rango, ni para subida ni para descarga de información.

Advertencia:
El ejemplo de arriba limitará cualquier conexión al rango de IP especificado. Esto puede reducir el número de fuentes para descargas.

Por el momento sólo hay implementado un nivel de acceso. Un valor por debajo de 127 (valor por defecto Preferencias -> Seguridad) significa que cualquier intento de conexión es denegado.

Actualización del Filtrado de IP (ipfilter.dat)
En Preferencias -> Seguridad está la opción Actualizar desde URL. Añade un enlace al archivo de filtrado, p.e. http://www.iespana.es/IPFILTER/ipfilter.dat, http://www.hk-tcm.net/p2p_web/Guarding.P2P o http://www.garnerhk.com/p2p/Guarding.P2P y pulsa Cargar. Los formatos de filtrado de listas de IP usados en PeerGuardian Methlabs, o Lussnig's IP Filter son soportados por esta función. Enlaces que apuntan a un archivo *.zip también se pueden utilizar si la lista que contienen está en el formato adecuado.

Herramientas del Filtrado de IP
En el área de Herramientas o en el Menú rápido (Alt+x) puedes usar las herramientas del Filtro de IP para añadir listas adicionales, borrar entradas y otras manipulaciones. Además se muestra una estadística de cuán a menudo fue filtrada una IP determinada.

Notas:
• | El fitrado evitará enviar y descargar datos de los clientes bloqueados
• | No es posible añadir a un cliente a la lista de IPs filtradas mediante un click ni nunca lo será
• | El filtrado se realiza a nivel TCP, de forma que no se realiza ninguna conexión con los clientes bloqueados

21.08.2004 16:33


573

 Categorías

Todos los archivos, listados en la ventana de Tráfico, pueden ser añadidos a categorías definidas por tí mismo. La primera categoría es siempre Todo que muestra o todas las descargas o bien aquellas filtradas por la selección de la Vista de Filtros. Para acceder a las opciones de categorías, pulsa el botón derecho del ratón sobre cualquiera de las categorías existentes mostradas en las pestañas.

Seleccionar Vista de Filtros
Esta opción sólo está disponible en la primera categoría (todos) y te permite filtrarla para ciertos tipos o estados de archivos.

Todo: | Sin filtro, se muestran todos los archivos
Sin catalogar | Sólo se muestran las descargas que no están en ninguna categoría autodefinida
Incompleto, Completo, Esperando, Descargando, Erróneo, Pausado, Detenido | Filtra la lista de acuerdo con el estado de la descarga como se muestra en la columna Estado
Video | Archivos de video con las siguientes extensiones .mpg, .mpeg, .avi, .divx, .rm, .ram, .wmf, .asf, .vivo, .mov, .ogm, .vob
Audio | Archivos de audio: .wav, .mp3, .ogg, .mp4, .aac, .flac, .ape, .au, .wma, .mpc, .mp2
Archivo: | Archivos comprimidos: .rar, .zip, .ace, .gz
Imagen de CD | ..cue/.bin (CDRWin), .mds/.mdf (Alcohol120%), .ccd/.sub (CloneCD), .bwa/.bwt/.bwi/.bws (BlindWrite), .nrg (Nero), .iso

Añadir Categoría
Crea una nueva Categoría. Los ajustes a elegir para esta categoría son opcionales y se utiliza la carpeta Incoming a menos que se especifique otra cosa.

o Título
Nombre de la categoría que se mostrará.

o Comentario
Descripción o comentario.

o Archivos entrantes
Se puede utilizar un directorio Incoming separado para cada categoría. Los archivos completos son movidos a esta carpeta. eMule utiliza la carpeta por defecto cuando se deja vacía esta casilla.

o Cambiar prioridad a los nuevos archivos asignados
A los archivos añadidos dentro de esta categoría se les establecerá automáticamente la prioridad especificada.

o Auto-Asignar Categ. (formato separado por |)
Cuando se comienzan nuevas descargas, éstas pueden ser asignadas automáticamente a esta categoría si el nombre del archivo coincide con un patrón dado. Se utiliza. | para separar diferentes términos y * como comodín para una cadena cualquiera de caracteres.
Ejemplo: *.avi|a*.*
Esto asignaría los nuevos archivos con la extensión 'avi', y los archivos cuyo nombre comienza con 'a' a esta categoría.

o Color
Define el color utilizado para los archivos de esta categoría. Este ajuste también afecta a la categoría Todos para mostrar todos los archivos y su correspondiente categoría de un vistazo.

Editar Categoría
Todos los ajustes de Añadir Categoría pueden ser cambiados en cualquier momento.

Eliminar Categoría
Borra la categoría seleccionada. Los archivos en la categoría no se verán afectados y pasarán a formar parte de la categoría Todos.

Prioridad, Cancelar, Detener, Pausar, Reanudar
Estos comandos se aplican a todos los archivos de la categoría. Cuidado con el comando Cancelar.

Descargar en orden alfabético
Lee el apartado Administración de fuentes para obtener más detalles sobre prioridades en las categorías y esta opción.

Reanudar siguiente archivo pausado
Al completarse una descarga, se reanudará otra pausada de la categoría elegida.

Añadir archivos a Categorías
Se pueden añadir archivos a categorías mediante el menú contextual de descarga (botón derecho del ratón) -> Asignar a categoría o mediante "arrastrar y soltar". Selecciona una descarga, mantén presionado el botón izquierdo del ratón y arrastrala a la categoría deseada. Se pueden seleccionar varios archivos mediante las teclas CTRL o SHIFT (Mayúsculas).
En la ventana de Búsqueda los archivos pueden ser añadidos directamente a las categorías seleccionándola con los botones situados en la parte baja de la ventana de búsqueda antes de efectuar la descargar.
Nota: Si no has creado ninguna categoría, tán sólo te aparecerá la pestaña de la categoría Todo en la ventana de Tráfico, "Asignar a categoría" del menú contextual de descarga aparecerá sombreado y además no te aparecerán los botones de categorías en la ventana de Búsqueda.

Para versiones: .43a +

12.09.2004 9:06


574

 Interfaz Web
La opción Servidor Web proporciona a eMule el acceso remoto y la administración de sus funciones y ajustes. La Interfaz Web puede ser abierta dentro de cualquier navegador mientras sea conocida la dirección IP real de la máquina que contiene eMule.

Para conectar al Servidor Web , la dirección IP y el correspondiente puerto del servidor han de ser introducidos como dirección en el navegador. La dirección ha de tener la apariencia de una URL normal, p.e. http://xxx.xxx.xxx.xxx:puerto. Las Xs representan la dirección IP real y el puerto es el 4711 si se usan las configuraciones por defecto del Servidor Web. Si la conexión se realiza a través de un router, el puerto usado por el Servidor Web se debe abrir o redirigir en él para que el acceso a esta función sea posible. Encontrarás más información en el tema Puertos de esta ayuda
Para probar el servidor en la misma máquina donde se está ejecutando el eMule introduce como dirección la dirección local del sistema http://127.0.0.1:4711.

IPs Dinámicas
Muchos ISPs proveedores de accesos telefónicos a internet fuerzan una desconexión cada 24h para asignar una nueva dirección IP al volver a marcar. Para acceder al Servidor Web, se ha de conocer la dirección IP real.
Muchos servicios proporcionan de manera gratuita una solución práctica para conocer en cualquier momento la IP real de una IP dinámica. Estos servicios permiten asignar una dirección estática del host como http://miDirección.miHostEstático.com a máquinas con IP dinámica. Una pequeña utilidad, llamada Dynamic DNS Client Program, que ha de ejecutarse en el ordenador donde está ejecutándose eMule, actualizará la dirección IP al host estático cada vez que la IP cambia. Ahora se puede acceder sencillamente al Servidor Web sobre el host estático http://miDirección.miHostEstático.com:4711.

Si se introduce la dirección correcta, la ventana de acceso es mostrada. Para entrar a la Interfaz Web proporciona la contraseña establecida en las preferencias del Servidor Web.

Importante:
Está firmemente recomendado establecer una contraseña propia en preferencias. Si no se establece una contraseña de administrador, cualquiera puede acceder a tu eMule y establecer preferencias, borrar o añadir archivos, etc.

En esta Interfaz Web se proporciona el acceso a casi todas las funciones del eMule. Todos los cambios afectarán directamente a eMule en el PC servidor.

Para versiones: .27b +

10.09.2004 16:59


575

 Línea de comandos

Algunas de las funciones básicas en eMule pueden ser controladas mediante la línea de comandos. Esto permite la ejecución en archivos de procesamiento por lotes o el acceso remoto a eMule en una sesión de Telnet.

Sintaxis:
emule.exe estado

• | status
Escribe información sobre las actuales transferencias en el archivo status.log
• | connect
Conecta a un servidor
• | disconnect
Se desconecta de un servidor
• | limits=up,down
Establece los límites para la velocidad de subida y descarga. Igual que en Preferencias -> Conexión -> Límites
• | resume
Reanuda cualquier archivo pausado o detenido en la lista de descargas
• | restore
Restaura una tarea minimizada del eMule
• | ignoreinstances
Permite múltiples ejecuciones de eMule. Nota: Para correr dos eMules en la misma máquina han de ser instalados en diferentes carpetas, deben tener diferentes carpetas temporales (Temp Folder) y además los puertos utilizados por cada eMule han de ser únicos (no los mismos). No está recomendado correr dos eMules simultaneamente excepto con propósitos de testeo.
• | exit
Sale de eMule
• | assertfile
Opción de depuración. Escribe información posiblemente útil a un archivo en lugar de interrumpir el programa.

24.09.2004 15:16


576

 MuleMRTG

La serie Windows NT (NT, 2k, XP, 2003) muestra tanto a través de ficheros de log como por pantalla, información sobre el rendimiento de aplicaciones mediante la cónsola "Rendimiento" (perfmon.msc). eMule (versiones superiores a 0.42a) permite también acceder a algunos datos de ejecución en el mismo formato que la consola "Rendimiento".

MRTG - Multi Router Traffic Grapher es una herramienta que presenta esta información en forma de gráficos en documentos HTML. En primer lugar, esta herramienta se utiliza para controlar el tráfico de entrada y salida de servidores o routers pero sirve igualmente bien para la supervisión a largo plazo del eMule. Mira este ejemplo.

El siguiente procedimiento describe cómo configurar MRTG como un servicio NT usando el instalador proporcionado en la página de descarga.
Funciona sólo en Windows NT, 2k, XP, 2003 no en Win9x/ME

• | Descarga e instala Active Perl con la configuración por defecto
• | srvany.exe y intsrv.exe son necesarios para ejecutar MRTG como un servicio. Descarga Windows Server 2003 Resource Kit Tools (el instalador MS funciona sólo para XP y 2003 no para 2k, el srvany que contiene funciona en 2k) o busca en Google para descargarlo. Copia los dos ficheros a una carpeta.
• | Descarga y ejecuta el instalador MuleMRTG. Debes especificar la ruta donde está instalado el Active Perl (p.e. C:\Perl) y la ruta a srvany.exe. Las otras rutas ya deben haber sido rellenadas con las rutas correctas. Las rutas utilizadas no deben contener ningún espacio en blanco o terminar en \

MRTG obtiene cada 5 minutos una lectura de los datos de rendimiento del eMule y crea una salida en HTML para ver. Los archivos HTML son almacenados en el Directorio de Salida HTML y puede abrirse con cualquier navegador. Tan sólo hacer un doble clic sobre el archivo index.html.

MRTG se usa para estadísticas a largo plazo. Tarda entre 10 y 15 minutos en mostrar la primera gráfica diária..

Para versiones: v.42.a+

24.09.2004 15:17


577

 Enlaces eD2K

Los enlaces eD2k son un formato especial de enlaces que permiten añadir una descarga directamente a eMule. Estos enlaces permiten a los webmasters ofrecer descargas directamente desde sus páginas web y hacer más fácil intercambiarlas en la red. Un buen sitio para buscar enlaces es en eMule Content DB.

Formato de enlace
eMule soporta muchas maneras sofisticadas de generar y usar estos enlaces.

• | Enlaces eD2k básicos
 | ed2k://|file|<archivo>|<tamaño del archivo>|<hash del archivo>|/ La forma más básica de un enlace eD2k contiene sólo lo necesario.
• | Enlaces eD2k con hash set
 | ed2k://|file|<archivo>|<tamaño del archivo>|<hash del archivo>|p=<hash set>|/ El hash set completo, es decir, cada uno de los hash de cada trozo de 9,28MB en el que se divide el archivo (este trozo es conocido como chunk), asegura que siempre sea correcto y ayuda a distribuir archivos nuevos y poco distribuidos.
• | Enlaces eD2k con fuentes
 | ed2k://|file|<archivo>|<tamaño del archivo>|<hash del archivo>|/|sources,<IP:puerto>|/ Añade una o varias fuentes ya conocidas en el formato IP:puerto al enlace, ofreciendo fuentes instantáneas para la descarga.
• | Enlace eD2k con host
 | ed2k://|file|<archivo>|<tamaño del archivo>|<hash del archivo>|/|sources,<nombre del host:puerto>|/ Lo mismo que el anterior, pero en lugar de usar una IP utiliza un nombre de host. Ofrece mayor flexibilidad especialmente con IP's dinámicas. Un nombre del host debe de configurarse en Preferencias -> Opciones adicionales -> Nombre PC para enlaces eD2K propios
• | Enlace eD2k en HTML
 | <a href="ed2k://|file|<archivo>|<tamaño del archivo>|<hash del archivo>|/">nombre mostrado en la página web</a> Forma fácil de crear un enlace ya preparado para mostrar en una página web.
• | Enlace eD2k con fuentes HTTP
 | ed2k://|file|<archivo>|<tamaño del archivo>|<hash del archivo>|s=http://cualquierweb.net/archivo|/ eMule también puede descargar directamente desde fuentes de páginas web. Un formato muy útil y conveniente para webmasters. Ver Link Creator en el siguiente párrafo para más información.
• | Enlaces eD2k con Hash Raíz
 | ed2k://|archivo|>nombre de archivo<|>tamaño del archivo<|>hash del archivo<|h=>Hash Raíz<|/ Los enlaces con Hash Raíz AICH permiten métodos avanzados de comprobación y corrección de errores al suministrar un valor de confianza para el AICH (Método Avanzado de Gestión Inteligente de la Corrupción). Leer aquí para más información sobre AICH y Hash Índice AICH.

Crear enlaces en eMule
En eMule es muy fácil generar cada enlace eD2k excepto por los enlaces HTTP. Selecciona cualquier descargar en tu lista y pulsa el botón derecho del ratón:

La ventana de Archivos Compartidos ofrece más posibilidades para los archivos completos:

Link Creator
Los webmasters que lanzan software popular a menudo tienen el problema de que los mirrors están saturados y que hay un tráfico inmenso por el nuevo lanzamiento. Ofreciendo descargas eD2k y de fuentes en el mismo enlace pueden ayudar en esta situación. Esto ofrece una manera para que los usuarios puedan añadir la descarga a eMule como si fuese un gestor de descargas, distribuyendo el archivo en la red y dando una alta velocidad a través de los servidores HTTP.
Link Creator es una herramienta fácil de usar y muy rápida para generar estos enlaces.

Tan sólo introduce el archivo para calcular su hash y generar el enlace. Se pueden añadir fuentes HTTP opcionales. Utiliza el botón "Remove" para eliminar una fuente HTTP seleccionada o el botón "Clear" para borrarlas todas.
Es recomendable añadir el hash set también para mejorar la calidad de la descarga. Pulsa el botón "Start" para generar el enlace.

28.09.2004 14:11


578

 Manejo de fuentes

Encontrar fuentes en la red es de vital importancia. De hecho, los servidores, la red Kademlia y eMule en sí mismo están pensados con la finalidad de ser capaces de encontrar fuentes con la mayor eficiencia posible. Para un mayor rendimiento de eMule debemos entender necesariamente una serie de conceptos. La lista de fuentes para cada descarga se muestra pulsando dos veces con el ratón sobre dicha descarga. Para ver la información y acceder a la gestión avanzada de fuentes debemos tener activada la opción "Mostrar mas controles (controles básicos avanzados)" en Preferencias -> Opciones adicionales

• | Búsqueda de fuentes para las descargas
 | eMule utiliza diferentes métodos para encontrar fuentes para las descargas. Pulsando dos veces con el ratón en una descarga se nos mostrará la procedencia de esas fuentes en la columna Tamaño
 | - | eD2k Server La fuente se encontró preguntando al servidor al que estamos conectados justo al inicio de la descarga o se añadió posteriormente a través de las búsquedas que en intervalos regulares efectúa nuestro eMule a los servidores que componen la Lista de servidores.
 | - | Kademlia Kademlia nos ofrece una manera muy rápida de encontrar fuentes de un gran número de usuarios distribuidos sin la necesidad de servidores centralizados. Para más información consulta la Guía sobre las Redes.
 | - | Intercambio Fuentes Tras añadir una fuente para una descarga en particular, eMule busca en esas fuentes por si conocen otras fuentes que todavía no hayamos localizado. En caso afirmativo, el cliente con el que estamos conectados nos mandará una lista de esas fuentes.
 | - | Pasivo Las fuentes pasivas son otros clientes que conectan con nosotros. Si esos clientes no son conocidos en alguna de nuestras descargas eMule les pregunta a ver si pueden ser fuentes para alguna de las mismas y en caso afirmativo las añade como fuentes a su respectiva descarga.
• | Número total de Fuentes Básicamente a mayor número de fuentes encontradas, más rápida será nuestra descarga, pero hasta cierto límite. Un número total de fuentes excesivo ralentizará nuestro eMule y congestionará nuestra conexión debido a la gestión de fuentes, esto ralentizará nuestras descargas. El total de fuentes encontradas para todas las descargas se muestra en Estadísticas -> Transferencia -> Descargas -> Fuentes encontradas. Esta cifra no debería exceder de 3.000
• | Estado de las Colas y de las Fuentes Una vez añadimos a un cliente como Fuente, se le pregunta por el estado de sus fuentes. Los posibles estados son:
 | - | En Cola y QR: nn QR (Queue Rating) significa Puesto en la Cola. Nos muestra el lugar en el que nos encontramos en la lista de espera de ese cliente. Cuando llegamos al principio de la cola (QR:1) esa fuente empezará a enviarnos la descarga. El uso del Sistema de Créditos modifica la velocidad de avance en la cola.
 | - | Cola llena Otros clientes estaban esperando antes y ya se ha alcanzado el Tamaño máximo de la cola de espera fijado por ese cliente.
 | - | Demasiadas conexiones En ese momento eMule está demasiado ocupado buscando otras fuentes, así que esa fuente en particular se retrasará hasta que quede una conexión libre para ella. Normalmente este estado desaparece rápidamente. Si no es así, eMule está funcionando con demasiadas fuentes. Consulta el apartado "Número total de Fuentes" del punto anterior.
 | - | No se necesitan partes (acrónimo: NNP) La fuente no tiene ninguna parte de las que faltan a nuestra descarga. Las partes disponibles de una fuente concreta se muestran en la Barra de Progreso.
 | - | Se le ha pedido otro archivo (acrónimo: A4AF) A4AF (Asked For Another File). Una fuente concreta sólo puede ser usada para una única descarga. Si esa fuente tiene partes disponibles para otra de nuestras descargas, eMule decide qué descarga tendrá preferencia. En ese momento las otras descargas mostrarán esa fuente como "(A4AF) Se le ha pedido otro archivo". El siguiente párrafo nos explica la compleja gestión de esas fuentes.

Gestión avanzada de A4AF

El gráfico nos muestra unas descargas junto sus fuentes encontradas (con la opción "Mostrar mas controles (controles básicos avanzados)" activada). Por ejemplo, el cuarto fichero tiene 27 fuentes en total, de las que 26 son útiles y 49 A4AF.
Si las descargas corresponden a una serie de ficheros o están "cortadas" en partes múltiples, eMule mostrará una distribución de fuentes tal como se muestra en el gráfico superior para Fichero1_parte_n. Lo más probable es que las fuentes encontradas para alguno de los ficheros puedan proveernos partes de los otros ya que se les supone una distribución conjunta. eMule sólo pone en cola una de las fuentes, por esto observamos en el gráfico esa gran cantidad de A4AF. eMule nos ofrece dos herramientas en este menú contextual para gestionar esas fuentes A4AF: la Prioridad y la opción Intercambiar automáticamente todas las fuentes (A4AF) a ÉSTE archivo.
También el menú contextual de Categorías nos ofrece la posibilidad de gestionar las fuentes con A4AF. En él encontraremos las opciones Prioridad y Descarga en orden alfabético

El sistema de gestión de A4AF de eMule decide cuál de los ficheros asume una fuente en el siguiente orden:
• | Intercambiar automáticamente todas las fuentes (A4AF) a ÉSTE archivo (mayor preferencia) Sólo un fichero puede tener marcada esta opción y siempre se quedará con las fuentes A4AF.
• | Categoría - Prioridad Los ficheros dentro de una categoría con Prioridad alta tendrán preferencia ante los que no tengan categoría o los que tengan una Prioridad más baja.
• | Descargas - Prioridad Dada una categoría, la Prioridad de descarga decide cuál de los ficheros se queda con las fuentes.
• | Descarga en orden alfabético (la menos importante) Asigna las fuentes según el nombre del fichero a descargar. En el ejemplo anterior de Fichero1_parte_n, esto significa que Fichero1_parte_1 se queda con todas las fuentes A4AF, cuando se acaba de descargar éstas pasan a Fichero1_parte_2 y así sucesivamente. Para descargas que tengan un formato así, es preferible crearles una categoría propia. Asegúrate que los ficheros están nombrados en orden alfabético y activa esa opción. Para renombrar una descarga pulsa F2, pulsa el botón central del ratón sobre él o escoge Información -> Nombre en el menú contextual.
Notas:
• | Asignar a una categoría la opción de Descarga en orden alfabético cambiará la Prioridad de todos los ficheros de esa categoría a Normal. Los ficheros que se añadan posteriormente a esa categoría mantendrán su propia prioridad. Para que esos ficheros se descarguen en orden alfabético, asegúrate de ponerles la misma prioridad que al resto de la categoría (no pongas Auto)
• | La gestión A4AF comprueba si una fuente puede ser cambiada a prioridad baja para permitir el Intercambio de Fuentes entre clientes. Esto asegura que incluso las descargas con prioridad más baja encuentren rápidamente todas las fuentes posibles.
• | El cambio en la asignación de fuentes a una descarga debe ajustarse al tiempo mínimo de comprobación de la cola (reask) establecido en la red. Puede que tengas que esperar hasta 30 minutos para que cambie una asignación de fuentes.
• | Una fuente con un QR menor de 50 nunca llegará a cambiar desde la descarga con prioridad más alta para tener la seguridad que la descarga se iniciará desde esa fuente.

Aplicable a la versión 0.43a en adelante
12.09.2004 9:52


661

 Gestión de la corrupción

El eMule emplea diversos medios para asegurarse que los ficheros se comparten en la red y se descargan sin errores. Si sucediese un error, denominado corrupción, eMule posee funciones avanzadas para corregir esa corrupción descargando de nuevo una cantidad mínima de datos.

Hash de ficheros e ICH - Gestión Inteligente de la Corrupción

Hash de ficheros, Hash de partes y Conjunto de Hashes
Para cada fichero que se comparte en la red se crea una identificación única empleando el algoritmo matemático de encriptación MD4. Este valor se llama Hash de Fichero y se encuentra en todos los enlaces eD2k normales, ej.

ed2k://|file|name|12043984|6744FC42EDA527B27F0B2F2538728B3E|/

donde 6744FC42EDA527B27F0B2F2538728B3E es el hash de fichero que hace que sea identificado de forma única en toda la red.
Este Hash de Fichero se calcula dividiendo todo el fichero en partes de 9.28 MB. Para cada una de estas partes se calcula un Hash de Parte empleando el mismo algoritmo MD4. Estos Hash de Partes, llamados Conjunto de Hashes, se emplean para calcular el Hash de Fichero final. Por ejemplo, un fichero de 600 MB se dividiría en 65 partes, cada una con su propio Hash de Parte, que se usan entonces para crear dicho Hash de Fichero.
Para asegurarse que eMule siempre recibe el Conjunto de Hashes correcto se puede crear un enlace especial que lo contenga, ej..

ed2k://|file|nombre|12043984|6744FC42EDA527B27F0B2F2538728B3E|p=264
E6F6B587985D87EB0157A2A7BAF40:17B9A4D1DCE0E4C2B672DF257145E98A|/

donde el valor de p= indica el Hashset. Cada Hash de Parte se separa por un ":". Este fichero tiene un tamaño de 12043984 Bytes (=11.49 MB) lo que significa que tiene una parte de 9.28 completa, y otra con el resto hasta los 11.49 MB lo que supone dos Hash de Partes.

ICH (Intelligent Corruption Handling) Gestión Inteligente de la Corrupción
Cada vez que eMule finaliza una de esas partes comprueba si los datos que se han descargado coinciden con el Hash de Parte para esa parte finalizada. Si es así, esta parte se ofrece a otros clientes para ayudar en su distribución.
Si no coincide, ha habido un problema de corrupción y toda la parte necesita ser descargada de nuevo. Para evitar descargar los 9.28 MB, la ICH descarga 180KB del comienzo de la parte y comprueba toda la parte de nuevo para ver si el Hash de Parte ahora es correcto. Si no es así, los siguientes 180 KB se descargan, se comprueban de nuevo etc. hasta que el Hash de Parte es finalmente correcto. En el mejor de los casos eMule solamente tiene que descargar 180 KB si la corrupción se encuentra justo al comienzo de la parte. En el peor de los casos toda la parte ha de ser descargado de nuevo si la corrupción se encuentra en la zona final de la misma. De media la ICH permite evitar descargar de nuevo el 50% de los datos cuando hay corrupciones.

AICH - (Advanced Intelligent Corruption Handling) Sistema Avanzado de Gestión Inteligente de la Corrupción
El sistema ICH normal es bastante efectivo, aunque tiene sus limitaciones ya que sólo se puede comprobar el bloque de 9.28 MB, no partes más pequeñas. Si más de una posición está corrupta o si algún cliente dañino envía datos corruptos continuamente o incluso falsifica todo un Hash de Parte, la ICH deja de ser efectivo.
Aquí es donde el AICH ayudará a obtener una integridad de los datos completa con un gasto mínimo de redescarga o de sobrecarga creando hashes mucho más pequeños.

Hash Raíz, Hashes de Bloques y Conjunto de Hashes AICH

Esta vez nuestro punto de partida son las partes de 9.28 MB en un fichero. Cada parte se divide en bloques de 180 KB, obteniendo 53 bloques en cada parte y para cada bloque se calcula un valor de hash empleando el algoritmo de hash SHA1. Estos valores se llaman Hash de Bloque y forman el nivel inferior en el Conjunto de Hashes AICH.

La imagen superior muestra cómo todo un árbol de hash se construye en base a los bloques de un fichero con 4 partes completas. Cada parte contiene 53 bloques por lo que obtenemos 212 Hashes de Bloque que constituyen un árbol de hash de 7 niveles hasta obtener el Hash Raíz. El árbol completo se llama Conjunto de Hashes AICH.
Los puntos verdes y amarillos muestran las dependencias matemáticas de los Hashes de Bloque más pequeños hacia el Hash Raíz. Esto significa que si tenemos un Hash Raíz de confianza el árbol entero puede verificarse con él.
eMule puede crear enlaces que contengan el Hash Raíz, ej.

ed2k://|file|nombre|12043984|6744FC42EDA527B27F0B2F2538728B3E|h=A2
NWOTYURUU3P3GCUB6KCNW3FTYYELQB|/

donde h= es el Hash Raíz. Este valor debería incluirse en los lanzamientos ya que mejora de forma significativa la resistencia a la corrupción del fichero al proporcionar un Hash Raíz de confianza. Lee Confiar en el Hash Raíz.

Reparando una corrupción
Cuando eMule detecta una corrupción en una parte solicita un Paquete de Recuperación de un cliente al azar que posea un Conjunto de Hashes AICH completo. Este Paquete de Recuperación contiene los 53 Hashes de Bloque de la parte corrupta y unos Hashes de Verificación del resto del árbol de hashes. La imagen superior muestra el Paquete de Recuperación para un fichero de 4 partes. El número de Hashes de Verificación se calcula en base al número de partes de un fichero (2^x >= 'número de partes', con x= Número de Hashes de Verificación).
Tras recibir el Paquete de Recuperación eMule comprueba los Hashes de Verificación con su Hash Raíz de confianza. Si coinciden, eMule comprueba los 53 bloques de la parte corrupta con los Hashes de Bloque del Paquete de Recuperación. El AICH restaura entonces todos los bloques que coincidan con su Hash de Bloque y deja únicamente el(los) bloque(s) corrupto(s) para descargar de nuevo.
Una reparación correcta se mostrará en el log de la siguiente forma:

09.09.2004 02:43:43: Parte descargada 6 corrupta sad.gif ([fichero])
09.09.2004 02:43:46: AICH recuperó 8.22 MB de 9.28 MB de la parte 6 del archivo [fichero]

Confiar en el Hash Raíz
La mejor opción es descargar de un enlace que contenga el Hash Raíz. Suponiendo que la fuente de este enlace sea de confianza el Hash Raíz se considera por tanto de confianza y se guarda para este fichero.
Si en el enlace no se proporciona un Hash Raíz entonces eMule tiene que llegar a confiar en el Hash Raíz, el cual se lo mandarán las fuentes de ese fichero. Solo confía en el Hash Raíz si al menos 10 fuentes diferentes envían el mismo valor y al menos el 92% de todas las fuentes coinciden en ese valor. Dado que este Hash Raíz no es realmente de confianza sólo es válido para la sesión actual y no se grabará a disco ni se pueden crear enlaces con dicho Hash Raíz..
Una vez que eMule construye el Conjunto de Hashes AICH completo, es decir cuando ha finalizado el fichero, comienza a enviar el Hash Raíz a otros clientes.

Notas:
• | Los ficheros recién lanzados o de ficheros difíciles de encontrar posiblemente no poseen suficientes fuentes completas para generar un Hash Raíz en el que confiar. Se recomienda distribuir los ficheros junto con el Hash Raíz.
• | Si no existe el Hash Raíz, o incluso aunque esté falsificado, eMule será capaz de descargar correctamente un fichero y finalizarlo en condiciones normales. La funcionalidad de AICH no podrá ser usada en este caso.
• | Dado que los Conjuntos de Hashes AICH son muy grandes no se guardan en memoria sino en el fichero known2.met y se leen únicamente cuando son necesarios..
• | El AICH sólo será efectivo para clientes eMule iguales o superiores a la versión 0.44a aunque mantiene compatibilidad con los clientes antiguos.

Resumen del Traductor:
Un fichero se divide en bloques de 9.28 MB que se denominan Partes, a cada parte se le aplica el MD4 y obtenemos su Hash de Parte (Part Hash). Si pones todos los hashes de Partes de un fichero juntos eso es el Conjunto de Hashes (Hashset). Si a este Conjunto de Hashes se le aplica el MD4 entonces se obtiene el Hash de Fichero (File Hash) que se usa en los enlaces eD2k.

A partir de la versión 0.44a del eMule existen unos nuevos tipos de Hash, comenzamos por las partes anteriores de 9.28 MB, las dividimos en 53 bloques y les aplicamos esta vez el SHA1, entonces obtenemos los Hashes de Bloque (Block Hashes). Estos Hashes se van combinando para obtener unos Hash parciales, y se siguen combinando hasta llegar a un solo hash combinación de todos los demás que es el Hash Raíz (Root Hash). El conjunto de todos los hashes que se han calculado es el Conjunto de Hashes AICH (AICH Hashset), que tiene una estructura de árbol. El Hash Raíz es el que se puede añadir a los enlaces eD2k a partir de la .44a, y sirve para verificar que los datos del Conjunto de Hashes AICH que nos envíe otro cliente son válidos.
Para detectar dónde se produce una corrupción en una parte le pedimos a un cliente que tiene el Hash Raíz correcto que nos envíe un Paquete de Recuperación, que contiene los 53 Hashes de Bloque de la parte que tenemos dañada, junto con otros Hashes de Verificación necesarios para comprobar que los datos que nos ha enviado son correctos y los podemos verificar con el Hash Raíz que tenemos.

Aplicable a: v.44a+

28.09.2004 13:15


579

 Mensajes de error

A client caused an unhandled error while receiving or processing a packet. Disconnect
Se detectó un error que fue causado por otro cliente conectado a ti. Lo peor que te puede ocurrir es que lo perderás como fuente.

Error fatal: imposible crear socket en el puerto 4662
Este error ocurre si otra aplicación está usando el puerto 4662 para realizar conexiones. La mayor parte de las veces ocurre cuando se usa a la vez eMule y eDonkey sin cambiar uno de ellos a un puerto diferente.
No es recomendable utilizar a la vez eMule y eDonkey o eMule y Overnet a no ser que se tenga el ancho de banda (de subida) para hacerlo.

ERROR: Your port 4662 is not reachable. You have a LOWID
eMule ha detectado que algo está bloqueando tu puerto 4662. Puede ser causado por cortafuegos o routers mal configurados. Lee las FAQ o busca en los foros para saber cómo configurar tu cortafuegos/router.

ERROR: Your port 4662 is not reachable. You have a LOWID http://www.edonkey2000.com/documentation/lowid.html ! Please correct your network config !
Este error es similar al anterior. No aparecerá en una ventana de Log sino en la ventana de Información del servidor. Este mensaje lo generan servidores parcheados por Lugdunummaster. Ver aquí para más información sobre parches Lugdunum.

Error fatal intentando la conexión. La conexión a Internet podría estar desactivada
La razón más obvia para que se produzca este error es que tu conexión se haya caído, pero también puede ocurrir cuando tu conexión a internet esté muy saturada o cuando estés usando el cortafuegos Zone Alarm, que parece que maneja varias conexiones bastante mal.

¡Error de versión del archivo part.met! (x.part.met => (null))
Un error grave ha ocurrido mientras eMule estaba escribiendo datos en un archivo .part.met. Estos son los archivos en los que eMule hace el seguimiento de las descargas temporales.
La causa de este error es una caída de Windows o de eMule. Para recuperar los archivos puedes intentar lo siguiente:

- Localiza los archivos en tu carpeta Temp. Si no puedes encontrarlos... mala suerte.
- Usa un programa como Known Metinator, DonkeyDoctor (en español, pero el programa y el foro de ayuda también está en inglés) o eD2k RecoverMET para reconstruir el archivo .met.
- También puedes probar arrancar eDonkey con tu actual carpeta Temp y tal vez pueda corregir el problema.
- Lee Resolución de problemas -> Descargas para más información.

Siempre sal de eMule antes de cualquier operación y no esperes demasiado. Es un error muy serio y hay muchas probabilidades de que tengas que descargar todo el archivo de nuevo.

El estatus de una descarga aparece como "Erróneo"
También un error de una operación con un archivo. Puede ocurrir cuando:

- eMule es incapaz de abrir un archivo .part.
Comprueba tu carpeta Temp en las Preferencias por si hay algún error
Comprueba si algún archivo en la carpeta Temp está protegido contra escritura
Reinicia eMule

- Completando una descarga o moviéndola a Incoming
Comprueba tu carpeta Incoming en las Preferencias por si hay algún error
Comprueba el espacio disponible en el disco duro de la carpeta Incoming
Reinicia eMule

Si nada funciona, sal de eMule, borra preferences.dat y known.met en la carpeta que instalaste eMule, y después reinicia.

El cliente 'xxx' (IP:xxx.xxx.xxx.xxx) causó un error: hash recibido corrupto o no válido. ¡Desconectando cliente!
Nada que puedas hacer por tu parte. Fue causado por otro cliente que te envió un hashset inválido ante la petición de una fuente.

Error: Imposible codificar el hash de la parte descargada - hashset incompleto (XXX). Esto no debería suceder nunca
Este error es un bug que puede ocurrir con archivos pequeños. Sin embargo nunca será completamente corregido. Puedes ignorarlo con tranquilidad.

Error de archivo escribiendo xxx : Error desconocido al acceder a ..\temp\yyy.part
Cuando eMule estaba intentando completar un archivo encontró un problema con el archivo .part. Posibles razones:

- una carpeta Temp o un archivo .part movidos.
- otro programa está accediendo al archivo (por ejemplo, un antivirus, otra aplicación p2p)

Comprueba la razones y reinicia eMule.

¡Versiontag no válida en server.met (0x3c)!
Hubo un error al cargar o actualizar el server.met. O bien un server.met no válido se actualizó de una URL o bien el server.met propio está corrupto. Prueba con otra URL para actualizar la lista de servidores y borra el archivo server.met si el error persiste.

An attempt was made to access an unnamed file past its end
Este mensaje aparece causado por paquetes inválidos de servidores o de otros clientes. Este mensaje no afecta al funcionamiento de eMule y las versiones .28a y superiores se han encargado de ello adecuadamente.

21.08.2004 16:30


580

 Enlaces eD2k

Los enlaces de internet de eD2k no se añaden a eMule
Si los enlaces de eD2k no se añaden a eMule cuando pinchas sobre ellos en el Explorador de Internet, es que el formato especial del enlace eD2k no está correctamente asociado. Comprueba el botón de Enlaces eD2k en Preferencias -> General. Si el botón está inactivo (en gris) puede ser que algunas entradas del registro de Windows se hayan estropeado. Descarga esta herramienta (por Resterampe) y elimina la antigua asociación, después pulsa el botón de Enlace eD2k otra vez..

Estas entradas de registro son las responsables del formato del enlace web:
HKEY_CLASSES_ROOT\ed2k\shell\open\command
Nombre: (Predeterminado)
Tipo: REG_SZ
Data: "Ruta a emule.exe (¡con las comillas!)" %1

y

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ed2k\shell\open\command
igual que arriba

Opera
Opera 7.2x y superior
Abre eMule. En Opera ve a Preferencias -> Programas y rutas -> Protocolos y presiona el botón de Añadir. En el menú de diálogo, introduce ed2k en el campo de Protocolo y la ruta a eMule aparecerá automáticamente en Abrir con aplicación por defecto. En caso contrario, la ruta correcta para eMule.exe tendrá que ser introducida en el campo Abrir con otra aplicación.

Antiguas versiones de Opera:
Para permitir que los enlaces web funcionen desde Opera, hay que editar un archivo de configuración en la carpeta de instalación de Opera. Cierra Opera y abre uno de los archivos en un editor, por ejemplo Bloc de notas.
Opera 6.x:
Añade la línea TrustedExternalURLProtocols=ed2k bajo [User Prefs] en el archivo Opera6.ini y guárdalo.
Opera 7.x:
Para Opera 7.x añade la misma línea en el archivo OperaDef6.ini.

Mozilla, Firefox
Necesitarás un plugin para asociar diferentes formatos como eD2k a los navegadores Mozilla o Firefox. Consigue mozex (enlace de descarga alternativo), abre las preferencias de tu navegador e introduce
ruta_a_eMule\emule.exe %r
en la casilla de edicion de eD2k del plugin de mozex..

por ejemplo: C:\Archivos de programa\eMule\emule.exe %r

12.09.2004 9:33


581

 Interfaz Web
Servidor web: Internet Explorer abre un diálogo de descarga en vez de mostrar la página
Para evitar este problema Usar HTTP 1.1 y Usar HTTP 1.1 en conexiones proxy deben estar activados en las Opciones de Internet Explorer. Ve a Herramientas -> Opciones de Internet -> Avanzadas: configuración de HTTP 1.1
20.08.2004 9:50


582

 Descargas

Tras una caída o cuelgue del sistema, alguna(s) descarga(s) pueden desaparecer repentinamente de la lista aunque sus archivos estén todavía en la carpeta Temp. Esto ocurre si un *.part.met se corrompe.

General
Sal de eMule antes de llevar a cabo alguna acción de recuperación.
Para asegurarte de que todo está adecuadamente ajustado comprueba Preferencias -> Directorios. Debe estar correctamente escrita la ruta de la carpeta Temp.

Copias de seguridad
eMule crea automáticamente copias de seguridad (*.part.met.BAK) de todos los archivos *.part.met. Si hay alguna diferencia en tamaño o en la Última modificación (click con el botón derecho del ratón sobre el archivo -> Propiedades) borra el archivo *.part.met y renombra la correspondiente copia de seguridad.

Herramientas de recuperación
El capítulo de Herramientas posee algunos enlaces a herramientas de recuperación. Haz una copia de seguridad de los archivos *.met y *.part antes de intentar recuperarlos. Los cambios no pueden deshacerse.

Movimiento manual
De forma poco frecuente, un archivo *.part.met está tan seriamente dañado que evitará que otros archivos se carguen. Añadiendo los archivos de uno en uno, se puede identificar la descarga dañada y eliminarla/recuperarla.

1. Mueve todos los archivos de la carpeta Temp a otra carpeta, como copia de seguridad
2. Mueve un *.part y el correspondiente *.part.met de nuevo a la carpeta Temp
3. Inicia eMule y comprueba si la descarga se añadió correctamente a la lista
4. Cierra eMule
5. Repite los pasos del 2. al 4. hasta que encuentres la(s) descarga(s) corrupta(s)
6. Intenta borrar o trata de recuperar las descargas corruptas con una herramienta de recuperación

12.09.2004 9:32


583

 Comportamiento anómalo
"Comportamiento Anómalo"

Si aparecen problemas al actualizar la lista de servidores o notamos que con frecuencia desaparecen los valores de nuestros ajustes, algunos archivos de configuración pueden estar corruptos. Esto ocurre especialmente tras caídas o tras actualizar desde versiones modificadas de eMule. Borrar todos los archivos *.met, *.ini y *.dat en la carpeta Config de eMule (¡¡no borres tus archivos temporales de descargas!!) puede ayudar con estos problemas. Sal de eMule antes de borrar estos archivos. Después de reiniciar, ajusta las opciones adecuadas en las Preferencias de eMule y reinicia de nuevo.

Nota de los traductores:
Ten en cuenta que el borrado de los ficheros *.met, *.ini y *.dat puede provocar la pérdida de los créditos obtenidos en tus descargas anteriores.
Recomendamos, en lo posible, no eliminar los ficheros 'clients.met' (créditos acumulados por otros usuarios) y/o los ficheros 'cryptkey.dat' y 'preferences.dat' (ficheros de identificación y autentificación necesarios para conservar los créditos obtenidos de otros usuarios)

20.08.2004 9:51


584

 Conexión a un servidor
Desconexión de un servidor poco tiempo después de conectarse
Muchos servidores limitan la cantidad de archivos compartidos. Si se alcanza esta cantidad, el cliente es automáticamente desconectado. eMule muestra el número de archivos compartidos en la página de estadísticas. Generalmente menos de 500 compartidos no causará problemas y asegura que todos los archivos serán aceptados.
Desde eMule v.28 el número de archivos aceptados se muestra en la lista de servidores. El valor del Límite de archivos bajo es el número de compartidos que un servidor publica, el resto de archivos que supere esa cantidad es ignorado. Cuando se alcanza el Límite de archivos alto el servidor desconecta al cliente.
Para prevenir las desconexiones, eMule v.29 y superiores únicamente publica el número de archivos permitido por el Límite bajo del servidor.
20.08.2004 9:52


585

 Lista negra

Los nuevos servidores Lugdunum parcheados p75+ tienen un sistema de créditos para juzgar el comportamiento de los clientes. Cada acción, como conectarse, buscar, pedir fuentes, etc. cuesta puntos de créditos. Si se agotan, el servidor se desconecta y envía un mensaje de advertencia de que el cliente está en la lista negra.
Esto es un problema especialmente cuando se están descargando más de ~30 archivos ya que a la fuente que pida todas estas descargas costará un montón de créditos, expulsando al cliente. eMule v.30a y superiores han tenido en cuenta este problema.
Información adicional sobre este tema en la página web de SilentBob.

Última actualización: Monk

20.08.2004 9:52


586

 Guía para principiantes
1. Descarga e instalación
Consíguelo aquí. Puedes escoger entre descargarte un instalador o solamente un archivo Zip con el ejecutable. Extrae el contenido del archivo a cualquier directorio que quieras y ejecútalo desde ahí.

Nota:
Si usas Windows98 es posible que te aparezca un mensaje diciendo que no se encuentra el archivo oleacc.dll. Esta dll es parte de las actualizaciones de MS para Windows 98.
2. Preferencias
Una vez que eMule haya arrancado ve a Preferencias. A continuación se describen solamente algunos de los parámetros importantes. Si deseas conocer más detalles sobre las opciones, consulta todo el manual.

- General

Alias.
Por favor, introduce un alias. El alias de http://emule-project.net es aburrido.
Asociar eMule con los tipos de enlace edk
Para que eMule reconozca los enlaces especiales en la web utiliza este botón [image]. Si el botón está deshabilitado eMule ya está correctamente asociado.
- Conexión
La ventana de conexión es la más importante del diálogo de Preferencias. Por favor, lee adecuadamente esta explicación.
Asistente
Para una configuración rápida puedes utilizar el asistente. Te ayudará a establecer unos valores iniciales adecuados.
o | Sistema operativo
Se recomienda usar un sistema operativo actualizado como Windows 2000 o XP ya que pueden manejar un gran número de conexiones mucho mejor que Windows 9x/ME
o | Descargas simultáneas
Este parámetro modificará el número máximo de Fuentes por fichero, no el número de ficheros que puedes descargar. Si tienes muchos ficheros en tu lista de transferencias, debes disminuir el número máximo de fuentes por archivo. Indica aproximadamente cuantos ficheros tendrás en tu lista.
Nota:
No añadas demasiados ficheros a tu lista de descargas. El valor de Fuentes encontradas en la ventana de estadísticas no debería ser superior a 3000. Demasiadas fuentes saturarán tu conexión al estar continuamente intentando conectar con todas ellas. Cuando despliegues una descarga en la ventana de transferencias y ves muchas veces Demasiadas conexiones en el estado de las fuentes, entonces tienes demasiadas fuentes para tu conexión. Reduce tu Límite máximo.
o | Tipo de conexión
Elige tu conexión entre los valores de la lista. Es importante que escojas el valor correcto para tu conexión. Si no se encuentra en la lista, escoge "Personalizar" e introduce los datos en las casillas para indicar tu ancho de banda. Recuerda que no es lo mismo kiloBits (kb/s) y kiloBytes (kB/s). Un Byte son 8 bits.
Pulsa Aplicar y habrás finalizado con el Asistente para la conexión.

- Directorios
En las Preferencias de Directorios puedes indicar la carpeta donde los ficheros completos se guardan (Archivos entrantes) y la ruta a los ficheros inacabados (Archivos temporales).
Las carpetas marcadas en Directorios compartidos son distribuidas en la red. Si quieres compartir múltiples subdirectorios utiliza la tecla CTRL y pulsa en la carpeta superior.

Nota:
Si estás cambiándote de eDonkey2000 a eMule indícale que utilice la misma ruta de Archivos entrantes y temporales que en eDonkey. Los ficheros se añadirán automáticamente en el próximo inicio de eMule.
3. | Servidores
Los servidores son necesarios para poder acceder a la red. En el primer inicio es importante usar una lista de servidores actualizada.
La manera más fácil de actualizar tu lista de servidores es emplear la casilla "Actualizar server.met desde URL" en el eMule. Mira aquí para obtener más detalles sobre actualizar tu lista de servidores.
Hay muchos sitios web que proporcionan buenos ficheros server.met, pero para un inicio rápido copia esta dirección
http://ocbmaurice.dyns.net/pl/slist.pl?download/server-good.met

a tu portapapeles y pégala en la casilla de actualización, tras eso pulsa el botón de actualizar. Gracias a Maurice por proporcionar este servicio de listado de servidores.
El número de servidores que se han añadido a tu lista se muestra en el tab de Servidores, en la zona de Registro.
4. | Conectando a un servidor
Cuando has actualizado tu lista de servidores, pulsa el botón de Conectar [image] en la esquina superior izquierda.
Una vez que te hayas conectado correctamente a un servidor, la barra de estado en la parte inferior del emule será parecida a esta:

Importante:
Indica una Id Alta. Todo está bien.
Si te muestra este icono cada vez que te intentas conectar entonces tienes una Id baja, y deberías leer acerca de la ID, cortafuegos (firewalls), y Routers en la Ayuda y Preguntas comunes.
5. | ¡Ya está!

Ahora puedes comenzar a descargar bien a través de una búsqueda directa dentro del eMule (utiliza la búsqueda Global si no consigues el resultado que quieres), a través de una búsqueda en la web con algún motor de búsqueda o mediante algún sitio dedicado a publicar enlaces edk.
6. | Cosas adicionales que deberías saber
o | Explicación de los iconos del eMule
o | Colores en la barra de descargas
o | QR - Queue Ranking: Posición en las colas
o | Si quieres tener una buena velocidad de descarga añade ficheros con muchas fuentes. Ficheros que tienen menos de 100 fuentes se pueden considerar poco frecuentes y les puede costar un tiempo descargarse. ¡Ten paciencia!
o | eMule descarga más rápido cuanto más tiempo se esté ejecutando. No esperes que nada más iniciarse se ponga a descargar a toda velocidad.
o | Esta red está diseñada para ficheros grandes. Por favor, no compartas un gran conjunto de ficheros pequeños (canciones). Esto supondrá una carga excesiva sobre los servidores.
o | Serás recompensado al compartir
¡Diviértete con tu eMule!

09.10.2004 8:09


587

 Guía sobre las redes
A partir de la versión 0.42a de eMule, éste dispone de dos redes posibles - la red clásica basada en servidores eD2k y una red completamente nueva que carece de servidores y está basada en Kademlia.
En esencia ambas redes tienen las mismas funciones. Ambas proveen de medios separados para conseguir encontrar a otros usuarios o los ficheros que te quieres descargar.

Conceptos básicos
Identificación de ficheros
Todos los ficheros tienen un valor de hash. Este hash es una combinación de números y letras que son capaces de identificar de forma única a un fichero. Un fichero puede tener múltiples nombres, pero esto no cambia su valor de hash. Esto permite que cada usuario encuentre todas las fuentes para un fichero en particular sin importar que alguien le haya cambiado el nombre al mismo.
Además, los ficheros se separan en bloques de 9,28 MB. Cada parte a su vez también tiene un valor de hash. Por ejemplo un fichero de 600 MB contiene 65 partes, entonces a cada una de las partes se le asigna un valor de hash, y el hash del fichero se obtiene a partir de los hash de estas partes, para de esta forma poder compartir el fichero en las redes.

Identificación de otros clientes
Como el hash de los ficheros, cada usuario en la red obtiene un hash de usuario único y permanente (no confundir con el ID). Esta identificación de usuario se halla protegida mediante un algoritmo de encriptación de clave pública para evitar usos incorrectos.

Descargando datos
Es importante entender que las descargas en el eMule no se ven afectadas por la elección de la red. La topología de la red (con o sin servidores) sólo afecta al método de búsqueda de ficheros y de clientes que sean fuentes para tus descargas.
Una vez que se encuentra a una fuente, tu cliente contacta con ella. La fuente entonces le reserva un puesto en su cola para esa descarga, cuando alcanzas la primera posición en su cola tras haber esperado apropiadamente entonces puedes descargar de él.

Red clásica eD2k basada en servidores
Conectando a la red
El elemento clave de esta red son los servidores eD2k. Cada cliente se debe conectar a un servidor para poder entrar en la red.
Cuando conectas tu cliente a un servidor, el servidor comprueba si otros clientes van a poder conectarse directamente contigo. Si es así, el servidor le asigna a tu cliente lo que se llama una "Id alta". Si la comunicación se encuentra bloqueada, entonces el servidor te asigna una "Id baja".
Una vez que se te ha asignado la ID, eMule mandará la lista de tus ficheros compartidos al servidor. El servidor añade los datos sobre los archivos que le has enviado a su base de datos.

Buscando ficheros
Una vez que te has conectado a la red, el cliente puede buscar ficheros basándose en palabras clave. Una búsqueda puede ser bien local o global. Si es local (busca sólo en el servidor en el que estás conectado) las búsquedas son más rápidas, pero pueden ofrecer menos resultados. Si la búsqueda es global (busca todos los servidores de la red), le costará más pero obtendrás más resultados. Cada servidor busca las palabras en su base de datos local y devuelve una lista con los nombres de los archivos (y sus valores de hash) que se ajustan a esa búsqueda.

Encontrando fuentes para los ficheros
Las descargas se pueden añadir mediante la función de búsqueda del eMule o a través de enlaces eD2k ofrecidos en muchas webs.
Una vez que están en tu lista de descargas, eMule primero contacta con el servidor al que estás conectado y posteriormente al resto de los servidores de la red buscando fuentes para esa descarga en particular. El servidor busca ese hash en su base de datos y devuelve los clientes que él sabe que poseen dicho fichero.
Solo pueden ser fuentes válidas aquellos clientes que hayan descargado al menos una parte entera (9,28 MB) del fichero (la Última parte puede tener un tamaño menor).

Red sin servidores Kademlia
Conectando a la red
Lo único necesario para poder conectar a esta red es la dirección IP y el puerto de cualquier otro cliente eMule que ya esté conectado. Esto es lo que se llama "Autoarranque" (bootstrap).
Una vez que el cliente se ha conectado a la red, el cliente consulta con otros clientes para ver si pueden conectarse directamente con él sin problemas. Este proceso es muy similar a la comprobación de ID alta/baja de los servidores. Si pueden contactarte sin problemas se te asigna una ID (similar a una ID alta) y se dice que tienes un estado "abierto". Si no pueden contactar contigo entonces se te asigna un estado "Tras cortafuegos". Desde la versión v.44a en adelante, la red Kademlia soporta un Mediador para los usuarios tras un cortafuegos (firewall). Los Mediadores son otros clientes de Kademlia que tienen estado abierto y actúan como punto de contacto para aquellos usuarios que están tras cortafuegos y por tanto no son accesibles directamente.

Búsquedas en Kademlia
En esta red no importa lo que busques. Da igual que sea una búsqueda de archivos, de fuentes para una descarga o bien de otros usuarios, todas funcionan de una forma similar.
No existen servidores que hagan un seguimiento de los clientes y los ficheros que comparten, por lo que es una labor que la hace cada cliente que se conecta a la red - en esencia, cada cliente es un pequeño servidor.
Dado que cada cliente es identificado de forma única mediante un valor de hash, la idea de Kademlia es asociar una cierta "responsabilidad" en base a ese hash. Cada cliente de la red Kademlia trabaja como un servidor para ciertas palabras clave o fuentes. El hash del cliente determina dichas palabras o fuentes.
Por tanto el objetivo de cualquier búsqueda es encontrar a aquellos clientes que tienen la responsabilidad para el término de búsqueda actual. Esto se consigue mediante un cálculo complejo acerca de la posible distancia al cliente destino y preguntando a otros clientes cual será la ruta más corta hasta él.

Resumen
Ambas redes tienen un concepto totalmente distinto de conseguir lo mismo: Buscar ficheros y buscar fuentes para los ficheros. El principal objetivo de la red Kademlia es ser totalmente independiente de los servidores y facilitar la escalabilidad. Los servidores sólo pueden aceptar un cierto número de clientes y si un servidor grande deja de funcionar la red se resiente gravemente.
Kademlia es una red autoorganizativa y se ajusta a sí misma para obtener el mejor rendimiento posible en base al número de usuarios y la calidad de sus conexiones. Por tanto es más resistente a daños a gran escala en la red.

Se aplica a la versión .42a+
28.09.2004 13:55


588

 Herramientas
Herramientas para el eMule y utilidades:
MetMedic | Herramienta para editar ficheros .met y recuperar descargas desaparecidas
DonkeyDoctor | Herramienta de recuperación. Fácil de usar.
eD2k RecoverMET | Herramienta en línea de comandos para la recuperación de ficheros part.met (enlace eD2k)
eD2k Link Killer | Limpia asociaciones incorrectas de enlaces eD2k en el registro.

Herramientas varias y utilidades:
Test de conexión | Página de TheDonkeyNetwork para verificar si el puerto de tu cliente está abierto
Online Signature | Modifica imagenes con los datos de onlinesig.dat. Mira Firma en línea
New Online Signature | Web alemana que está desarrollando la aplicación Online Signature
AC-Plug | Conecta con internet de nuevo si el modem pierde la conexión
VideoLAN Client | Modo alternativo de previsualizar archivos multimedia. Mira en Preferencias -> Directorios
RASPPPOE | Driver PPPOE para DSL de marcado por Robert Schlabbach
WinSockFix | Herramienta para reparar los Winsocks de Windows.
LSPFix | Herramienta para reparar los Winsocks de Windows.

Si conoces alguna otra buena herramienta relacionada con eMule manda un mail (en inglés) a Monk@emule-project.net y lo añadiré a esta página.

21.08.2004 16:43